Unable to complete Tracklist

Tags: #<Tag:0x00007f757c3f1620> #<Tag:0x00007f757c3f0d38> #<Tag:0x00007f757c3f61c0>

I’m trying to enter the 2016 SXSW Artist Showcase, which has 1006 tracks in the first part. I put the Part 1 files in Picard and used a plugin to copy tracklist info. I made a new release, and when I got to the tracklist I pasted the information from the plugin. I wond up with 973 tracks (I plan to add the missing 33 later), but I can’t get past the Tracklist. At first I was expecting the old behavior where I would move to the next page and resolve the artist for each track. Realizing it’s all done on the tracklist page now, I spent hours going through each artist to ensure they were recognized or added as a new artist. I now have 973 tracks with green artists and completed track titles, but I still show the error “You must enter a title and select an artist for every track.”

I’ve scrolled through the tracklist several times, and I’m certain all of the artists are green. The title fields are filled, too, although they are still white. What else can I do to get past this error and save the release? I’d hate to lose all the work I’ve put in so far, and naturally will not work on Part 2 until Part 1 is resolved.

2 Likes

There might be an empty row in one of the artist credits (MBS-8067).

Thanks, I guess I’ll go through the 973 artists to see if that’s the case.

973 clicks later, no luck. The only tracks with two lines are those with correct (green) artists on line 2. None were like the linked bug. Any other ideas?

You might also want to look into the “Add Cluster As Release” plugin which will seed the “Add Release” form with information from the tags (incl. sub-second precision track times…).

1 Like

Well, that’s strange and unfortunate for you, @doomedtx
Make sure the first (Release Information) and third tab (Recordings) are green as well.
Only the Tracklist tab is red ?

I have had some issues with release editor at times, making me having to reload it (loose all ongoing edits).
I hope you can avoid that. It never happened to me with so many edited data.

Maybe @Bitmap has an idea or can tell you how to dump the current RE contents into a file at least.

Thanks, I added it both with the “Add Cluster as Release” and “Copy cluster to clipboard” plugins. I was hoping one would work better than the other, but they both resulted in the same thing: 33 missing tracks, and 973 unrecognized tracks that I have to manually search each artist.

Yep, that’s the only red tab. I tried importing the list into the beta site just in case it was different. It wasn’t.

I think I passed my limit on how much time this problem was worth sometime yesterday, and then I still dedicated a few more hours to solving it. In any event, here is the 973-song tracklist in case someone else cares to try. I planned to import the release into Picard and use it to identify the 33 missing tracks, but I can’t do that now and won’t be looking through all 1006 to find which ones didn’t make the import. http://pastebin.com/KFbP4XUv

I’m not going to bother with the Part 2 tracklist. It’s been years since I contributed a VA release, and I didn’t realize there’s now no auto artist lookup. I’m not doing another 500+ clicks only to find out I can’t get past the system again. Thanks for trying to help.

2 Likes

There are 1006 lines in that list, but many numbers (between 2 and 93) are used multiple times. E.g., there are six tracks numbered 2, and seven tracks numbered 3.

5 Likes

Good catch, I hadn’t noticed that before because I didn’t look back through the list once I pasted it. However, after parsing the list and pressing “Reset track numbers,” those duplicate tracks were all removed from the list and I was left with 973 entries. I’m trying it again because I’m curious if fixing those duplicate numbers will fix the import. Also I’m wondering how both plugins managed to number the tracks that way. Odd.

UPDATE: This is the 4th total time I’ve imported that same tracklist in the pastebin, only this time I have 1006 tracks instead of 973. Maybe those 33 tracks were in the code somewhere but not visible to me. And it looks like the tracklist isn’t red, without me manually making all 1006 green! I guess I’ll try again after all :slight_smile:

4 Likes

And there was much rejoicing! I don’t know why my first three attempts failed, but after going through all 1006 artists to turn them green (didn’t work quickly like I thought it might), the release entered!

8 Likes

Greatest congratulations!
@doomedtx, I think you deserve a trophy :trophy: of some sort! :clap: :bow:

2 Likes

WHAT!? :scream:
And it’s only the Part 1!? :astonished:

1 Like

Yes, and I’m working on 587 tracks from part 2 now :slight_smile:

4 Likes

All I have to say is…
GOOD JOB

:muscle: :muscle: :muscle:

2 Likes

Same happened to me today.

With my user script engine (Violentmonkey) completely disabled.

  1. Submit TOC from Picard
  2. New release by artist
  3. Type any release title in first tab
  4. Tracklist tab : Track parser : Lines start with a track number ; Lines contain track artists ; Use track artists ; Use track titles
    Here you see that it has not taken account your track artists. It has kept the green release artist only everywhere
  5. Click Edit Note tab

Then you can’t submit because red Tracklist tab « You must enter a title and select an artist for every track. » — with or without artist fix after step 4 — despite checking all artists are green.

I have to abandon my release. :confused:
Seems similar to this cause.

Updated some stuff, it was not related to Search→Replace.
☞ c/w MBS-9292

It’s the same if I submit the release by title, then fill in artist name in first tab.

The problem is systematic:

Picard’s Lookup CD + Add a new release + Track Parser’s Use track artists = Track artists are not used + You must enter a title and select an artist for every track.

Shall I create another ticket than MBS-9292 as there is a strictly Track Parser issue on new releases, even when not using any seeding?

I seem to have run into this. I got two CDs in the post today, successfully added one (single artist) and then tried to add a various artists release, but I’m told “You must enter a title and select an artist for every track” even though every track has both. I removed the medium, then saved the release and tried adding it manually, but I get the same result. I also tried removing the disc id, but that doesn’t seem to make any difference.

Should I delete the whole thing and start again?

1 Like