Unable to complete Tracklist

IIRC, the bug was only triggered when using the track parser button with its Use track artists.
Simply fill in titles and artists without using the track parser and you will be able to submit your release add.

Maybe now that your medium-less release does exist, you can manually add medium before submitting your Disc ID to it.

I already tried adding a new medium and get the same result.

I didn’t originally use the track parser, but I did open it at some point.

1 Like

OK, I tried adding a medium again, making sure I added nothing to the track parser and “Use track artists” was definitely unchecked.

I still get the same error.

1 Like

When you add artists in the tracklist, are all artist boxes green, not red?

I did the test in your release without submitting it.

I have just used Add Medium button and had to use track parser to type some track names there (it is not important as it can still be edited later in the tracklist):

Test 1
Test 2

I unchecked the track number and track artist options and clicked the popup Add Medium button to confirm:

Then I entered some track artists manually in the tracklist:

You see, it’s all green and I get no error messages on any tabs.

1 Like

Mine weren’t green or red, just white.

I didn’t type anything in the Track Parser—is that important?

I unchecked track artist, but I don’t think I unchecked track number. It’s mystifying why this should matter though.

Please show a screen capture of your white artist fields.
Usually they are whit until you type anything inside.
Type something inside track artist fields then, if the artist search does not automatically trigger, click the magnifying glass and pick an artist.
Another way to directly select your desired artist is to paste its full URL in the artist field.

I think I’ve figured it out. None of these are existing artists, but I didn’t see the “Add a new artist” at the bottom of the drop-down list. It wasn’t visible without scrolling and the other text seemed to be the end of the list. I wouldn’t expect to find a button in a drop-down list either.

If you click Done without adding a new artist the entries appear with a white background.

Successfully added the tracks now.