Master thread: Is my IP blocked / IP blacklisted / VPN blocked / QNAP / Can't connect to / Picard doesn't work on home network

mod edit: please use this thread to enquire about any IP/connection issues

I’m a relatively new user of Musicbrainz and an expert in tech (I know the basic and can generally figure most things out with a little research). I had used Picard about a year ago fine. For some reason when I’ve tried it again, Picard isn’t checking my music. Additionally, I can’t access the website. I know the website is up because I can access it using a VPN and on my mobile device when I’m not on wifi. Any help would be appreciated.


Do you happen to have a QNAP NAS?

1 Like

Check your messages, i need your IP to check, but i guess it is blacklisted.

Thanks for getting back to me. My IP address is:

This IP was in the blacklist, I removed it, you should be able to access our services now.

Do you own a QNAP device ?

Sorry for the inconvenience.



Hi there,

Thanks for doing that. I’ll check when I’m back at home. Yes, I do own a QNAP device. Will that effect it? Is there something I can do to ensure it doesn’t happen again?

That’s a long story, but basically QNAP devices are querying our webservice abusively, currently 70% of the incoming traffic is from such devices, but the bad thing is that most users aren’t aware of it, and it doesn’t serve any purpose (users don’t complain at all when we block those queries at http level).

But we are now blocking at IP level, to spare more bandwidth, so only legit and regular users of MusicBrainz having a QNAP device actually complain, and we whitelist them.

The whole story is at


Thanks Zas. It works now. Appreciate your help with this.


My problem is the same. I have a Qnap NAS and I cannot access My IP is Could you help me?

Your IP was in the QNAP blacklist, i removed it, you should be able to access our services again.
Sorry for the inconvenience.

1 Like

It works, thanks for your help

Hi Zas,

I also have the same problem - IP address is I don’t have a QNAP NAS but have a ddwrt router with a NAS. I can’t access your website through this IP address, but can do so through my phone as a wifi hotspot.

Best wishes,


I unblacklisted your IP, you should be able to access all our services again now.
Sorry for the inconvenience.

Hi Zas,

I think I’m having a similar issue where I can’t access musicbrainz from my home network and I have a QNAP device at home. Any chance I can get help with this? My IP is


Sorry for the delay, i totally forgot this post. This IP was in the blacklist, now (finally) removed.

1 Like

I am having the same issue and I also do not have a QNAP device. The problem is, that I do not have a native IPv4 due to the fact that my ISP is using DS-Lite. This means, that I share the same IP with many users. However, I do have a static IPv6, but I assume that your IP-blacklist is based on IPv4, right?

1 Like

I am having the same problem, I can access the site with my phone but not from home, my address is

Your IP ( was in a public spam/abuse blacklist (like those provided by honeypot project, etc…), it isn’t anymore (i just updated those lists).
So, you should have access to our services from this IP.

Sorry for the inconvenience.

I’m still not able to connect to My IP is: However, as I said before this IP is shared by hundreds of users due to DS-Lite. Please find a solution for that. I am really missing Musicbrainz Picard.

Your IP was in the QNAP devices blacklist, it is now whitelisted.
You should be able to access all our services again.
Sorry for the inconvenience.