Unable to complete Tracklist

Thanks, I added it both with the “Add Cluster as Release” and “Copy cluster to clipboard” plugins. I was hoping one would work better than the other, but they both resulted in the same thing: 33 missing tracks, and 973 unrecognized tracks that I have to manually search each artist.

Yep, that’s the only red tab. I tried importing the list into the beta site just in case it was different. It wasn’t.

I think I passed my limit on how much time this problem was worth sometime yesterday, and then I still dedicated a few more hours to solving it. In any event, here is the 973-song tracklist in case someone else cares to try. I planned to import the release into Picard and use it to identify the 33 missing tracks, but I can’t do that now and won’t be looking through all 1006 to find which ones didn’t make the import. http://pastebin.com/KFbP4XUv

I’m not going to bother with the Part 2 tracklist. It’s been years since I contributed a VA release, and I didn’t realize there’s now no auto artist lookup. I’m not doing another 500+ clicks only to find out I can’t get past the system again. Thanks for trying to help.

1 Like

There are 1006 lines in that list, but many numbers (between 2 and 93) are used multiple times. E.g., there are six tracks numbered 2, and seven tracks numbered 3.


Good catch, I hadn’t noticed that before because I didn’t look back through the list once I pasted it. However, after parsing the list and pressing “Reset track numbers,” those duplicate tracks were all removed from the list and I was left with 973 entries. I’m trying it again because I’m curious if fixing those duplicate numbers will fix the import. Also I’m wondering how both plugins managed to number the tracks that way. Odd.

UPDATE: This is the 4th total time I’ve imported that same tracklist in the pastebin, only this time I have 1006 tracks instead of 973. Maybe those 33 tracks were in the code somewhere but not visible to me. And it looks like the tracklist isn’t red, without me manually making all 1006 green! I guess I’ll try again after all :slight_smile:


And there was much rejoicing! I don’t know why my first three attempts failed, but after going through all 1006 artists to turn them green (didn’t work quickly like I thought it might), the release entered!


Greatest congratulations!
@doomedtx, I think you deserve a trophy :trophy: of some sort! :clap: :bow:


WHAT!? :scream:
And it’s only the Part 1!? :astonished:

1 Like

Yes, and I’m working on 587 tracks from part 2 now :slight_smile:


All I have to say is…

:muscle: :muscle: :muscle:


Same happened to me today.

With my user script engine (Violentmonkey) completely disabled.

  1. Submit TOC from Picard
  2. New release by artist
  3. Type any release title in first tab
  4. Tracklist tab : Track parser : Lines start with a track number ; Lines contain track artists ; Use track artists ; Use track titles
    Here you see that it has not taken account your track artists. It has kept the green release artist only everywhere
  5. Click Edit Note tab

Then you can’t submit because red Tracklist tab « You must enter a title and select an artist for every track. » — with or without artist fix after step 4 — despite checking all artists are green.

I have to abandon my release. :confused:
Seems similar to this cause.

Updated some stuff, it was not related to Search→Replace.
☞ c/w MBS-9292

1 Like

It’s the same if I submit the release by title, then fill in artist name in first tab.

The problem is systematic:

Picard’s Lookup CD + Add a new release + Track Parser’s Use track artists = Track artists are not used + You must enter a title and select an artist for every track.

Shall I create another ticket than MBS-9292 as there is a strictly Track Parser issue on new releases, even when not using any seeding?

I seem to have run into this. I got two CDs in the post today, successfully added one (single artist) and then tried to add a various artists release, but I’m told “You must enter a title and select an artist for every track” even though every track has both. I removed the medium, then saved the release and tried adding it manually, but I get the same result. I also tried removing the disc id, but that doesn’t seem to make any difference.

Should I delete the whole thing and start again?

1 Like

IIRC, the bug was only triggered when using the track parser button with its Use track artists.
Simply fill in titles and artists without using the track parser and you will be able to submit your release add.

Maybe now that your medium-less release does exist, you can manually add medium before submitting your Disc ID to it.

I already tried adding a new medium and get the same result.

I didn’t originally use the track parser, but I did open it at some point.

1 Like

OK, I tried adding a medium again, making sure I added nothing to the track parser and “Use track artists” was definitely unchecked.

I still get the same error.

1 Like

When you add artists in the tracklist, are all artist boxes green, not red?

I did the test in your release without submitting it.

I have just used Add Medium button and had to use track parser to type some track names there (it is not important as it can still be edited later in the tracklist):

Test 1
Test 2

I unchecked the track number and track artist options and clicked the popup Add Medium button to confirm:

Then I entered some track artists manually in the tracklist:

You see, it’s all green and I get no error messages on any tabs.

1 Like

Mine weren’t green or red, just white.

I didn’t type anything in the Track Parser—is that important?

I unchecked track artist, but I don’t think I unchecked track number. It’s mystifying why this should matter though.

Please show a screen capture of your white artist fields.
Usually they are whit until you type anything inside.
Type something inside track artist fields then, if the artist search does not automatically trigger, click the magnifying glass and pick an artist.
Another way to directly select your desired artist is to paste its full URL in the artist field.

I think I’ve figured it out. None of these are existing artists, but I didn’t see the “Add a new artist” at the bottom of the drop-down list. It wasn’t visible without scrolling and the other text seemed to be the end of the list. I wouldn’t expect to find a button in a drop-down list either.

If you click Done without adding a new artist the entries appear with a white background.

Successfully added the tracks now.