New cover art not loading


#1

This morning I added a cover art picture to the following release

The cover art shows correctly on the web page for the release, but Picard will not load the picture when I try to tag the album. The error log includes the following report:

E: 21:12:33 Network request error for https://ia801509.us.archive.org:443/18/items/mbid-0f7424ce-24a1-479d-a1b6-5f7c37febf61/index.json: Error downloading https://ia801509.us.archive.org:443/18/items/mbid-0f7424ce-24a1-479d-a1b6-5f7c37febf61/index.json - server replied: Not Found (QT code 203, HTTP code 404)
E: 21:12:33 CAA JSON error: Error downloading https://ia801509.us.archive.org:443/18/items/mbid-0f7424ce-24a1-479d-a1b6-5f7c37febf61/index.json - server replied: Not Found

Based on the discussion in a seeming related post (see below), I waited now about 10 hours for the problem to resolve on its own, but so far this has not happened.


Cover Art Problems
Failed cover art upload, what now?
Incomplete records in CAA?
#2

It sounds like you might still have the Download only approved mages box checked in the Cover Art Archive section of the configuration options.

This is checked in the default settings originally applied, and will only download images once the edit to add them in MusicBrainz has passed. If it’s checked, try again after unchecking it and see if that helps.


#3

No, that was already unchecked.

From the error report, Picard seems to be trying to download a file from archive.org that does not exist:

https://ia801509.us.archive.org/18/items/mbid-0f7424ce-24a1-479d-a1b6-5f7c37febf61/index.json


#4

Okay, I’ve seen that on occasion. It appears to be a situation where the image file hasn’t yet been replicated to the download mirrors. When that happens here, after doing the lookup (or whatever) to populate the information in the right side panel in Picard, I just drag a local copy of the image file onto Picard and it uses that for the tagging.


#5

Hey there,

i have a similar problem, picard doesn’t load various cover artworks i uploaded during the past week.

So this is how it looks like (in the back, you can see that the release page displays the artwork):

and in this case, the cover art isn’t displayed for some days now:

now could there have been a problem, with the cover art archive, that is resolved now, and i could cancel the uploads and retry it now?

thanks!


#6

(New forum theme here? Compose box looks different.)

Anyway, appears something has been weird at IA/CAA last week. For example, http://ia801904.us.archive.org/4/items/mbid-092fdbdb-cb5e-422d-bd57-04442d1086a2/index.json doesn’t reflect a bunch of edits that were approved at 16:00 today (it’s 21:37 here now). The first image (18411439759) should be approved (same with all the others), and the second one (15815751194) has been deleted — so it shouldn’t be there at all.


Album artwork help needed
#7

@XonE - I came into this forum for my first post for a similar reason to you. Yesterday I scanned a CD and uploaded the artwork for https://musicbrainz.org/release/c4119c02-3e57-4b52-a8f2-49b5e81b6b83.

Yet when I look, it says “Image not available yet, please try again in a few minutes.”. Click on the “original” link and the art is clearly there. What is missing are the smaller versions to be shown on the Musicbrainz page itself.

Picard is also failing to acknowledge the new artwork.

Is this because they are still waiting for votes? The one image visible on that page is also due to be removed to be replaced by my cleanly scanned set.


#8

I think there are multiple problems with cover art feature.

404 Error in Picard
I also opened a thread here because of 400 Errors in Picard: Red CD / circle on edited releases / 404 for archive.org requests I also created a bug ticket but it looks like that project isn’t maintained https://tickets.metabrainz.org/browse/CAA-104 ? The bug is open since October. Also all the other bugs in this project. By now I put the picture with mp3Tag tool manually after editing in Musicbrainz. With Picard it’s still work only infrequently.
UPDATE: he requests a index.json document, thats doesn’t exist. This is the problem.
E: 18:55:21 CAA JSON error: Error downloading https://ia801504.us.archive.org:443/16/items/mbid-d57eac86-a8f5-43b1-b201-80c1ebc0be1f/index.json - server replied: Not Found

Pictures are uploaded but not processed
Like this edit I did 30 hours ago https://musicbrainz.org/release/a90dc100-26ef-4a6a-af5e-f02625d98717/cover-art Could be, that this error has to do with first problem.
UPDATE: Should be a other problem. For example this not short time ago edited release https://musicbrainz.org/release/d57eac86-a8f5-43b1-b201-80c1ebc0be1f/cover-art has all processed versions (200px, 500px and original) but in Picard I get still 404 message.

Any red error message in web interface on uploading
Round about every 10th updload fails for me. Than I have to click upload again. Sometimes once, sometimes several times…
UPDATE: also described here: Random "⚠ Error uploading image"

And now?
Could be, that there are still more problems. The question ist - who will fix the bugs. Who is the maintainer?

Look also on this post:


#9

Same here with https://musicbrainz.org/release/ce86eb98-c3b2-4186-9d56-8cbc9d7710f7/cover-art — hasn’t processed uploads from last night. :frowning:


#10

Despite the confidence inspiring graphic design of the website, the truth is that Musicbrainz is still very much in development. The basics work really well in capturing and storing high quality meta-data. But there are delays, inconveniences, missing features.
As I understand things, all bugs, feature requests and development requests are put into the ticket system.
Then a team of largely volunteer coders decide what is highest priority or what suits their individual skill set or area of interest, and get to work on it.

When I manage to keep Musicbrainz framed as “a project in development, to which I contribute” then the delays in getting Cover Art, areas of clunkiness and development routes prioritised are understandable. (On my good days anyway.)


#11

I got the same problem. Even with applied yes votes to cover art and shown art on web front end picard can’t load the new images. Example:


Picard Errorlog:
E: 15:34:15 Network request error for https://ia801505.us.archive.org:443/29/items/mbid-eebc0a34-9240-4b7c-a6c9-3ffa7ace73b1/index.json: Error downloading https://ia801505.us.archive.org:443/29/items/mbid-eebc0a34-9240-4b7c-a6c9-3ffa7ace73b1/index.json - server replied: Not Found (QT code 203, HTTP code 404)
E: 15:34:15 CAA JSON error: Error downloading https://ia801505.us.archive.org:443/29/items/mbid-eebc0a34-9240-4b7c-a6c9-3ffa7ace73b1/index.json - server replied: Not Found

For another one no cover art at all is shown:

Picard Errorlog:
E: 13:03:51 Network request error for http://coverartarchive.org:80/release/b1187aad-4a75-3fa3-9859-73acdc9f9cd0/1356503896-500.jpg: Error downloading http://coverartarchive.org:80/release/b1187aad-4a75-3fa3-9859-73acdc9f9cd0/1356503896-500.jpg - server replied: NOT FOUND (QT code 203, HTTP code 404)
E: 13:03:51 Coverart error: Error downloading http://coverartarchive.org:80/release/b1187aad-4a75-3fa3-9859-73acdc9f9cd0/1356503896-500.jpg - server replied: NOT FOUND

Much more examples could be found on my collection:
https://musicbrainz.org/collection/a26f5d10-727e-473a-a221-3df20d60ffc3

My experiences:

  • Completely new cover art uploads works fine.
  • Reordering/Deleting and adding new cover art for existing makes problems; especially when uploads fail with “:warning: Error uploading image”.

#12

Still fails after nearly four weeks for this releases:







If someone could cross-check? I don’t believe those will work in future. There went something wrong at CoverArtArchive. The only idea I have is to remove all cover art for those releases, wait, and add them from the scratch. Any other suggestions are welcome…


#13

The first in that queue has thumbnails showing for all Cover Art.
Mer de Noms the same.
The rest are missing all or some thumbnails. As in “Image not available …”


#14

Yes, on the web for this two all cover art is there and still they doesn’t load into Picard:


Error message:

CAA JSON error: Error downloading https://ia601509.us.archive.org:443/1/items/mbid-24d2b9a8-2354-37d0-9130-9afbebf2e53f/index.json - server replied: Not Found

image
Error message:

CAA JSON error: Error downloading https://ia801505.us.archive.org:443/29/items/mbid-eebc0a34-9240-4b7c-a6c9-3ffa7ace73b1/index.json - server replied: Not Found


#15

A lot of the cover art I uploaded in the last half of November 2017, is missing the “index.json” file in the directory with the actual images, and XML index, and torrent file, and stuff. Musicbrainz doesn’t use that file (because it keeps track of images inside of itself) so it will display the cover art just fine. But Picard apparently uses “index.json”, and so fails with this (example) error:

CAA JSON error: Error downloading https://ia800104.us.archive.org:443/18/items/mbid-a89efc39-cc91-441f-b9b3-c0a06d3e10ad/index.json - server replied: Not Found

All of the JPGs and stuff are there, just not the index.json. As an experiment, I uploaded some new cover art, to see if the CAA would regenerate the index.json file… and… it didn’t.

These files are new or regenerated:
mbid*_meta.sqllite
mbid*_files.xml
mbid*_archive.torrent
mbid*-stuff_thumb500.jpg
mbid*-stuff_thumb250.jpg
mbid*-stuff_thumb.jpg
mbid*-stuff.jpg

These files are not new or regenerated:
mbid*_meta.xml
mbid*-stuff*.jpg (the previous art uploaded in November 2017)

There is still no index.json

Anyway. This seems to be a problem on Archive.org’s end, only effecting uploads in November 2017.

UPDATE:

I wrote this too soon. The CAA did regenerate the index.json file after a several minutes.

So… the workaround for this seem to be to upload anything as new cover at for a release, and the CAA will regenerate the index.json file after a few minutes…

Update 2:

If you add cover art (upload a JPG though MB) to regenerate index.json, and then you cancel the open edit on MB, your uploaded JPG and generated thumbnails will remain on the CAA – presumably forever as orphaned files.

It seems the synchronization between MB and the CAA needs some work…


#16

I can confirm that. I’ve tried the same for the problem albums from my list.


#17

Worked for me too. Seems this issue is confined to images uploaded in a certain period around early December 2017. Uploading any other cover art to the same release fixes it.


#18

not sure if this is exactly the same issue, but this problem seems to still persist:

for a week I’m trying to add cover art to two releases which had wrong cover art or very low resolution before.
The art never shows up but displays “Image not available yet, please try again in a few minutes”.
For the first time I’ve waited a few days. Then canceled the edit, uploaded again, waited a few hours, no luck. Edited the images, reuploaded, no change.

the “original” version is always available via CAA but the 250px and 500px thumbnails always result in a “Page not found”

The edit:
https://beta.musicbrainz.org/edit/55448662
the original which works:

the 500px that never shows:
https://coverartarchive.org/release/6a7d8842-cf00-4a7b-847a-96cb35803778/20748234717-500.jpg
the 250px that never shows:
https://coverartarchive.org/release/6a7d8842-cf00-4a7b-847a-96cb35803778/20748234717-250.jpg

same for this edit:
https://beta.musicbrainz.org/edit/55448215
the original that works:

the 500px that never shows:
https://coverartarchive.org/release/57ca0184-b79a-4398-bb8e-661e7e118e9b/20748079201-500.jpg
the 250px never shows:
https://coverartarchive.org/release/57ca0184-b79a-4398-bb8e-661e7e118e9b/20748079201-250.jpg

…help


#19

The important bit is your originals have uploaded correctly.

I do notice when reports like yours appear, I also am getting warnings from Eset Anti-Virus blocking some of the servers.

Now and then some of the CA servers get on block lists. This then seems to have a knock-on effect on how they behave for a few days. I don’t know what else is uploaded there, but this does seem to pop-up every few months. Then the problem is cleared and it all settles down again.


#20

I’ve seen the same thing, but they showed up after 3 or 4 days.