Discogs import script not working

I’ve installed discogs_importer.user.js with violentmonkey on chrome and tampermonkey on firefox.

I had to resort to watching a video to figure out that the script is supposed to add a button on discogs, not Musicbrainz. People write it adds a button to “the site”, which I took to mean Musicbrainz, figuring it would “pull” info from Discogs to MusicBrainz when what it does is “push” the data.

Anyway, what this video shows at 00:56 is not happening. No MusicBrainz section and buttons are added. https://youtu.be/dsojvxMvmWU?t=56 despite tampermonkey saying it’s executed the script several times. Violentmonkey gives me no feedback about what it’s doing, or even if it’s doing anything.

From where? Which version?

If the script is correctly installed and fails to load, it should show you something in the browser web console.
In Firefox you can access it through the Tools > Web Developer > Web console menu. Firefox and Chrome (IIRC) have the F12 shortcut key to open that log window (look for a tab named “Console”)


This happened to me the other day but when I logged in to Discogs it started working again. They may have changed something that messes with the plugin.

There is another thread around where a few of us was spotting a hit n miss with Discogs. They seem to messing with the advertising and cookies lately. In the process they keep breaking and bugging their site code. Then fixed a few hours later.

Aha - that thread is here:

That time we realised that:
a\ we had to feed Tamper Monkey a single banana, and
b\ we cleared the Discogs cookies.

Try logout of Discogs, delete all Discogs cookies, log back in again.

If that fails, throw the Violent Monkey a banana :banana:


Whatever this installs. I assume that should always have the latest. https://github.com/murdos/musicbrainz-userscripts#discogs_importer

Do I have to login to Discogs? I deleted everything with Discogs in it from my C: drive, with all browsers not running. Still nothing added when I go back. :frowning:

I just tested by logging out, and it worked/the submission button was there again. So not sure what’s up sorry. To test:

Clear cache properly for Chrome, visit: chrome://settings/
And then ‘Clear Browsing data’, which is down the page a little bit.

And then we’ll just make sure you’re testing with a release that works for me (this one)

And that you’re not seeing these boxes on the right hand side of that exact link above:

If none of that works you dig further/hassle murdos or whoever :wink:

I registered and logged in and the buttons show up now, in chrome and firefox. Dunno why they wouldn’t without doing that.

1 Like

Ran into the same problems; so this thread was really helpful!

1 Like

Same problem here with Greasemonkey in Firefox. Creating an account & logging in to Discogs solved it for me as well.

I have always imported releases without being logged in on Discogs and I am still able to do it… Just wanted to mention this to make it clear that it is not required to have a Discogs account in order to use the import script, this is just about some cookies causing this problem. So if you have this problem, simply delete your cookies for Discogs.


I did that. It did not work. The import script will only work for me when logged into Discogs. As long as it works, it’s fine.

it happens from time to time where you have to be logged into Discogs for the script to work it is normally on there end. it has been talked about on here before.