Albums not showing up in KODI Artist menu

I am not sure this is the right place to ask, but maybe I will get some advice. When I go to the Artist menu in Kodi for a particular artist (Uriah Heep), no album is showing up, except for a particular track which is in a “Various Artists” album. In the Album menu, all albums are there, I can play them through the “Files” menu. I tried to add them anew, it did not work. Deleted and rebuilt the database, no effect. I reinstalled Kodi and MusicBrainzPicard, no effect. This is on a Windows 10 system. Same thing shows on an Android tablet, which runs Kodi. The music is on a NAS system. I tried to reorganize the albums in the Artist folder, since I would like to separate the discs from a box set in different folders. I have done this many times so far and did not have a problem. This time when I was erasing the old folders, I got a warning that some system files are about to be erased, which I foolishly ignored. Any advice? Thank you in advance.

This seems like more of a Kodi support question. But maybe we can help :blush:

Firstly, have you checked all the instructions here?

I use Plex instead of Kodi, where it would 99% surely be that the folder structure is wrong for Plex’s wants. However it looks like Kodi ignores your folder structure completely

Luckily Kodi recommends using Picard to tag your files. The page I linked above has comprehensive instructions for tagging your files.

Assuming you have run all your files through Picard, matched and saved them with the correct settings, you should be able to rescan your library in Kodi.

Hope that helps!

KODI user here… but an older edition. Shouldn’t matter much.

Album properly tagged with Picard? Got full Artist MBIDs in there? And an artist name?

As a test, go into one of the folders under FILES and do a right click \ “scan item to library”. Then say Yes to “Do a full tag scan even when music files are unchanged”. Anything different now?

The key with KODI is making sure the tags are right. It uses the tags to set everything up. And especially makes use of Picard MBIDs for artist names when in the tags.

1 Like

Thank you for quick response. Picard does show up all of these tags. Did several times re-scanning of individual albums, as well as of whole artist folder.

1 Like

Can you read an SQL Database? Maybe we can look into there and see what is seen by KODI.

In Picard:

It is the Release Artist ID that will be used to tag the album. The Artist ID is only for a single track.

I’m poking around settings on mine to see what I could break to hide the views like you have.

In Estuary skin, when looking in an Artist view pop up the options menu on the left.

Look for FILTER

Are you sure you have no filters set?

Make sure that compilation is set to ALL and not YES. When I set that to YES it hid all the albums and only showed compilation…

Also similar, when looking at the WHOLE artists view, again check the menu on the left. Make sure no filter has been set.

Checked all of these, everything seems fine. Release Artist Id is there. No filters set. Ripped again one of the albums, tagged it with Picard and scanned it into the library. Does not show up in the Artist menu.
I do not know how to read the SQL database, and even don’t know where in the computer it is located. But seemingly the problem is of that nature.
Again, does not seem like a Kodi issue, since I have the same problem on the tablet Kodi.

On the Artists page, are all the expected artists listed? Just no albums showing under each artist? This is why I was thinking some kinda filtering error.

Next obvious one is the logging. Log file - Official Kodi Wiki
( %APPDATA%\KODI\kodi.log in win 10)

Turn on the log file. Restart KODI. Scan in an album. Then go into the Artist View and try and locate the album. Ideally watch your clock when you take the step to go into the Artist View and look. Then we can try and make sense of that log by checking timestamps. It may give us a clue.

Follow those instructions and put the log into and put the link up here. I have some experience of reading those logs.

Thank you! I have to go out now. Will try later and report.
However, no albums ONLY for Uriah Heep. All others are there.

Ah - even more interesting. Something is doing a weird filter of some kind. Look more at the “Filter Albums” example I am showing in that above post in your Uriah Heep artist folder. Use that CLEAR button you see in the above image. Or set a filter, and then clear the filter. Just to make something change in there.

Here is the link:
Started Kodi at 22:58
It seems that the last lines are relevant, but i cannot make anything out of them. Hopefully you can.

Another observation. I could add the whole Uriah Heep folder from “Files” to “Favourites” with no problem. All albums are there and playing. But not in the Artist menu :frowning: :slight_smile:

A couple of basic checks to run (not really specific to this problem/software, but always worth a try), comparing against files/songs that work:

  • Check file formats
  • Double check tags (artist and albumartist tags in particular)
  • Folder settings (e.g. unwritable folder)

Another test to run is to tag some completely different files against the Uriah Heep (yes, incorrectly!) entries in Picard, and put them in the same folder. See if they show up in Kodi - this way you can narrow down if it’s the files/folder or how they’re being tagged.

I have a busy start to the (UK) day, but will look at this later. The fact these appear in favourites and other places makes me think that your tags are likely good. This is something specific to the Uriah Heep artist.

Update: nothing in the log at all. Did you turn debugging on? ( Enable the setting Enable debug logging in the settings page located at Settings > System Settings > Logging) Maybe needed to wait a bit longer after going into the Uriah Heep section before uploading this copy? I see none of those steps.

Have you run a Clean Library? from the Setting\Media\Music section?

Sideways thought. Check your compilations with Uriah Heep tracks. Make sure these have the correct Artist IDs for Uriah Heep. If one of these starts by adding bad data to the database for Heep, maybe this could affect things like this?

Personally I have my sources rigged so it scans my best tagged files first. These are then used to populate the database tables with the artist data.

New report :slight_smile:.

  1. I have an Uriah Heep track in only one compilation album. Checked with Picard. The Uriah Heep track has “Artist” and “Artist Sort Order” tag which are both Uriah Heep, but does not contain the Uriah Heep MBID identificator tag. Removing the track and rescanning, removed Uriah Heep from the list “Artist”, when I put it back there and rescanned, it showed up in the same fashion as before.
  2. Tried to scan one album. Did not show up in the “Artist” view. The log report shows:
    It seems to me that the database is corrupt in some way and does not recognize the entries. One can see that one and the same group of lines shows up 8 time, which is exactly the number of tracks in that album. However, the album was present and accessible together with the album art in the “Album” view, just as all other Uriah Heep albums (I have a ton of them :slight_smile:). Same thing, as i said earlier in “Favourites”.
1 Like

Forgot to mention that I cleaned the Music Library from the Setting\Media\Music section several times to no desirable effect.

1 Like

Resolution! Had to learn some SQL basics. Opened the MyMusic82.db of Kodi. The entry for Uriah Heep was missing its MBID. In addition, there were 2 entries for Ken Hensley, one of which had the Uriah Heep MBID. Removed this entry and put the correct MBID for Uriah Heep. Worked like a charm! All the Uriah Heep albums scanned properly and showed in the “Artist” view.
As a result of all that pain, the good news is that I understand a little better how tagging works, which means I have to put way more work on my music library :frowning: :slight_smile:
Thank you @IvanDobsky and @aerozol for your interest and suggestions! These helped a lot! :+1: :clap:


Wow, I honestly wouldn’t have expected that!! Nice work!

Welcome to the club my friend :joy:

Excellent. Well found. This is the direction I was heading, but too exhausted last night to finish this up.

The first artist KODI sees in the audio files is the one that gets into your database. This can lead to an oddity like this. My method is to have multiple “Sources” setup and my best tagged CDs are in a source named “!!Ripped CDs” and added first. This way the first data scanned into the database all has full MusicBrainz MBIDs. Also make sure compilations are in “Various Artists” folder instead of “Compilations” again to push them later in the database scanning.

Learning to hack around in the database is good, but always keep a backup before making changes.

Also note - if you update the tags in an album, then go hunt it down in FILES view and use the Right Click \ Scan Album to Library option to re-read all those tags. Otherwise changes will not always be picked up on a normal scan as it spots the album and doesn’t realise there is new data to read.

1 Like

Thank you for all advice.

  1. But what do you mean by “multiple Sources”? When I rip a CD, I tag it right away with Picard and it gets saved to the NAS. Then I scan it in Kodi. The “Source” for me is the folder on the NAS that has the Shared Music.
  2. I did certainly make a copy of the database before playing with it :slight_smile:.
  3. New problem has arisen. As I wrote in the beginning of the thread, I do not know exactly how this whole mess happened by erasing files on the NAS, but it is showing up on all 3 installations of Kodi I have - on a PC, on an Android tablet, and on a Raspberry Pi. I fixed the problem on the PC database. I could copy the database from the Android to the PC and saw it has the same problem and corrected it, but I cannot find a way to copy it back to the tablet. And I have no clue how to do that on the Raspberry OS. As you see my knowledge of databases is very rudimentary :slight_smile: :frowning:. Any advice in that respect?