Why doesn't catalog number search work?

Tags: #<Tag:0x00007f5119a05958> #<Tag:0x00007f5119a05688> #<Tag:0x00007f5119a054f8>

I tried to find Ultimate Dolly Parton, catalog number 82876 52008 2 but searching for the number exactly as it is on the case with spaces turns up nothing. But go to the release group for the album and there is the catalog number, exactly as it is on the case.

I’d expect a database search to be able to find information in the database when someone enters an exact match.

1 Like

It works for me: indexed search with advanced syntax, catno:"82876 52008 2".

1 Like

Would be nice if going to Search > Search Entities - Other Lookups - Catalog Number
then putting the Catalog Number in the Catalog Number field did what catno:“82876 52008 2” does in index search with advanced query syntax does.

Instead it kicks back Found 2,265 results for “82876 52008 2”.

If there’s a box that says it’s for searching by catalog number, people might expect it to actually work for finding what it says it is for finding.

Can somebody fix that search box?

2 Likes

Indeed, this input field only works as expected when I put quotes around the numbers (because the catalog number contains spaces).

3 Likes

Oh finally they are fixing that madness!! Excellent. There is another lost thread from a few years back where I was trying to make sense of why catalogue number searches were so weird. And this would explain it.

If that ticket is finally being fixed maybe I can search at MB again instead of using Discogs as an Index. :rofl: :stuck_out_tongue_winking_eye:

1 Like

I find that catno: doesn’t restrict its search to the Catalog Number field. I’d call that a bit broken. Try a search for OPCD-6506. That’s a 3 disc Reader’s digest release of Linda Ronstadt songs. You’ll either get nothing or you’ll get hits with OPCD or 6506 in fields other than catalog number.

barcode: is a bit too restrictive. There are tons of barcodes on CDs (and other items) where the final check digit is left off, so one must try adding 0-9 and hope that it’s in the database correctly. If barcode: could also do a partial string search after whole string search fails, it would be more useful. Even worse is when they leave off the leading digit.

1 Like

Are you sure that’s in the database? Can’t find that on the list of Linda Ronstadt’s releases at all.

2 Likes

It’s not in the MB database, but depending on how it’s searched for, the MB search will return as hits parts of catalog numbers if finds in fields other than catalog number.

Can you be more specific? If you want to search explicitly for the catalog number your search would be

And that finds no result as is expected. If you search for something existing, e.g. “ST-11269”, that would be found.

If you just enter the search term without advanced search or without the “catno:” it will do a full text search for it and of course match in other fields as well

1 Like

Now that I have the Discogs import script working (had to create an account there and login) I tried to add https://www.discogs.com/Linda-Ronstadt-Her-Greatest-Hits-And-Her-Finest-Performances/release/14126072

It says it already exists with Reader’s Digest Music and Warner Special Products and that catalog number.

So I searched for those two labels, and also the Reader’s Digest (no Music) link it gave me and… Nope. Not on any of the pages for those three labels. Warner Special Products pages show a lot of OPCD- numbers but no 6506 that I could see. Mostly Various Artists compilations, no Linda Ronstadt.

Suggestion: Make “This label/catalog number pair already exists.” a link to the release that is in the database but nothing tried in searching, nor Picard, can dig up.

Edit: Went back and tried the import again and this time it didn’t lie to me that it already existed, but rejected adding the link to 45worlds, which is on the MusicBrainz whitelist. http://www.45worlds.com/cdalbum/cd/opcd0605

At least it’s finally added, bagged and tagged.