Where is the all=1 user script?

I don’t know when it stopped working but I used a script that added the ?all=1 to every MB URL. I really liked that but it’s gone. Searching for “show all release groups” or “all=1” didn’t give me any hits. Where can I find it? (Or is there now a setting to always show all groups?)


1 Like

Weird I could not find it!

1 Like

I know it’s alittle bit lame, but I have just added this search hint in this userscript topic title, now it is found via forum search, as first result:

1 Like

The ?all=1 is not added even after reinstalling the script. Do I need to do anything else?

Xubuntu 23.04, Firefox 125.0.2

1 Like

What is your script engine?
Greasemonkey? Violentmonkey?

What do you see in the console (F12) after clicking an artist link?

TamperMonkey, and this is the error I see, no further details (and no ?all=1 either):

Error: An unexpected error occurred undefined

1 Like

Maybe you can try these (successively):

Thanks for helping out!

I tried downgrading first as that was simpler than disabling all other scripts of installing ViolentMonkey. Lo and behold: it works, the old version works!

Now you want to know what makes the difference, I guess. What do you need to know?

1 Like

Thank you very much!
If you have time, could you please test these versions one after the other, and tell me which one is incompatible with Firefox and/or Tampermonkey?

  1. Version 2024.4.11
  2. Version 2024.4.11 patched
  3. Version 2024.4.11.1730

None of those three work with Firefox + TamperMonkey.

For a while I did not get any debug info in the console but with 2024.4.11 after disabling the “expand release groups” script get this:

env: run “mb. ALL RELEASE GROUPS” ASAP → document-start content.js:59:293

env: inject “mb. ALL RELEASE GROUPS” now content.js:58:86

Thanks so much for testing!

Hopefully, the breaking change is very small between the version that works for you and the version that does not work.

Thanks very much, I will surely find how to fix for multi-browsers.


1 Like

My test with Tampermonkey in Vivaldi shows that it’s the version 2024.4.11 patched that does not work for me.

An even smaller change.

Are you sure that version 2024.4.11 does really not work for you, @jerry1970?

Tried it again, but it does not work.
I think I did see some irregularities after updating. Maybe I should try testing them all with closing the browser after updating…

1 Like

Thank you, so I really have to install Firefox on some PC.
Good to know.

1 Like

OK hopefully there is a Firefox on my company laptop, on which I have no admin rights.

Strange that it says it is up to date but my Firefox version is far behind yours: 78.11.0esr (64-bit).

I quickly tested DEBUG, INSTALL-USER-SCRIPT and mb_ALL-RELEASE-GROUPS with Greasemonkey (userscript pioneer), Violentmonkey (open source) and Tampermonkey (proprietary).

Scripts work with Greasemonkey and Violentmonkey.
But DEBUG and mb_ALL-RELEASE-GROUPS (who have neither include nor match in their metadata block) don’t run on Tampermonkey. They only run in Greasemonkey and Violentmonkey.

Usually, having no include and no match means that the script should run on all pages.

But it seems that Tampermonkey really wants an explicit // @match *://* to run such userscripts.
So this problem is not really related to Firefox but to Tampermonkey.

I reported the problem to Tampermonkey support:

1 Like

OK, let’s see what that will do.

By the way, I am on Linux (Xubuntu 23.04). Maybe different versions per platform? Nah, that would be weird…

They don’t intend to fix it.

You can either use Violentmonkey or Greasemonkey instead, in the meantime.
But I know some userscripts no longer run properly with newer Greasemonkey.
I advise Violentmonkey.

I am trying FireMonkey first but I seem to have to run scripts manually and several return that jquery is not defined. (jQuery is still used a lot, while I’ve not used it in years…)

None of the versions run in FireMonkey (Xubuntu 23.04, Firefox 125; different laptop than the other one but same OS and Firefox version, just running FireMonkey here and ViolentMonkey on the other).
If it’s a matter of matching, shouldn’t that be a simple one to change in the script?