Warning: The Cover Art Archive is currently experiencing difficulties

musicbrainz
coverartarchive
Tags: #<Tag:0x00007f2a013cc530> #<Tag:0x00007f2a013cc2b0>

#1

Wanting to express my sincere appreciation for the warning notice that I found when I was trying to add CA.

“Warning: The Cover Art Archive is currently experiencing difficulties. Adding images for this release is unlikely to work at the moment.”

I felt that my efforts and time were appreciated and that MB thinks that me and other editors wasting our time with pointless attempts to edit is something worth making an effort to avoid.

Sure I tried uploading once but then moved on, confident that the problem was not my mistake and was already being addressed. Felt gooood.

Thanks and keep up the good work.


#2

I only wish the same were available in Picard!


#3

For me there wasn’t any warning like this. I added some cover art, some of it was available after a few minutes as usual, but some isn’t available up to now.

One example: The image of type medium at https://musicbrainz.org/release/f6aa8971-c5c6-301c-8e15-6eab142a4fa0/cover-art exists as “original” on Cover Art Archive, but not as “250px” or “500px”. So it isn’t displayed on MB.

Does anybody know how to fix it? Or is deleting and uploading it again the only solution?


#4

Me too. I have some that still isn’t available, a full day later.

When I’ve seen this in the past, it all was eventually fixed without any other action on my part. It usually only took a few hours, so I’m not sure why this is taking so much longer. I don’t think deleting and uploading again will help.


#5

The warning is for when the upload itself will fail. Usually what you’re describing means the upload worked, but the IA didn’t (yet) generate the thumbnails. Sometimes that takes quite a long time if they have some server issue.

A good way of checking is going to the cover art tab of the release and clicking on the “original” link for the appropriate image. If that loads, you’re good.


#6

Yes, the original is on IA. But the other sizes are not available. And with some releases Picard shows me an error that the JSON file is not availabe on IA. It looks like IA hadn’t created some resized images and hadn’t updated the metadata for the images of a release.

My questions to this issue are: Do I have to inform someone else about this issue? Or will some IA fellow repair this not properly processed uploads without being triggered by me? Or will the error persist until I cancel my edits and upload the images a second time?

Maybe someone can help answer my questions.


#7

It usually repairs itself eventually, although there’s been a couple cases in the past where we had some specific issue that needed fixing on our side for the process to work IIRC (@Bitmap, how was that stuff?). If you can list some examples, we can look into it.

In any case, cancelling + uploading really shouldn’t be necessary :slight_smile:


#8

That’s no problem :wink:




Edit:
Maybe it is possible for admins to check where the json file is missing or the json is older than the newest image, or to check where thumbnails are missing?


#9

The issues listed above are solved now, but I still get new issues. There are cover arts of two releases I uploaded 4 days ago, but the images still are not available to MB (original image is available, but others aren’t):


Is there a general problem with upload handling by CAA or is it just a small glitch which I experienced often due to bad luck?


#10

It’s an on-going problem. I’m seeing the same thing with my recent uploads. There’s a ticket out, though: https://tickets.metabrainz.org/browse/CAA-99


#11

Good to know, thanks for the link!