Technical issues adding artists and recordings


I have been having difficulties adding entries. The only thing reliable for a new artist seems to be add them to a recording. Relationship in open edits don’t appear (they vanish if you hit submit, at least for me), if I try to add the same relationships again in a new edit it complains that this is not “new information” (unless it is a new relationship), however the relationship never appear. As a result, if a new artist is only linked to a recording by a relationship, that artist will be deleted since it complain the artist has no relationships (only these ghost relationships).

Today, via a recording, I tried to add the classical & electronic Artist Robert Bernat:
Classical, electronic, and brass composer affiliated with major institutions such as California Institute of Arts as Woodrow Wilson Fellow. Has wikipedia, IPI, ISNI, NYT & LA times obituaries, etc. discogs discography. He is ISNI 0000 0000 4370 6979 and IPI 56005603, and is not yet in MusicBrainz for some reason.

However, when I tried to add him (via new recordings, the only reliable way), I just got an endless spinning hourglass. (I feared he might have gone as an open edit not associated with any recordings, in which case he’d be deleted, but it looks like he just wasn’t added. If he had gone in as open edit associate with a recording, he doesn’t seem to appear in drop downs until the edit is approved, meaning at most one recording can be associated until the edits are approved?)

Here are links for him. Can someone look into the technical issues and add once they are fixed?

#2 :slight_smile:


I’ve never had not be any more or less reliable than any other part of the site. What kind of issues have you had via that route?


I have never seen this, and adding new relationships shouldn’t be an open edit (unless you specifically ask for it). If you hit this issue again, could you contact me? I’d like to take a look and try to figure out what’s wrong :slight_smile:


Maybe not auto edits for limited users.
Maybe kx3u8193 was limited user when their relationship edits were queued (when it worked).