Tagging christmas songs (not albums)

Is there anyway to tag specific songs as christmas songs? For example, River by Joni Mitchel?

1 Like

You could go to the recording or work and tag them from the sidebar, if that’s what you have in mind :slight_smile:


Are the tags shared or just for me?

1 Like

kind of both, actually. I’ll demonstrate with an example.

I’ve tagged several artists with “awesomename”, including NǽnøĉÿbbŒrğ VbëřřĦōlökäävsŦ (Nanocyborg Uberholocaust). however, if you look at the tags page for the artist, you don’t see awesomename. that’s because someone downvoted my tag. I can still see it when I look at the artist though

also, if you’re pulling your tags using an external program, (for example, genre tags in Picard), I’m 98% sure it will pull all your tags, including any that others have downvoted


Thanks for the example. I used it to try to accomplish my question… Here’s an update…

  1. christmas-music is an official genre and lots of people are using it (Tag “christmas music” - MusicBrainz) so, I used that to add a tag to Joni Mitchell, River (https://musicbrainz.org/recording/760828c4-c062-4667-94c6-0d358c1c768c)

  2. Note that River is tagged firstly on the listed under three genres: folk, christmas-music and pop.

  3. I used the latest version of Picard 2.8.5 on my mp3 and flac versions of the albums.

  4. I clustered the files and looked up the release on Musicbrainz. Found the specific release (https://musicbrainz.org/release/a575174c-36c5-4ba5-8f34-1d752815fd99).

  5. Selecting track 8, River… the genres shown are “Contemporary Folk;Folk;Folk Rock;Pop;Singer-Songwriter”

Use MB Genres is turned on, minimal genre use is 0% and max number of genres is set as 10:

So, any ideas on how to display the Christmas-music and pick on? ( I had a look at the Picard docs, but can’t see anything)…

Neither Joni Mitchell nor the release or release group are tagged as “christmas-music”, so this can’t work.

Also Picard will currently use the genres from recordings, releases and release groups for each track. The artist genre’s will only be used if there are no genres specified on the other levels and if you have activated the “Fall back on album’s artist genres” (see your screenshot).

So if you want to have “christmas music” show up as a genre for this album you should add that to the release or release group.

But actually the only christmas related song seems to be River, and that one is already tagged as christmas music. Does this tag show up for you?

1 Like

ok. I want to do it at the track level. Blue is not a christmas album, just the one track River

Correct - see above.

Not in Picard, only on the MB website…

When I load this album into Picard with your genre setting I get this for River:

I don’t:


I just re-encoded the album to flac and tried Picard on that.
The genre for River still doesn’t include Christmas-Music:

Not sure if it will change anything but FYI I’ve added a +1 tag for xmas music to the song (in case results now vary)

just checked and the ‘Christmas Music’ genre appears in my list! Why would your vote make it appear for me when it already appears for @outsidecontext ?

That is interesting - let’s test, I’ve removed my vote again, see if it shows up now!

1 Like

it clearly prefers @aerozol 's opinion over anyone elses /s :laughing:


You are correct. The genre ‘Christmas-Music’ is now not showing…
with minimal genre usage = 0%

@dpr send us a screenshot of your settings… mine look like this and the genre appears:

Here you are.

ok hear me out, tick Use folksonomy tags as genre then see if it pulls through

I noticed that difference between your setup and mine when you asked for a screenshot of my options :slight_smile: and tried it out before I uploaded my options screenshot… it didn’t make any difference!



Might be time to raise a JIRA bug ticket?

what version of Picard are you on? I’m on 2.8.5