Tagging christmas songs (not albums)

yes same as me

That would have been too easy… maybe we could try a different track?

It should be weighting my vote more, but unfortunately it’s probably a threshold thing? 1 vote vs 2?

Sounds like you guys are onto it… If it’s not weighting my vote more, let us know and I’ll fill a bug report :bug:

1 Like

With minimal genre usage set to 0% shouldn’t it ignore the votes?

It behaves differently for me vs @sound.and.vision

go ahead and create a ticket… let me know if i can help

1 Like

Yes, that should basically be the result. The percentage is the min. number of votes relative to the tag with the most vote. So if theost voted tag is voted for 10 times and you set this setting to 90% only tags with 9 or more votes are considered. That means with 0% it would consider all tags.


please let me know the bug report number

I’ve made a ticket: [PICARD-2598] Inconsistent genre tag weighting results - MetaBrainz JIRA

I wonder what would happen if you used the same file to test with as others, and a clean install. There must be something different going on… but it may still be a bug ofc. Do you have many plugins and scripts etc running?

Another question is, is that single vote for xmas music in there currently yours? I have no idea as to how Picard uses genres quite frankly, and if you’re ‘logged in’, but that seems like it could be a sneaky way for you to always get different results to everybody else :dotted_line_face:

1 Like

@dpr: We need some more details what is happening in your case in order to figure out why you got different results.

Inside Picard could you enable the debug output by opening Help > View Error/Debug Log, the in this dialog set the log level to debug with the drop-down menu in the lower left.

Afterwards load or reload the release in question, then share the output in the debug log here or on the ticket.

It’s mine. If I remove the vote for “Christmas Music”, then the genre is removed from the song.

The genre stuff seems to be broken to me. The MusicBrainz entry now looks like this:


In Picard, it looks like this:

They match the release-group. The release has none. Also note that folk-pop has one vote and shows up.

Not many… just setting the original release date…

Well, if you are the only one having tagged it christmas music and you remove this tag the recording will obviously no longer be tagged Christmas music.

Also just to be sure: before you run the debug log thing please make sure the recording is tagged as Christmas music again. Otherwise this all makes no sense.


I removed all of my plugins. I set the genre back - Christmas-Music on the track and re-ran Picard with the debug turned on. I’ve uploaded it to the ticket.
Thanks for looking at this!

1 Like

@dpr Thanks for the debug log. However, I am unable to reproduce any wrong behavior. For me the genre “Christmas Music” gets loaded and assigned properly for “River”, with the same loaded data as in your debug log. Could you please double check your setting for “Maximum number of genres”? This should be reasonable high, in this case at least 9, as the recording in combination with genres set on the release group and release level will have 7 genre tags and 9 genre tags if “Use folkosonomy tags as genres” is enabled.

Also I would discourage you to enable the option “Use folkosonomy tags as genres”, as this will pull in other non-genre tags as well. For your debug log case this option was enabled. In this case you would even end up with 9 tags for “River”.

If you set maximum number of genres to a value less than the returned genre tags than Picard will remove some with the lowest vote counts. As multiple tags in this case will have only one vote this can mean Christmas Music gets excluded. This would also explain why you got the tag once it got upvoted by someone else.


Thanks for looking at this so quickly.

This setting was the problem. I increased it to 10 and “Christmas Music” appears in the genre list!
Sorry for wasting your time. I should have noticed this. :frowning: My excuse is that I have the flu!


All good :slight_smile: I’m glad we got it resolved. Happy tagging