Submit AcoustID button stays disabled

Tags: #<Tag:0x00007f00c27552c8> #<Tag:0x00007f00c2755160>

Picard wont let me send AcoustID :frowning: No matter what I try, the button stays greyed out.

1 Like

Same as @rukkulakki button stays greyed out in Picard

1 Like

If the AcoustId submission button stays disabled this usually means one of two things:

  1. The files matched to tracks in the right pane don’t have AcoustIds

  2. The files have AcoustIds, but are matched to tracks which have already this AcoustId assigned

Basically this means you have to do the following:

  1. While files are on the left pane, select the files and press Scan
  2. Picard will get the AcoustId for each track. If a match is found it will be loaded in the right. Files without a match stay the left.
  3. Check the matches on the right and if necessary correct them manually. If you keep the matches as they were the AcoustId submission button will stay disabled, as there is nothing new to submit. If you manually do changes, the submission button might become available, but only if you assign the files to recordings which do not have the same AcoustId already.
  4. The files on the left did not have a matching AcoustId. Those must be matched to MusicBrainz data by other ways (Lookup, manual). Once done, the AcoustId submission should be available for those cases. If not, check the error log for problems with the AcoustId.org service.
4 Likes

@outsidecontext I’m having this same problem and I don’t understand the suggested remedy.

When I drag the folder full of m4a files into Picard, everything is already matched so it just jumps over the right-hand pane of Picard.

What do you mean by “Check the matches on the right and if necessary correct them manually”?

Detailed steps needed here.

The first step then is to move the files back to the left, then you can select the files there and press “Scan”.

Picard will now lookup the AcoustIds an try to match the files. You can end up with files that get matched to different tracks or not get matched at all and staying on the left. Now drag this files back to the release that matches yours (which Picard originally had already loaded).

If the AcoustIds of the files are not already linked to these tracks the Submit AcoustId button will be available.

1 Like

Thanks. I tried that and it seems the AcoustIds are already linked (the Submit AcoustIds button is still unavailable).

Is there some way to verify that the AcoustIds are correct?

I’m wondering because I created this release using Add Cluster as Release… from Picard, but I didn’t submit any AcoustIds.

Also, when I click Lookup CD, nothing is found.

You can click on the recording of the release and check the attached AcoustIds there. When you created the release and used existing recordings it is not unlikely that they already had fingerprints submitted. But if you just created new recordings it is less likely that somebody else linked them to AcoustIds.

CD lookup has nothing to do with AcoustIds. If CD lookup does not give you results you should submit the disc ID to MB. You can do this in current Picard using the “Lookup in browser” button in the CD lookup dialog (next Picard will make this a bitore obvious).

1 Like

Sorry, I got lost at “click on the recording of the release”. Where, exactly?

I created this release and the songs don’t belong to any other release, so how could they already have fingerprints?

As for adding a Disc ID, I looked at How to Add Disc IDs, but it’s completely out of date, and just get lost trying to figure it out.

I would like to contribute information to the MB database, but the documentation and Picard UI really need to be fixed.

Which release is it? If you click on a track on this release on MusicBrainz.org you get to the recording page. On the recording page there is a “Fingerprints” tab that lists all linked AcoustIds for this recording. Example: https://musicbrainz.org/recording/8f30d9e3-c65d-4c35-aa22-0cf2410ed4d7/fingerprints

If this is empty, as you expect, then the problem indeed lies elsewhere. In this case please check in Picard:

  1. After you used “Scan” on a file, does it show an AcoustId tag in it’s metadata? See this example:
  2. After you used “Scan” on a file are there any error messages in Help > View Error/Debug Log ?

It doesn’t look completely out of date to me. If you tell us were you got stuck we might be able to assist you and improve the documentation if it is incorrect.

1 Like

This is the release. Under Fingerprints, I see: “This recording does not have any associated AcoustIDs”.

I tried Scan and checked for the AcoustID. No errors. The “Original Value” column is empty, but the other side has a unique ID.

I guess this is why I’m confused. Maybe I just don’t understand how this is supposed to work, but the online database appears to have no AcoustIDs, while Submit AcoustIDs is greyed out. Nevertheless, there is something appearing in Picard. Idk what that second column represents, because unlike Original Value, it’s not labeled.

As for How to Add Disc IDs, I went through it again and figured it out. I could make some suggestions, but nothing specific beyond a revision to bring the screen shots and accompanying text up to date with changes to Picard since version 0.9.0.

1 Like

Just to be sure, in the end before you try to submit the AcoustIds your screen should look something like this (note that this is just fake files, hence no proper AcoustId is shown in the screenshot, but you should get the idea):

That means the release is loaded on the right, all the files are attached to it and if you click on one track it shows that there is a new AcoustId for this file? If this is all given and there are no errors in the Error/Debug log it is indeed strange, the button “Submit AcoustIDs” should be active as shown in the screenshot.

It is actually labeled “New value”. On the left there is the original data already present in the file, on the right are the new values that will be saved.

Yes, there will be some additional changes to this dialog in the upcoming Picard release. I think this will be a good time to update the instructions :slight_smile:

2 Likes

Thanks for your message. I was able to get the state you describe/illustrate (release loaded on the right w/AcoustIDs), but only after some experimentation and additional steps.

What I am seeing now looks rather like a bug.

When I drag the local folder of files into Picard, it auto-recognizes via the MB database and jumps to the right-hand pane of the window. There are no associated AcoustIds.

Then, I drag the yellow CD icon from the right into the middle pane of the window. There, I select the Unclustered Files folder and click Scan. Picard now scans the files and adds AcoustId attributes to the New Value column (I didn’t notice this before because of the column widths and the heading is centered).

I then tried to Cluster the files and clicked Save. I assume this updated my local files with the AcoustId attributes. So now, my local files have AcoustIds.

Next, I see what appears to be a bug.

To start from a clean slate, I Remove everything and drag the folder from the desktop into Picard once again. And once again it auto-recognizes into the right-hand pane. If I then drag the folder into the middle pane of the window, the files (with AcoustIds) are unclustered. If I Cluster the files, I would expect to be able to Submit AcoustIds, but it remains grayed out.

However, if I Scan the unclustered files yet again, and then click on Cluster, finally Submit AcoustIds lights up. I.e., If I Cluster and then Scan, it doesn’t work, but if I Scan and then Cluster it does work.

This looks like a bug because (1) the files already have AcoustIDs, and (2) it shouldn’t matter whether I scan or cluster first, right?

FWIW, I haven’t yet submitted the AcoustIds in case you would like me to try something else, to facilitate debugging.

There seem to be some misconceptions here:

  1. If you remove the files from Picard you afterwards have to start with scanning the files again. The AcoustId submissions submits pairs of AcoustId fingerprints + MusicBrainz recording IDs. The fingerprint is calculated from the audio data and only available after you used scan. The fingerprint itself is not stored in the files, because it can be easily regenerated locally.

  2. You can only submit fingerprints for files you have actually matched to recordings on the right pane. Nothing gets submitted for files in the middle pane since the middle pane contains files that are unmatched. If you drag files from the right to the middle pane you explicitly tell Picard that you consider those files unmatched.

I am seriously confused by your description. Where are the files when Submit AcoustIds lights up? If the files are still on the middle pane the AcoustId button should never show up. Also clustering has zero relevance for AcoustId submission. What can happen is that you cluster files while they are still queued up for scanning, this could probably interrupt the scan process.

Please follow the description above. There are two critical steps here:

  • Scanning, this needs to be done to have the fingerprints. Wait for the scanning to complete for all the files.
  • Matching the scanned files to your release on the right. Only if the scanned files are matched to the proper recordings you can submit the IDs.
1 Like

Well, the intention may be that the AcoustId button should never show up when the files are in the middle pane, but that is exactly what I am seeing. I’m merely reporting that the only time I can get it to light up is with files dragged into the middle pane. I can’t say why. Presumably, that’s for the app developers to sort out. You say that scanning needs to be done to get the fingerprints. I get that, and I am always waiting for the scan to finish. Scan is only an option in the middle pane, so it seems logical to assume the operation would happen there, no?

In any case, sorry, my eyes are glazing over at this. It’s too complicated. After working in the IT business for over three decades, my Spidey sense tells me that this part of Picard needs to be rethought. :slight_smile:

I made a small screencast showing the entire process, starting at the point where the already tagged files are loaded on the right:

If this lights up when all files are on the left than indeed this would be a bug and should be reported at https://tickets.metabrainz.org/projects/PICARD/issues/ . But it is hard for me to reproduce this currently because I don’t fully understand what you are doing and what the end result of your screen is.

Yes, Scan currently is only available in the middle pane, because it is a search function (“Try to identify the selected files by their AcoustId fingerprint”) and is applied to unmatched files, just as “Lookup”. But Scan is something different then submitting AcoustIds, submission only makes sense for properly matched files on the right.

The problem is that Picard has no direct functionality for exactly what you want to do.

What you want to do: For new files you already matched to the proper release generate the AcoustId fingerprint for submission. You want to contribute data to AcoustId / MusicBrainz.

What Picard currently offers: Searching for matching recordings based on the AcoustId fingerprint (the Scan button).

The only way to currently solve your use case is to basically misuse the search function, because it also generates the fingerprints, but that is only part of what it does. So the whole drag left, drag right issue is to workaround the parts of the Scan button you don’t need for this use case.

We already have a ticket to provide fingerprint generation independent of the search functionality.

3 Likes