Sleepy Server; 504 Gateway Timeout

error
sleepy-server
504-gateway-timeout
classical
relationships
musicbrainz
Tags: #<Tag:0x00007fcb4cb404c8> #<Tag:0x00007fcb4cb402c0> #<Tag:0x00007fcb4cb40108> #<Tag:0x00007fcb4cb40a18> #<Tag:0x00007fcb4cb41fa8> #<Tag:0x00007fcb4cb434e8>

#1

Hi there,
I’ve tried to add a great bunch of releationships for this classical 4 disc release:


When submitting I get an error message:

Any idea how I could save my work? I don’t want to loose the work of half a day :cold_sweat: :crazy_face:
Any workaround appreciated…

Thanks,

ClæpsHydra

PS this isn’t the first time I recognize this. Before I could submit my edits anyway after waiting a short time. But today not, tried 4 times


How to deal with running out of time while working on an edit?
#2

I got something similar recently when trying to add a small number of ‘parts’ relationships to a very large series (BWV). I was only able to do it the other way round (adding ‘part of’ relationships to the individual entities). I don’t know how to save state in a situation like this but would also be interested if there is a way. Also, maybe the timeout is too short?


#3

It’s unfortunately due to the current load issue on our database server. Large requests are impacted first. We are working on improving the situation by isolating services and changing load balancer. Nonetheless, it is not recommended to keep an editing form open for half a day, not only because of load issue, but also because other editors might change the data you are working with in the meantime. Thus a workaround is to submit more smaller sets of modifications, which have another advantage: edit notes can be made more specific.


#4

In this example, I was guilty of something myself. It became more complex and elaborate than expected. I’m relatively new to this classical area and had to read much documentation and HowTos in parallel. Time consuming… Then I had to interrupt because of an appointment and could first continue (much, too much) later…

Is there any hint as to which time limits, number of relationships or for which kind of relationships this becomes particularly critical? Then I could consider that in the future.

By the way: In the meantime I had to reboot my computer due to an other problem and all is lost anyway :confused: