Save 'errors'


#1

When saving with rename and move options, Picard displays an error for the first one or two tracks of each disc (see image). But the tracks are saved correctly. Is this a known issue?
(Windoze 10)


#2

For what it’s worth, I have not seen such behaviour. I am using Mac OS X, not Windows.


#3

I’m using Windoze 7 here, and I’ve never seen it do that either.


#4

file attributes are set to read-only.


#5

Sorry, I don’t understand. Are you referring to a Picard option? I don’t see one like that.


#6

Go to Windows Explorer, right-click on the files and select Properties. If the check-box “read only” is checked, you should uncheck it and save the properties. Of course there could be other reasons for this error, but files being read-only is the usual suspect. You can also check the activity log under the Help menu in Picard to see what happens when you try to save those files.


#7

Linux user here. I started seeing this happen with the first track in a folder after the last release (I think). MD5 indicated the file doesn’t change (if no tags are changed).


Picard too fast
#8

Just fixed the issue on my system.

Looks like when writing to a asynchronous file system (async NFS) Picard will get confused. It’s writing the file and then immediately trying to reading it to confirm it was saved. It’s doing this too fast and on slower storage systems the file has been not be committed to the disk before Picard tries to read it. So it gives you a file not found error.

This explains why I was able to fix it by forcing synchronized transfers on NFS. I am now making Picard wait (in I/O wait) for the write to complete before the read can be executed.

So this may be an issue with network storage protocols. An easy fix might be to add in an option to delay the confirming read by x amount.

Or I’m totally wrong.


#9

I think you may be right here. The error on my system happens only when I am renaming and moving files from the local drive to the NAS and then only on the first one or two files. The files are being saved OK - it’s just that Picard thinks they are not.


#10

i wouldn’t have thought of that. way to go.


#11

Glad you found a work-round. It sounds a bit technical, though. Any idea how I might do something similar on a windoze machine?


#12

This is going to sound pretty old school, but on my Windoze machine, I first copy the files to be processed from the NAS to a local drive on the computer. I make sure that the target directory for Picard is also on the same local drive, and then when the processing is complete I move the processed files back to my NAS. It’s a tiny bit more work for me, but overall the processing seems faster and it avoids all the problems with Picard reading from / writing to the NAS.


#13

I guess that is the simple work-round. Maybe I was trying to be too clever and use Picard’s naming and moving options to move the file to the NAS after tagging it. I could always just make that a manual step :face_with_raised_eyebrow: