Problems with ISRC batch-add

I use for adding ISRCs to releases. But the website sometimes does not work properly - especially with new releases.


After entering the MBID, i only see the title and the submit button. Is there a solution to this problem?

1 Like

Have a look at this post:

Bascially you can store the following bookmarklet (what is a bookmarklet) in your favourites toolbar:

javascript:var mbid=location.pathname.match(/^\/release\/([a-f0-9]{8}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{4}-[a-f0-9]{12})/);if(mbid)void(open(""+mbid[1]));

And then go to your release and click the bookmarklet.
Then you can paste a bunch of ISRC to submit, like shown in the demos (animated GIF).


I’ve got another problem. When all ISRCs are collected and I try to submit I get and endless loop to login with username and password. After aborting this I get an “Authorization Required” error. Maybe a problem with my username ClæpsHydra or password with special characters??

When I’m trying with command line tool isrcsubmit it doesn’t work either

I doubt it will work because you’re supposed to use what I’m suggesting in URHREF itself, not in the popup, but could you try: Cl%C3%A6psHydra instead of ClæpsHydra?

Your password has special characters as well?

If you need to encode something else, paste this in your browser address bar and then type/paste what you need to encode:

1 Like

Yes, it has special characters as well. I’ve encoded both as you suggested and tried it again with web-interface and isrcsubmit on the command line. Problems keep still the same. But a different error by isrcsubmit

As a test workaround I created a new account without any special characters in name and password (ClaepsHydraISRC). Again I’m not able to submit any ISRCs:

1 Like

Shame on me :blush: With the new account ClaepsHydraISRC both clients (web, isrcsubmit) work fine. I simply missed to activate my new account per send email verification link…

1 Like

Seems like something that should still be reported if it’s not just wrong/missing encoding of the username (and/or password) on “your” end (ie., probably in the software you’re using, which should then have issue(s) filed against them).


If you want to report issue, @ClA_psHydra, here is some context:

The bookmarklet is just a wrap around (enables pasting all ISRC at once) @kepstin’s magicisrc which makes your own browser call MusicBrainz’ /ws/1/track web service.

The other tool you tried is @JonnyJD’s which is also calling the same web service, I believe, as we cannot submit edit notes along ISRC either (a known limitation of that web service) — I don’t know if it uses updated v2 /ws/2/track web service.Apparently, it now uses python-musicbrainzngs, which does use updated v2 web service. Good point for your issue, as v1 is no longer supported.


@Freso, @jesus2099: Thanks for the help. I reported with:


I have been trying to figure out how to add my username and password to the bookmarklet but have not been able to find the instructions to do so. I came across some mention of it a while ago but I was reading on my tablet and have not been able to find it again. Any help would be appreciated.

I’m asked for my login/password at the last step of the submission through a basic web browser popup.

That is how it works for me also. I have been trying to figure out how to automate that step so i don’t have to walk over to the keyboard and type it in. The point where I add the ISRCs in my workflow I am across the room scanning cover art while checking on a calibrated monitor and have the mouse with me. just trying to iron out the little bumps in the my workflow.

PS the mediatools.exe that you host comes up as infected when I downloaded it, that may be why your copy is larger than others of the same version.

1 Like

With what antivirus?
Updated McAfee does not see anything wrong.

Panda Dome stops and quarantines it soon as I try to execute a command. But it does not categorize the file as a PUP or a specific virus like it does when it finds other things in my VM for downloading and testing. The media tools which I use is the same version does not trigger anything and works fine for using your solution for grabbing ISRCs directly from CDs.

1 Like

@therealdero I think you’ll find that Panda is giving you a false report there. Often when a file in not widely known about some of the lazy anti-virus vendors just mark it as bad. I use Eset AV and that shows it at clear.

A better test is to use and the file can be confirmed to be okay. @jesus2099 has had that thing up there for years without it changing.

Here is the full clean bill of health for the @jesus2099 mediatools.exe

1 Like

Wow thanks very much @IvanDobsky!
I was looking for something like that since @therealdero told me virus problem but didn’t find this great online scan tool!

Maybe it would be nice to move posts 15 to 18 (this one) to a brand new “Online virus scanner” (Genral chatter, no category) topic?

1 Like

That is a very useful website. It is far too common to hear of false positives. It is especially comical when the claim is made about a file that has sat quietly in a hidden corner of the internet untouched for years…

(I would leave these posts where they are. Other people will have carp virus scanners. These posts will reassure them that your mediatools.exe is safe)

1 Like

I’m not going to argue about which virus scanners are good and which ones are bad. I’ll just use the heuristic method of teaching about heuristic scanning. If you actually read the website response you posted you will see why I’m laughing after reading your response. But to each there own, There is a difference between scanning a static file and the behavior while being executed. It is also funny to believe that there is nothing wrong with two files that are supposed to be the same program and version but have different checksums.