Problems with ISRC batch-add

I’m just trying to help, most people do not change the default scanning settings and I’m not sure if mcafee even has the detailed options it once did, the default settings do not protect you very well. But take a look at the scan you posted my scanner is also listed on the front page as not finding anything. Now take a look at the behavior tab and look at all the things this thing does when executed. Do a search for * “oleacc-msaa-loaded” just for one. Ask yourself why is it accessing the WinINet Functions of windows, it is cleaning up after its self. now compare all those registry keys accessed and network functions called on and the whole list of things it does, that have nothing to do with its function, to this scan of the clean file. Believe me I am only trying to help.

1 Like

This behaviour tab says:

Network Communication
UDP Communication

I don’t think this tool was supposed to access network indeed… :thinking:
I will try to get a hand back on the older version to scan it worth same tool. Not easy without the good old PunBB forum.

Did you click on the next tab down and switch from the sandbox to tencent habo where you can see info I was talking about?

Also under the details tab you can see the commands it is executing with each .dll by expanding the sections under imports.
My copy

@IvanDobsky’s copy

@IvanDobsky thanks for pointing this tool out it almost replaces all the functions of the Virtual Machine I use for downloading and testing files before allowing on my main system.


@therealdero - I am glad you like the site. It is certainly handy quick check to add to the toolbox. I agree that relying on a single anti-virus test is madness. Especially something dubious like McAfee. I also agree with your sentiments that files should be investigated properly, but personally I did not have the time to fire up Wireshark or try and sniff a tool like this. I also didn’t really want to go charging down a tangent of security tool comparisons.

I have a much easier rule - don’t trust anyone. :smiley:

Just a heads up: It looks like RawGit (which the bookmarklet uses) is shutting down next year. Not until October but something to keep in mind. Migrating the script to a Github Pages page or something else should probably be done sometime before then.

1 Like

Tried both, went nowhere.

@kepstin’s magicisrc seems to be outdated: Looping authorization, ISRC:s that will not be submitted nor deleted from edit view, and are remembered thus stuck; and recordings have the expected titles but wrong MBID:s. All I got was this blank-named octet-stream to save/open which I cannot.

@JonnyJD’s is a zip (Win) done and dandy, but the README.txt tells me to stop reading, and its only .exe just flickers black and that is it. Maybe because it is 32-bit and no 64 available? isrcsubmit-2.0.1.tar.gz is another one, too other for Win7 and 7-Zip to handle, and latest action at “4 years ago”.

Every now and then EAC picks up ISRC:s at rip, and it would be nice to batch-add these.

Last time I used it with the bookmarklet was on 2019-01-08.

1 Like

So it should run fine then. Would you mind stepping me through it? I have a release tried with the above result, and a “clean” other one.

Please tell what is the example release or try to follow my video of how to use the bookmarklet.
Go to your release, click the bookmarklet then follow my video (basically you just paste all the ISRC at once from the first cell, then you press enter if everything is correctly in place and then submit and then indeed you should receive a 0 bytes file but that’s normal).

1 Like


The above tried:

Anew with Hindemith: Script remembers the already pasted-in ISRC:s, has them listed from before. Submit:

You must specify a ISRC to submit For usage, please see:

Back to edit form, paste ISRC:s again (they turn yellow), submit:


Info: Medium 1 Track 1: already has ISRC DEC989400170
Info: Medium 1 Track 2: already has ISRC DEC989400171
Info: Medium 1 Track 3: already has ISRC DEC989400172

Edit Preview

where listed recordings have correct titles but wrong MBID:s, as said before. Now what?

1 Like

Oh, it seems I was stuck just waiting for something else than error messages. shows it worked at 1st try, and I just did the other release to confirm ( Note to others: Discard octet-stream, error messages, green or red lights (and yellow). After submit, check “All My Edits” instead, and post that Edit note.

@jesus2099: Thanks! What should I call the script/version in the Edit notes? “Kepstin’s Magic ISRC submitter”?


Also noticed another thing good to know: The “incorrect MBID:s” mentioned are bastard links. F.i. in the quoted Edit Preview a couple of posts up, we have

but that URL has… followed by the Track MBID otherwise correct. In the URL, swap “recording” to “track” and you have it. Why this, dunno.

1 Like

Just a fyi: The “magicisrc” page is a very simple Javascript page that uses the MusicBrainz apis directly. As long as the APIs don’t change (which is pretty unlikely), it should continue to work.

The “octet-stream” issue is simply a result of how the Javascript application sends the “add isrc” api request - it’s redirecting your browser to the API endpoint, and the API endpoint isn’t designed to be accessed from a browser. It might be possible to improve this on the MusicBrainz server so it’s a bit nicer, but it’s out of my control.

(also: thanks for the bug report about the edit preview links being incorrect - that should be a fairly quick fix on my end)

Note that the magicisrc page does show all of the ISRCs that are already attached to the recordings for reference, but this is not an editor - if you need to remove ISRCs, you have to do that on the MusicBrainz site.


Ahh, turns out that I completely forgot that the APIs are going to change - and very soon, as ws/1 is deprecated and will be removed in the next couple of MusicBrainz server updates (probably no more than a couple months, maybe sooner). I’m going to have to make some updates to magicisrc, probably to implement OAuth2 - stay tuned.


A hint on this in plain text on the edit/return page would save time and effort for newbies.

Naturally, yes. Problem here was mainly me presupposing an already attached ISRC to be present under Recording Details, were it is curiously not, and not even looking way out right on its MBID page.

Thanks for your effort too.

1 Like

I am having another issue this time when ever I try to add isrcs it gives me the message of the link to the metabrainz blog which I dont even know how that got there and I wasnt even having issues with it until this morning

1 Like

Having the same problem. I hope this is fixed. I usually use the Spotify-ISRC bookmarklet, however, this would be nice for the times that Spotify doesn’t have the release.

I’ve tried asking people see when there gonna fix it but they always say it will be fixed when it’s fixed which doesn’t help things so that is why I am hoping a coders comes a long this thread that is willing to fix it

@kepstin’s magic-isrc beta should work with the current server.

I’m not sure what’s the current status of @jesus2099’s tools :slight_smile:


I am now using @JonnyJD’s all the time I need to submit my discs’ ISRC.

Now, there are two pending projects if you want to be able to mass paste ISRC to submit a whole non‐CD release ISRC: