Problems with ISRC batch-add

Panda Dome stops and quarantines it soon as I try to execute a command. But it does not categorize the file as a PUP or a specific virus like it does when it finds other things in my VM for downloading and testing. The media tools which I use is the same version does not trigger anything and works fine for using your solution for grabbing ISRCs directly from CDs.

1 Like

@therealdero I think you’ll find that Panda is giving you a false report there. Often when a file in not widely known about some of the lazy anti-virus vendors just mark it as bad. I use Eset AV and that shows it at clear.

A better test is to use and the file can be confirmed to be okay. @jesus2099 has had that thing up there for years without it changing.

Here is the full clean bill of health for the @jesus2099 mediatools.exe

1 Like

Wow thanks very much @IvanDobsky!
I was looking for something like that since @therealdero told me virus problem but didn’t find this great online scan tool!

Maybe it would be nice to move posts 15 to 18 (this one) to a brand new “Online virus scanner” (Genral chatter, no category) topic?

1 Like

That is a very useful website. It is far too common to hear of false positives. It is especially comical when the claim is made about a file that has sat quietly in a hidden corner of the internet untouched for years…

(I would leave these posts where they are. Other people will have carp virus scanners. These posts will reassure them that your mediatools.exe is safe)

1 Like

I’m not going to argue about which virus scanners are good and which ones are bad. I’ll just use the heuristic method of teaching about heuristic scanning. If you actually read the website response you posted you will see why I’m laughing after reading your response. But to each there own, There is a difference between scanning a static file and the behavior while being executed. It is also funny to believe that there is nothing wrong with two files that are supposed to be the same program and version but have different checksums.


We sure need someday to get that old forum topics back online for reference.
It was posted there. My version bigger file is an updated version.
I could only be sure if I could see those old posts.

That must be why I can’t find the post about adding the auto login to the bookmarklet.

@therealdero I was not having a go at you or saying you did anything wrong. I just supplied an independent check for the file in question. Apologies if you took offence, it was not meant. :slight_smile:


I’m just trying to help, most people do not change the default scanning settings and I’m not sure if mcafee even has the detailed options it once did, the default settings do not protect you very well. But take a look at the scan you posted my scanner is also listed on the front page as not finding anything. Now take a look at the behavior tab and look at all the things this thing does when executed. Do a search for * “oleacc-msaa-loaded” just for one. Ask yourself why is it accessing the WinINet Functions of windows, it is cleaning up after its self. now compare all those registry keys accessed and network functions called on and the whole list of things it does, that have nothing to do with its function, to this scan of the clean file. Believe me I am only trying to help.

1 Like

This behaviour tab says:

Network Communication
UDP Communication

I don’t think this tool was supposed to access network indeed… :thinking:
I will try to get a hand back on the older version to scan it worth same tool. Not easy without the good old PunBB forum.

Did you click on the next tab down and switch from the sandbox to tencent habo where you can see info I was talking about?

Also under the details tab you can see the commands it is executing with each .dll by expanding the sections under imports.
My copy

@IvanDobsky’s copy

@IvanDobsky thanks for pointing this tool out it almost replaces all the functions of the Virtual Machine I use for downloading and testing files before allowing on my main system.


@therealdero - I am glad you like the site. It is certainly handy quick check to add to the toolbox. I agree that relying on a single anti-virus test is madness. Especially something dubious like McAfee. I also agree with your sentiments that files should be investigated properly, but personally I did not have the time to fire up Wireshark or try and sniff a tool like this. I also didn’t really want to go charging down a tangent of security tool comparisons.

I have a much easier rule - don’t trust anyone. :smiley:

Just a heads up: It looks like RawGit (which the bookmarklet uses) is shutting down next year. Not until October but something to keep in mind. Migrating the script to a Github Pages page or something else should probably be done sometime before then.

1 Like

Tried both, went nowhere.

@kepstin’s magicisrc seems to be outdated: Looping authorization, ISRC:s that will not be submitted nor deleted from edit view, and are remembered thus stuck; and recordings have the expected titles but wrong MBID:s. All I got was this blank-named octet-stream to save/open which I cannot.

@JonnyJD’s is a zip (Win) done and dandy, but the README.txt tells me to stop reading, and its only .exe just flickers black and that is it. Maybe because it is 32-bit and no 64 available? isrcsubmit-2.0.1.tar.gz is another one, too other for Win7 and 7-Zip to handle, and latest action at “4 years ago”.

Every now and then EAC picks up ISRC:s at rip, and it would be nice to batch-add these.

Last time I used it with the bookmarklet was on 2019-01-08.

1 Like

So it should run fine then. Would you mind stepping me through it? I have a release tried with the above result, and a “clean” other one.

Please tell what is the example release or try to follow my video of how to use the bookmarklet.
Go to your release, click the bookmarklet then follow my video (basically you just paste all the ISRC at once from the first cell, then you press enter if everything is correctly in place and then submit and then indeed you should receive a 0 bytes file but that’s normal).

1 Like


The above tried:

Anew with Hindemith: Script remembers the already pasted-in ISRC:s, has them listed from before. Submit:

You must specify a ISRC to submit For usage, please see:

Back to edit form, paste ISRC:s again (they turn yellow), submit:


Info: Medium 1 Track 1: already has ISRC DEC989400170
Info: Medium 1 Track 2: already has ISRC DEC989400171
Info: Medium 1 Track 3: already has ISRC DEC989400172

Edit Preview

where listed recordings have correct titles but wrong MBID:s, as said before. Now what?

1 Like

Oh, it seems I was stuck just waiting for something else than error messages. shows it worked at 1st try, and I just did the other release to confirm ( Note to others: Discard octet-stream, error messages, green or red lights (and yellow). After submit, check “All My Edits” instead, and post that Edit note.

@jesus2099: Thanks! What should I call the script/version in the Edit notes? “Kepstin’s Magic ISRC submitter”?


Also noticed another thing good to know: The “incorrect MBID:s” mentioned are bastard links. F.i. in the quoted Edit Preview a couple of posts up, we have

but that URL has… followed by the Track MBID otherwise correct. In the URL, swap “recording” to “track” and you have it. Why this, dunno.

1 Like