Picard not saving tags


#1

Hi! My first post.

I use iTunes for my album collection and many, but not all, of my albums have tracks that start with the track number.
e.g
Bob Dylan 1-01 When I Got Troubles [Home-Recording].

Up until now, I have had to go into the iTunes info to edit every track to remove the number in the title and reference the track info in the track section of the “Info” section

I have tried several times using Picard to change the title by using “%artist% - %title%” and it works although it sorts the album alphabetically not by track in the folder.

However, when I add the album to the iTunes library, the track number reappears.

When looking at the file info in Mac’s Finder app, Picard changes the name of the file but not the title.

Any advice would be most welcome, Thanks


How to prevent MusicBranz Picard from adding a track number in front of the File Name when "Rename Files" is checked?
#2

If you say Picard does not change the tags, do you have “Save tags to files” enabled in options?

EDIT: I also moved your post to a new topic, as it is unrelated to the topic you replied to. Please make new topics for new issues.


#3

See also, in case you are tagging WAV files


#4

I am not tagging wave files they are mp4.

Here is the info of one track. You can see that Picard has altered the file name after saving but not the title.


#5

And what about Picard options, do you have saving tags enabled?


#6

No I did not and now it works fine, thank you very much for your help.