Picard Keeps Freezing

picard
Tags: #<Tag:0x00007f6d822d7f20>
#1

In the past month or so Picard started freezing after about 10-30 secs. It won’t even let me “X” out of the program. I have to close it through the task manager. I noticed there was a problem like this a couple of years ago with the library being too big, but figured that would have been fixed by now, – and I do have a very large library – and again, this just started happening. I’m using Windows 10. Any help?

0 Likes

#2

What version of Picard are you running?

What plugins are you using?

Updating to the newer version should help, but not all plugins are on v2 so it depends what you need.

How many albums are you trying to add in one go? How much artwork do you download?

When is this “freeze” happening? Is that when you have hit SAVE and it is editing files? Or when you transfer something to the right hand side so it is doing lots of database lookups?

If you are tagging multiple albums in one go then Picard can go very quite, and even grey out as “not responding”, but do be patient and just leave it to it. It is working hard in the background. Some artwork is now getting to VERY high resolution levels and if you are like me and try and download all available images you can get comical stalls even on fast connections. There is just so much data to download, and then shove into the files.

Also note that Picard has to be polite with the server too, so has various rate limiting code inside so it leave gaps between requests.

4 Likes

#3

Thanks Ivan for your response. I’d post the Debug info but it won’t even stay stable long enough to do that.

2.1.3

As far as I know, none. I’m assuming if it shows I can download on the right hand side of the plugins, this means I don’t have it installed. I’ve all restored all defaults as well.

I currently have 16,965 Albums
142,692 songs.
I only edit/lookup one album at a time.

I’ll open it up, after about 10 -20-ish seconds, regardless of what I am doing, it will freeze. No buttons/tabs will respond. Interestingly enough, if I’m able to open a separate window within that time, I can move the window but get no response from any button.

No matter what I’m doing, as long as I can complete the task within that 10-20 second period, everything works fine.

Same. I can save, edit, look up, etc. But after 10-20 secs, no response.

Also, I never/rarely tag multiple albums; one album at a time unless it’s a box set.

0 Likes

#4

Your answers should imply that Picard has a very fuss free simple time. Yet you get a stall. Even stranger that it waits on that same time period.

Where are the files you are editing? Local hard disk, USB attached disk, network?

Nothing obvious standing out initially. Worth trying is a “reset to defaults” by deleting or renaming the picard.ini file. Go to %APPDATA%/MusicBrainz/ and rename the folder to MusicBrainzHidden (or anything to hide it). That will make Picard start up as a totally fresh install.

If the problem has stopped, then post the picard.ini file up here as something could be broken in it. (I’ve see at least one example of that)

Also - what language is Picard running in?

1 Like

#5

Even if you do nothing ?

0 Likes

#6

I’ve let it run for about 20-30 minutes in the background thinking it would come back, but to no avail, as Ivan said above, it just “stalls.” (And that’s the perfect word for it, “stalls.”)

I’m going to do a clean install and delete the folder, as suggested by Ivan above, and report back. I will say I did move my music onto a new HDD from a 3T drive to a 6T drive recently, I’m not sure if that could have something to do with it.

I’ll report back.

0 Likes

#8

@IvanDobsky @Zas

Okay. So I did a fresh install deleting all APPDATA – Local & Roaming. And…

Same thing. A complete stall of the program after about 20 seconds.

I also did another fresh install onto my windows boot drive (EVO 250G M.2) thinking maybe it doesn’t like being on a separate drive – and without pointing to my music drive. This gave me the same “stall” results.

I’m at a loss of answers. I’m assuming no one else is experiencing this problem?

0 Likes

#9

What’s still not quite clear to.me is when this stalling happens. Does it happen even if you do nothing? Or on specific actions, e.g. when loading, clustering or saving files? Does it depend on the amount of files loaded?

In general Picard has some known performance issues when too many files are loaded.

1 Like

#10

You don’t tell us exactly what you’re doing (or not). Do you just start the program, it loads, the UI is displayed and you wait 20 seconds then it freezes ? Or do you do any action in between ?

We are aware of performance issue and UI somehow freezing when tagging/saving a lot of files (i tend to think it only happens on windows, never experienced this behavior on linux even with 20k FLAC files, it’s slow, mainly due to rate-limited requests, and eventually size of files, but never “freeze”, it’s rather unresponsive).

But the problem you describe looks like an hardware-related issue, some hard lock, or just a serious bug.
Does the system report any abnormal processor activity ?

Also can you share your debug log ? As requested in https://picard.musicbrainz.org/docs/troubleshooting/

0 Likes

#11

Are you starting by trying to load your whole library? How many items are on the right hand side?

Use the Snipping Tool in Windows to grab a screen shot of what Picard looks like. You can paste that directly into a post here on this forum. Makes it easier for us to work out what you are looking at.

0 Likes

#12

Yes. It happens regardless of action or non-action.

It happens without regard to action, saving, lookup, etc. I did a fresh install, deleted APPDATA, and did not point to my music library on another disc with same resulting “stall.”

I’m now going to split my library into two separate folders and see if that helps. I’ll report results.

0 Likes

#13

Still the same “stall” after splitting the libraries.

I also did another clean install, this time onto the same drive as the music libraries (now split,) and still the same result.

0 Likes

#14

Yes. this is exactly what’s happening. It stalls even when I do nothing. I even tried to upload a video demonstrating what’s going on.

Also note I’ve just now split my library, and installed Picard onto the same disc as the libraries. Still stalls. I have also restarted, pointed to a music library, resulting with same stalled results. It all seems to happen within about 20 secs.

Debug logs nothing, but the stall possibly keeps it from debugging further.

I am not ruling out that it’s not hardware related. This did happen after I installed a new 6T Barracuda and moved my media libraries over. However, I don’t use Picard everyday, and the last time it worked would have been around two weeks prior to the HDD installation. As noted in other posts, I have installed Picard onto three different drives to include a windows drive (M.2,) non-essential program drive (3T Barracuda - the last known working drive,) and my new 6T Barracuda Media drive. All of these have given the same results.

0 Likes

#15

I was finally able to get Picard to show some debug info, and snipped it for you. This didn’t show up the last couple of times I tried it. I hope this helps. :wink:

Right after I snipped it stalled again.

0 Likes

#16

I think this is the part of your description that still confuses me :slight_smile: Picard itself does not care about the number of files on your disc as long as you don’t load any files into Picard. Picard does not work like some music players, it does not manage a database of your music library, it only cares about the files you select and load into Picard.

If you would actually load all these 140k files (or even half of it) at once this would somewhat explain the behavior. But if this happens as you say also directly after start without loading any files the number of files on your disc doesn’t matter.

1 Like

#17

That screenshot is handy. So it is a totally blank Picard. As @outsidecontext says, you have been confusing us talking about a “library”. The “Library” really is irrelevant here.

Picard “just” does lookups of the separate audio files you hand it in that session. Aiming to match those files to the online database. Once matched, that online MB database is then used to improve your tags in those files. Along with options to rename and move files. Once Picard is closed it then forgets where everything was. There is no library.

Interesting screenshot. You are sitting there on a blank screen. Meaning not a single music file has been opened. That eliminates ALL the music files and potential tagging\lagging issues. Nothing to do with library sizes.

We also know you have reinstalled and not enabled any plugins. So that rules those out. The deleting of the AppData\MusicBrainz folder means no old picard.ini to confuse anything.

I notice you are running from an “H:” drive - I assume this isn’t a USB connected external drive is it?

What language are you running in? What is selected in the OS and in Picard? Just curious why "Unsupported locale setting " in the log window, and I know there was another hiccup in a different language.

The trouble is, the more “bare to the bones” the installation is getting, the less and less it is looking like Picard can be causing this. So be ready to go down the rabbit hole of which AV, what disk controller, are drivers up to date, blah blah…?

Do you have any unusual setup on that PC? Special tweaks? Security lock downs? “Tuneup” tools like CCleaner? Things that adjust and tweak and mess with the standard OS? Anything messing with network access?

0 Likes

#18

Something ain’t right in that screenshot. At the bottom of the image it is stretched out so far it falls off the edge of the screen.

Is that overlapping two monitors in dual screen mode? Or just running on some 4K TV?

I can’t see the status bar at the bottom. And the section on the right for the artwork is also off the edge of the screen. Is it all on the monitor? Or has some fallen off the side?

That image is 2746*1263 - for the sake of testing lets get this down to something normal. At least so that debugging text is of use and readable. Bring everything back to a sensible size. Shrink to a window that is on ONE monitor and so you can see all sides of the window.

What Graphics Card are you driving those screens with? Do you make sure you have up to date drivers from the manufacturer, or rely on Windows update? I am wondering why the PC is struggling to display the text in the dialog box fully - something has truncated the screen refresh.

0 Likes

#19

I mentioned that I split it because I know in the past there was a problem with large libraries/media-folders. As I understand it it is because Picard had a hard time reading folders with over a certain amount of media files. To rule this out as a possibility I split the libraries in two.

0 Likes

#20

No. It’s installed. However, I did use it with an external drive for a few months before putting it in. (I don’t know if that would have been a problem.)

English. (You don’t mean computer language, right?) Windows 10 - everything is up to date. They both should be running English.

I tend to agree with you. But for the life of me I can’t think of what would cause it. The last known working physical config. would have had both the Picard program and my music files on the same “G” drive which is a 3T Barracuda. What changed? I installed a 6T Barracuda which I had in an external drive and moved all media files over. But you can’t necessarily rely on this because I hadn’t used Picard for at least two weeks prior to this, in which case Windows (or NVIDIA, java, etc) could have installed a new update screwing something up. But if no one else is reporting an issue than it can’t be a Windows issue.

Here’s a pic of my System Info:

The only thing not included in the info is my Video Card is a 1080ti. I also have an Oculus 3 sensor setup that is permanently installed.

I also highlighted an interesting (for me at least) entry. I’m not sure what this means or if it would have something to do with this problem.

I just didn’t snip the entire screen. I can if you’d like. However I’m running one monitor an, AGON 35" 3440x1440 Ultra Wide monitor 100hz.

Background apps: Asus RAM Cache II; Asus Keybot (unplugged since yesterday); Logitech G-Hub (speakers); Steam; NVIDIA updater; GPU Tweak II; Oculus; Firefox (56.0.2) 64bit
Virus Protection is run manually. No cleaner installed. Both CPU and GPU are overclocked.

Man, I just don’t know what other relevant information I can give you; the tagger does seem to work fine when used through Media Monkey.


EDIT
Could it be the size of the drive? You know I have VLC as my video app, and it’s been stalling as well for some unknown reason, and all of the media is now on this 6T drive.

0 Likes

#21

Handy replies. Even more items eliminated. (And I like my puzzles… I’m not an official dev, but IT Support is my thing… and fixing Windows boxes is the day job… I’ve been working with nVidia graphics since the days of the Riva 128 :D)

Drives should not have an effect. I mentioned external in case it was failing.

Languages and OS version - more defaults that should not be having an effect as you are all nice and boringly normal there. Not likely to have a broken translation getting in the way. Nothing odd about Windows or the obvious software.

Picard doesn’t care which drives files are on. Your disks are good quality, and should not be relevant.

Again - Disk size, type, etc is not relevant when Picard freezes WITHOUT ANY FILES.

Windows update is unlikely to have caused this. I have Windows boxes in various updates states so it won’t be a standard thing. That graphics card should handle the monitors fine - but do make a visit to nVidia and download the latest drivers. They’ll always be better than what MS throws at you.

There is no reason the monitor should be causing problem, but shrink things down to make sure it isn’t something daft like that. Make the window an easier size so we can help debugging. At least help us to help you :wink:

Your drive sizes are not that odd. And NOT RELEVANT as you are NOT loading up the library yet. So y9ou can stop dancing between drives with your tests. I have my collection on 4TB and 8TB internal drives and Picard doesn’t care about those kinds of details. I’m also tagging on SSD’s, over the network, anywhere - that is not an issue. (Just making sure they are not failing)

As Picard crashes with NOTHING on screen and NOTHING yet loaded then it is NOT disk or music file related. When you start Picard and leave it sitting there, it will be going no where near your files. The most it is doing is checking if there are any updates on the MB server. Basically it should just be waiting and twiddling its thumbs and doing nothing…

With your specs, there is nothing too weird in that list. Apart from the old classic of running “on the bleeding edge”. If you are running an over clocked machine then there is always going to be potential for troubles when something asks it to work harder. Back off the overclock and see if it makes any difference.

Your blue highlighted line on the Sys Info is telling you that you have turned off the security options in the BIOS. Not relevant to the debugging task in hand.

Another check worth doing - disconnect some of the toys. The Oculus, even the G-Hub. Reduce the load on the machine. See if Picard stays up longer than 20 second.

Check the network card. Maybe even do a test with the network cable unplugged. Is your overclocking changing the PCI bus speed? Are you overclocking the network card?

Running without AV - mad, but your choice. Do run a proper check with something decent to make sure you are not infected. But killing Picard after 20 seconds would be an odd thing for a virus to do :smiley:

0 Likes