Non-latin artist "default" name for composer tag


Lets take for example this one:

He has “古川毅” as default/base artist name (though sort field name still has Latin “Furukawa, Takeshi”).

If i prefer to have Latin name in my composer tag field, what can i do (excluding manual renaming ofc)? As i know Picard operate artist aliases only for artist fields, but not for composer/other fields.

Try some of the settings in Options / Metadata.

1 Like

But these settings only work for “artist” field, no? Does in your example composer field for example also in Latin?

I have loaded all the releases by this artist into Picard and none of them set a Composer Tag on any track.

Since Composer is associated with a recording or a work, and since I cannot find any releases by this artist that have those associations, this is not surprising.

Please provide some example releases where Composer is defined but not translated.

This one for example:


Ok, thanks, i got one thing. Either the setting “translate names” was somehow disable earlier for me, or may be i used quite old Picard version before.

Another question - what define this “English” version name for artist? An alias? Could you tell me then why this don’t work for this artist for example?

This release:

This is how it looks for me now: artist translated, composer - not.

In general it also works for artists in advanced relationships, with one important limitation: the latin name gets guessed from the sort name, as the full list of aliases is not available in the release response for relationships.

There are open tickets to male alias translation also available for relationships, see e.g. PICARD-758 and PICARD-758.

As a side note, guessing the latin name from sort names was how the translation feature originally worked in the very early versions of Picard.

So i suppose for now there is no guaranteed working option?

Also, @outsidecontext , can you check this thread and last Reosarevok’s post (a question to you)?