No sound although player displayed

Tags: #<Tag:0x00007f4d513e31b8>

CD wont play although plays in other players.

MusicBrainz Picard is not a player, you cannot play your CD nor any audio files with it.

:information_source: It was previously called MusicBrainz Tagger. :wink:

1 Like

It can for quite some time:

A new integrated media player toolbar. This feature is considered beta and is disabled by default, but you can enable the toolbar in the menu with View > Player. Please note that the file formats supported by the player depend on your operating system.

3 Likes

What OS are you using? Last time I checked it was working on Windows, but isn’t working on Ubuntu 20.04 (getting a “connection refused” message).

As there were not any recent changes to the player (link) or the PyQt version (link), I believe it must have something to do either with installed plugins or with a recent Dbus patch (link).

The player is not working for me as well. Plays neither FLAC nor MP3.

  • Platform: Windows 10 2004
  • Picard version: 2.4.1

Debug log is very nondescript (verbosity: debug):

W: 22:11:00,526 ui.mainwindow.set_statusbar_message:392: Internal player: error, code=1, msg=

Is all that is printed when trying to play a file from the right-hand pane.

1 Like

Hmm, then is not the Dbus patch. No idea what could it be.

Oh, I think I got it. Working on a fix.

Update: nope, I have no idea. At least on Windows, some files work and some don’t no matter what I do.
VLC can play both mp3 files.
Mp3checker said the file which Picard can play is broken while the file Picard can’t play is fine.
Mp3check said both are fine.

Huh, you’re right, it does play some MP3s.

I’m trying to come up with indicators that make a file work or not work in the player. So far, all files with no tags worked. But then again some files with ID3v2.3, ID3v2.4, ID3v1 (or a combination thereof) worked, though most of them don’t. Bitrate also doesn’t predict if a file will play, as my working examples range from 128kbit/s to 320kbit/s CBR. I don’t have VBRs to test.

So it looks like MP3s with no tags will play, but everything else may or may not.

None of the FLAC, AAC, Ogg/Opus, Ogg/Vorbis I threw at it worked.

There is no CD playback functionality in Picard.

The playback depends on the playback capabilities of the OS. Windows has no support for FLAC and Vorbis files by default. You can change that by installing the Directs how filters for Ogg. See also Microsoft’s Codec FAQ.

We used to have a FAQ entry for this, but it got lost with the doc changes recently. I’'ll make sure we add it back.

2 Likes

That makes sense. I think though that relying on the operating system makes the player feature not that useful, at least on Windows. From my testing, it doesn’t even work with MP3 files in a robust way, including files tagged by Picard itself.

Actually, it’s still there in the File Formats section of the Frequently Asked Questions chapter.

I have no idea about the issue itself, but as a reminder here what I was saying when this feature was added:

About after sale support, i mean i can already imagine user reports about X format not being supported on Y platform (or player not working at all), and we can’t do much about it since it depends on external stuff (Qt and its plugins), so that will be mostly time to research and answer to users.

It seems this is exactly what’s happening…

2 Likes