Newbie here. Picard seems to be prefering tags other than the original release


#1

I tried searching old topics but couldn’t find this question posted so I figured I’d create a new topic.

I tried to drag into Picard the song “The Sign” by Ace of Base (Title and Artist already tagged) in order to tag the album and year of release. This song in particular was released as part of the album “Happy Nation” in 1992. Unfortunately after pressing the lookup button Picard identifies the song as part of the Album “The Sign (Remixes)” which only contains 5 remixed versions of the single. For many other songs Picard places them in compilation albums such as “20 Best Pop Songs of the 90s” with multiple artists rather than the original release album.

Is there any setting I can change so Picard will tag a song with the data from its original release? If not I would like to manually select the album without entering each tag individually and I cannot figure out how to do that. Thanks for any help.


Incorrect album matching -album/compilation instead of album
Picard tags Compilation not Albums or Single [sliders don't seem to do anything]
Original album?
How to make MusicBrainz Picard download the right album tags?
#2

Most likely, the recording is the same, so Picard can’t be sure which album this file came from. Whenever it misidentifies, I go to the browser window, find the release I want it in, then click the tagger link from the browser. That will load the right album in Picard. After that, you can drag the song to the other album (and it should go to the right track automatically), or drag it to the specific track.

After it has written the tags from the correct album, it usually will keep it there.


#3

In addition to what thebradleys said, you can also change the release types Picard prefers in settings under Options > Metadata > Preferred Releases. If you prefer albums over other releases, drag the album slider further to the right. If you don’t do compilations often, move the compilation slider further to the left. That does not mean Picard will never match a compilation, but if in doubt and there are multiple matches it will more likely prefer the album over the compilation.

Also your example suggests that you were tagging a single file. That makes it a bit difficult for Picard, as the exact same song will often appear on a lot of releases, especially if it was popular and was included on many compilations. If you have the whole album it is better to cluster the files first, and then lookup the entire album cluster.


How to stop Picard from tagging songs from compilations
I want the Original albums Please help
#4

I’m glad you explained these sliders, because I have never known which side to slide them to. They really ought to have low/high indicators or numbers or something, so it’s not so vague.


Get rid of various artists
#5

To manually find it, type Happy Nation in the search bar with album selected and hit enter. A MusicBrainz search window will open in your browser and if you hit the “tagger” button for the correct release that will load it in Picard. You can then drop the file on the track in Picard (it will probably identify it if you just drop it on the album).


#6

Thanks for all you replies.


#7

3 posts were split to a new topic: Colour of “Preferred release type” sliders