MacOS not visible move / rename checked

See the picture below

Can you give details which version of macOS and Picard you are using? And it might sound stupid, but please double check if the options to rename files or move files are indeed checked in Picard > Preferences > File Naming, or “Write tags to files” in Picard > Preferences > Tags.

This is how the items are supposed to look like:

In my screenshot rename files and save tags are checked, move files not. The screenshot is with current Picard 2.6.3 on macOS 11.4 Big Sur, but it looks similar to me on macOS 10.12.

Please also make sure that if you use macOS 10.14 or later that you use the download marked as macOS 10.14+ (x86_64) on Downloads - MusicBrainz Picard . While for me on macOS 11 the version for 10.12 looks the same, it could have an impact. The 10.14+ build is better suited for more modern macOS.

In case you are running macOS Big Sur on new Apple ARM CPUs be aware that Picard is not yet available natively on that processor architecture. The issue might be related to this. Unfortunately it will likely take some time until we will provide a native build, see also discussion at Crash/Freeze when choosing Preferences/Options on macOS 11.2.1 w/ Apple Silicon M1 - #16 by outsidecontext


hi @outsidecontext,
i have the same problem on my macOS 11.6.1 (and also before but I don’t remember old previous os versions) (x86)
I tried some old releases and the last release with checkmark in this menu is the 2.2.2, the problem is already present with 2.2.3.
I think it’s something with to do with Qt.
I tired all releases between 2.3 and 2.4.4 and they crashed, version 2.5.0b1 works but without checkmarks in the menu.
The last release 2.8.1 has also this problem.

I just tried to change my language from french by default, same as my system, to english and there is no problem in english, but if I go back to french the problem is still here.

@_MOI just to confirm: the issue about checkmarks not showing exists only when Picard is set to French (can you check other languages?) but not in (default) English, and since 2.2.3 ?

It would be great if you could create a ticket for this, adding screenshots demonstrating the issue.
Can you confirm that’s just a checkmark visibility issue but options are still toggled?

1 Like

Hi @Zas, I made a few more tests and I was wrong.
I cannot say since when the problem is there. Version 2.2.1 and previos are showing checkmarks because Picard doesn’t thake the system language in count when UI langage is set to “system default” and this bug is resolved since 2.2.3.
The real problem is maybe in all other langages than english (UK, AU,…). I tried French, German, Italian and Spanish and all of them has the same problem.
But it’s only the display in the menu, if you click on the menu it will change the behaviour and the checkmark in the preferences.

I will create a ticket as you suggest.
Edit: here’s the link