How do i authorize picard to local musicbrainz

Tags: #<Tag:0x00007fd29dc85920>

i’ve set up picard up with the default public musicbrainz, which works but is rate limited.

I set up a local musicbrainz server using the docker instructions, and
i’ve just created and indexed a local musicBrainz, using the docker instructions,
and patiently did the re-index
the local musicbrainz server supports search.
when i update picard to set the music brainzserver to 192.168.x.x:5000 and try to login on the options dialog,
the browser opens on the local musicbrainz server but say’s login is forbidden.

i’ve tried bouncing picard and musicbrainz, to get past the login prompts i’ve re-using the public servers oauth tokens,

does authenticating locally require https? (and if so is that typically done via a reverse proxy? or can the docker image support that?)

not sure what to try next…
thanks in advance
GT

picard v Version 2.5.5 on ubuntu
musicbranz from docker (using http port 5000)

more info:
i had stopped just before “enable replication” step of https://github.com/metabrainz/musicbrainz-docker

i tried performing that and notice the following:

sudo docker-compose exec musicbrainz /usr/bin/tail -f slave.log
Invalid or missing REPLICATION_ACCESS_TOKEN in DBDefs.pm – get one at https://metabrainz.org at ./admin/replication/LoadReplicationChanges line 116.

however if i confirm the token via:
$ admin/set-replication-token
Please enter your MetaBrainz access token (will not be echoed)…
Thank you!
set-replication-token: token file already exists at: ‘/mnt/smallMirror/musicbrainz-docker/local/secrets/metabrainz_access_token’
Try ‘set-replication-token --help’ for usage.

(same with -f option)

so: is REPLICATION_ACCESS_TOKEN the “access token” found on the
https://metabrainz.org/profile page?

I moved this to the MB Development category as this seems to be more an issue of setting up a login for a MB mirror.

If I understand correctly your issue is that you cannot login to the mirror. I don’t know the answer to this, but have you registered a user for your mirror?

1 Like

Your access token will be written to the file local/secrets/metabrainz_access_token. You can check it there.

Are you sure you have executed the step to grant access to the token for replication with:

admin/configure add replication-token
sudo docker-compose up -d

The complete command to replicate to the latest data packages AND see the process on screen is this one-liner:

sudo docker-compose exec musicbrainz replication.sh & sudo docker-compose exec musicbrainz /usr/bin/tail -f slave.log

1 Like

Hi @gtbradley

You cannot authenticate to a local MusicBrainz server because it doesn’t have access to editor’s private data. You have no need to authenticate with Picard since your local MusicBrainz server is read-only and not rate-limited. SSL is not enabled either for local MusicBrainz server.

Yes, see the above reply to check that is set correctly for your local server.

2 Likes

This means in effect that you won’t have access to any user specific resources (collections, tags, ratings). For Picard that means:

  • Do not enable ratings
  • Do not enable “Only use my genres”

Then Picard should not ask for for authentication against MB server.

2 Likes

o.k. i think it’s the ratings that was the issue.

  • i confirmed the access key was were it should be (note: docker-compose up -d uses a cached container, so not sure if it picks it up).
  • i saw that a new docker version is available, so pulled that from git and rebuilt.
  • disabled ratings,
  • and logged out of server from picard options.

anyway picard is connecting to my local musicbrainz now,
thank-you
GT

2 Likes