Help for newbie to Musicbrainz Picard


I’m a newbie to Musicbrainz Picard but despite spending hours trying, reading documentation, and Googling the problem I am unable to tag tracks using ‘Lookup in Browser’. The browser opens and shows the album I want, but clicking the green tagger button does nothing. I’ve tried using a different browser, to no avail.
Please can someone tell me what I am doing wrong - I’m sure it must be something completely obvious to everyone except me. I’m not a novice with computers, but this problem has completely floored me.

Lookup in browser does not work


What happens when you click the green Tagger button?

What should happen is that the release or recording you’ve found in the browser will now be loaded into the rightmost pane in Picard. From there, you match your unmatched files to that by dragging them onto the newly-loaded recordings.


What browser and OS are you using? Do you have any browser extensions? Have a look at this older thread which might have some hints on how you can make it work:


Maybe also look at

Also the tagger button has AFAIK issues with HTTPs, not sure how the state is here and if there anybody had an idea how to solve it


Hi Alex

Thank you for your post. That’s what I understand should happen, but nothing gets loaded into the
right pane of Picard, so there’s nothing to match. From what I have read on various sites is that the problem may be linked to my OS. I’m using Windows 10 (64-bit) The tagger doesn’t work on Edge or
Chrome. I have Kaspersky Internet Security 2016 and have checked that the
website isn’t blocked. Kaspersky may perhaps be the problem – I’ve had to use workarounds for some
sites in the past. Any suggestions as to how I may make the tagger work would be most

Kind regards


I think the easiest step is disabling Kaspersky for a minute so you can check without it.
If that doesn’t work, we know it’s not Kaspersky :slight_smile:

Current Windows 10 + Chrome works for me.
If you need a workaround in the meantime you can click on the release in your browser, and then paste the release URL into the search bar in Picard, it should make the correct release pop up.


Thank you for your message. (My first attempt to reply didn’t work and I got a message saying ‘new
users can only put one image in a post’ Hopefully I have rectified that now.)

From what I have read on various sites, the problem may be linked to my OS. I’m using Windows 10 (64-bit) I usually use Chrome but the tagger doesn’t work on Edge either. Kaspersky Protection and Rapport are enabled extensions on Chrome. I have Kaspersky Internet Security 2016 and have checked that the website isn’t blocked. Disabling it doesn’t seem to help. I had a look at the thread you suggested in my search for an answer, but some of the possibilities were somewhat out of my ‘comfort zone’ in my knowledge of computers. I may need some expert help! I didn’t have any luck using the scan facility either. Any more suggestions as to how I may make the tagger work would be most welcome!

Kind regards


The tagger button integration works by linking to Picard listening on your local computer, the tagger link looks like

This could be seen as suspicious by your malware protection. Maybe you have to unblock this URL, too. Also this might make trouble if browsing on musicbrainz using HTTPS, try without HTTP.


Hi Philipp Second attempt – I got this error :

“We're sorry, but your email message to [""] (titled Re: [MetaBrainz Community Discourse] [MusicBrainz Picard] Help for newbie to Musicbrainz Picard) didn't work.


Sorry, new users can only put one image in a post.

If you can correct the problem, please try again.”

So I’ve removed the images and am trying again!

Sorry not to reply sooner – I’ve had a very hectic few
days, with no time to look at Metabrainz again. The tagger link comes up with a page saying ‘nothing to
see here’.Pop-ups were blocked so I unblocked the site and reloaded,
but no change. I don’t know how to browse without HTTP/HTTPS – how do I
do this? I can’t find an appropriate setting to change on Chrome. If you can help further I’d be really grateful – I would
love to get this working! Kind regardsAnn


Hi @anniew not sure if you mind, but just mentioning that you may want to remove your email address from that post if you don’t want to share it with the internet :slight_smile:


Now that’s a good thing, the text “nothing to see here” comes from Picard, so Picard is actually answering. Are you sure the release was not loaded into Picard? To be sure, please do the following:

  • If Picard is running, close it
  • Start Picard, do not load any files for now (just to have a clean user interface and log so we can see changes easier)
  • Perform a search from the search field inside Picard on the upper right. This will start a search in your browser on The purpose of this step is to have Picard opened Musicbrainz at least once, which will enable the green tagger buttons for your entire session.
  • Search some release on and hit the tagger button
  • Go back to Picard, the release should load in the right pane

If it does still not load, please open “Help > View Error/Debug log” and paste the output here.


I’ve tried that. The selected album appeared in the right-hand pane but
with the music symbols attached to each track. I still can’t get it to show the coloured rectangles I need to match the


That’s all that is happening with this function, it is to load an album into Picard which could not be matched by e.g. lookup or scan. You now have to match your files against the tracks by dragging them onto the loaded release