Error with links to artists

Tags: #<Tag:0x00007f419f01b6d8> #<Tag:0x00007f419f01b610>

Please take a look at this page:

Then put the mouse over bass player “Lisa Marie Geiß”, then tooltip shows “Bender, Kai”. If you click, it shows artist Kai Bender. If I want to edit the relationships, the artists are correct. I think it’s an error.

I tested it with Chrome and Edge.

2 Likes

Try reloading your page as it is working fine here.

image

Is your mouse slightly off centre with its pointer in some way and picking the line above? Try clicking on “Lisa” instead of “Geiß” - does that work okay for you?

1 Like

While this one is working fine for me, I have seen the describe issue elsewhere.
I wonder if this is associated with

No, it has nothing to do with reloading the page or my mouse pointer. Maybe with the German translation. I have also a different sort order like you. Take also a look at the tooltip when I hover “Lisa Marie Geiß”.

where does Kai go? is that still Kai or has he become Lisa?

odd. I flipped language and it still correct

image

If you flip languages, does the error follow?
image

Edit: Something else odd I notice. Why does my say “Komponist(in)” and yours has no brackets?

1 Like

Guess that’s the doing of an extension like Binnen-I be gone

1 Like

The only thing I can do in German is count and order Beer. So don’t know what a Binnen-I is. One of the reasons I pointed out the missing (in) is due to the other thread about translation issues. I wonder if these are both connected. Maybe worth running the browser without extensions.

I can’t reproduce this here either, tooltip is fine. Even that Firefox text butchering extension does not cause this. @Acccept But I’d still suspect some browser plugin or user script. I’d disable everything that might modify content for some reason and see if the issue still happens.

I think you are all set to survive here :smiley:

2 Likes

Be lucky that the English language does not have to care about this (most of the time). In English it is a male composer or a female composer, in German we have two different translations for them, “Komponist” (male) and “Komponistin” (female). This leads to abbrevations like “KomponistIn” (capital I is called Binnen-I = inner-I), “Komponist(in)” or “Komponist*in” if you intend to show gender-parity in written texts (and yes, this is a huge minefield of political correctness).
And as the link by chaban shows, there are extensions that will replace constructs like “KomponistIn” by simply “Komponist” which is probably causing the problems here and in the other thread.

3 Likes

Yes, it’s right, I use Binnen-I be gone. But I also checked it with Chromium-based Edge, which I usually don’t use and so there aren’t any extensions installed.

If I switch the language to English, the error is gone. It’s only in the German localization, but it has nothing to do with the extension, it also happens in Edge.

Edit: After I switch the language back to German, it’s still correct (I’m confused). If I close the browser and open the same page again, it’s still correct. But I don’t know why. (tested with both Chrome and Edge)