Disc ID added to Musicbrainz but metadata still not retrieved by dBpoweramp CD Ripper

Tags: #<Tag:0x00007fbc801153e8> #<Tag:0x00007fbc80115320>

Hi, I ripped a large number of my CDs over the summer using dBpoweramp. When I found discs where the Musicbrainz metadata was not retrieved by dBpoweramp , I added the disc ID to Musicbrainz using Musicbrainz Picard and then found that dBpoweramp retrieved the Musicbrainz metadata immediately afterwards.

I ripped some more discs about a week ago and again followed the same process and added a number of disc IDs to Musicbrainz. But one week later, dBpoweramp still does not retrieve the Musicbrainz metadata for these discs. For several discs where a disc ID was already in the Musicbrainz database (i.e. I did not need to add it), dBpoweramp successfully retrieved the Musicbrainz metadata. Has something changed or is there an issue between dBpoweramp and Musicbrainz database at the moment? Thanks.

I don’t know about dBpoweramp. I use beets for tagging and I just added a new album to MB. But I hope this can be somewhat useful. (I’m a noob though)

  • I added all the tracks
  • Copied the release id from the address bar
  • Told beets to tag using that id
  • Used acoustID for fingerprinting and then uploaded them to MB
  • After 5 minutes I tried re-tagging and it worked (was a test and not a necessity)

I noticed it took about 10 minutes before the cover showed up on MB, beets didn’t grab it though.

I would double check our software’s “tolerance” level. I noticed a huge difference between Picard and beets when retrieving releases information. Sometimes one will grab the right release and the other will suggest it as the 12th “alternative”. It might be that dBpoweramp checks for a specific release type, or only releases that have mandatory fields. For example, I tried to prioritize releases with a country and a date, but beets just stopped showing releases that didn’t have that info.
No idea if this could apply here or if I’m just blabing, but might be useful for a future, newer, user.

If dBpoweramp is querying their own run copy of MusicBrainz, maybe their local copy is no longer replicating (ie., new data entered in MusicBrainz isn’t making it to their copy of the data). Another option could be that they’re relying on web service version 1, but that doesn’t seem likely if some lookups work but not others.

Did you ask on dBpoweramp support channels?

2 Likes

I did ask in the dBpoweramp forum and they suggested the Musicbrainz database might not have updated but I can see it has.

It has been broken for me for the last few weeks.
I suspect they are still using the v1 api.

If it’s only been broken for weeks, it’s not related to ws/1.