Can't download the AcousticBrainz using a web browser cause it's ftp:// only?

Tags: #<Tag:0x00007f9d0d2b6158> #<Tag:0x00007f9d0d2b6040> #<Tag:0x00007f9d0d2b5e88> #<Tag:0x00007f9d0d2b5cf8>

I went to https://acousticbrainz.org/download to download acousticbrainz-gui-0.1-win.zip but as you can see the link is an ftp:// link which neither Firefox 88.0.1 nor Microsoft Edge 90.0.818.56 can open, it asks you to use a program.

Tried to get ftp links to open with winscp but that didn’t work cause it asked for login, finally managed to add it to winscp manually and get the file.

I remember that Firefox used to be able to browse in ftp’s back in the day but that seems to be a thing they removed, also chromium based edge can’t do it either so this seems like an issue. You shouldn’t need an ftp client to download files these days, and file downloads should support http.

1 Like

We previously had a related issue with Picard’s EU download mirror. You’re probably best off alerting one of the admins about it (paging @reosarevok @Zas @outsidecontext or whoever is responsible for these things).

1 Like

I’m not sure if Mozilla and Microsoft have already started disabling and removing FTP from their browsers:


or
1 Like

Well I sure can’t download the file using Firefox 88.0.1 and that tracks with what the first article says:

For general release, FTP will be disabled in Firefox 88 released on April 19.

At this point, when Firefox encounters an FTP link, it will attempt to pass it off to an external application.

Same with Edge and the 2nd article which is about Edge 88.

Thanks for the notification everyone, we’ll move this to an http download location.

5 Likes

These links have now been updated to use http instead, thanks again for the report.

6 Likes

Thank you @alastairp
Could you please adjust your website certificate to match the domain name?

We know that there’s a pending certificate issue for https on this domain. It’s currently being issued by the test letsencrypt environment. It’ll be fixed next week. Until then, you can ignore the warning or use just http.

5 Likes