Any way to add proper genres to the mp3s?

Is there any way to add genres automatically right now? Wikidata or metadata-genres are not working. The brutal death metal Band is not “funk / jazz / rock / trance / rap”

The genres on the musicbrainz website seem to be good but somehow picard doesn’t fetch them?

any help would be much appreciated!

Yes, but I’m a bit puzzled by this question because you already found out about the genre plugins.

One thing you should be aware of is that you should always only enable one genre plugin or the builtin genre support at a time. Behavior when enabling multiple genre sources is mostly undefined and you will get the genres from one source only (but won’t be sure which one).

Regarding which genre to use my following advice still is true (except that the mentioned bug for MusicBrainz genres of course is fixed now):

You need to enable fetching genres in Options > Metadata > Genres.


Ok let’s do this from scratch in case I’m forgetting something or doing something wrong, my brain was a bit foggy last night.

My procedure is as following:

I’m starting Picard

In Preferences -metadata - genres I have enabled:

  • use genres from musicbrainz
  • fall back on album’s genres
  • use folksonomy genres
  • minimal genre usage: 100%
  • max 4 genres
  • divided by “,”
  • took this genre list and added it:

Plugins and Wikidata disabled

I add a Folder with lots of different music
I cluster the files
I go lookup or scan - whatever works best

And then I should have the genres from musicbrainz?

Update: Weird, it seems to work. Maybe copy pasting the genres into that blank space in preferences did help. How can I make it add more than one genre?

1 Like

You don’t need to do this. Instead just don’t enable “Use folksonomy tags as genres”, then the genres you get will be limited to this MusicBrainz genre list.

If you want to whitelist the genres manually do it this way:

+acid house
+acid jazz
+acid techno
+acoustic blues
+acoustic rock

The first line blacklists all genres, then each line with a + in front whitelists this specific genre.

Set the number of genres, as you did. If you don’t get all the genres for a specific release it maybe is because some of the tags are not used as much. In this case lower the threshold to something lower then the default 90%.


So weird, today everything worked fine. Thanks a lot for your replies!

1 Like