All Supported Types issue when uploading artwork


#1

I don’t know if this is a browser issue or a MusicBrainz site issue. I am using FireFox 57.

When you click on Select images… when adding artwork a dialog box comes up for browsing to and selecting the image you want to upload. The file type selection defaults to All Supported Types.

What I see is this: All Supported Types (*.jfif;*.png;*.gif;*.pdf)

*.jpg is not in the list any more so I have to use All Files (*.*) to be able to select jpeg images. Although functionality is not totally broken it is irritating as default All Supported Types used to work fine.


#2

MusicBrainz supported MIME types did not change recently and still include image/jpeg.

*.jfif is one of the file extensions associated to the MIME type image/jpeg but it is not the only one: *.jpg and *.jpeg should be recognized too.

Firefox might be using a native file select dialog box directly from your operating system (or desktop environment). It looks like a system setup issue to me.


#3

I have just tested Chrome (on the same computer) and it defaults to Custom Files which displays *.jpg files correctly.

This seems to point to an issue with Firefox. I will look into FireFox MIME types.

Would the Custom Files or All Supported Types list not be set programatically by the MusicBrainz JavaScript?


#4

MusicBrainz does programatically set the list of accepted MIME types and it includes image/jpeg.

The issue here is that your browser/system does not correctly match *.jpg files with this MIME type.


#5

I have looked at my registry and all the image/jpeg MIME type file extensions are correctly set.

I have also looked at the JavaScript and can see that the accepted MIME types and file extensions are defined. The specific extensions that are accepted are jpg, png, gif & pdf.

This is really looking like a FireFox 57 issue. It would be nice if someone else running FireFox 57 can confirm that they have the same problem.

I will install an older version of FireFox and see if the problem goes away.


#6

I have Firefox 57.0.1 and can see *.jpg images fine.


#7

It was a Windows registry issue. I found the correct key to change.

\HKEY_CLASSES_ROOT\MIME\Database\Content Type\image/jpeg\Extension was set to .jfif. I changed it to .jpg and now it works correctly. I have no idea what changed it to .jfif.

Chrome was working because it checks MIME types in a different order to FireFox. FireFox checks the registry first.

Thanks for your time guys!


#8

There seems to be something going on out there in the jungle but exactly what is causing it isn’t clear.


#9

I recently updated my Windows 10 with the Creators Update. The jfif issue started at about the same time.

As I had also recently updated FireFox and the problem was in the browser I thought it was a FireFox issue.


#10

Feels like a sorting issue to me. jfif is before joeg and jpg in alphabetical order.


#11

This .jfif issues is looking more like a Windows 10 Creators Update problem. I have just applied the latest Windows update and the registry key has reverted to .jfif.