Windows Explorer does not show tag changes

windows
windows10
id3
tags
Tags: #<Tag:0x00007fd5e7239fc8> #<Tag:0x00007fd5e7239730> #<Tag:0x00007fd5e7238e70> #<Tag:0x00007fd5e7238858>

#1

Hello disocbot,

I have been experimenting with Picard. When I save after finding the album information, the music files remain the same. What exactly happens when I “save”? If I inspect the music files after the save ! none of the information such as album name appears in the Windows 10 detail of the file. See the screen capture at the end of this note.


Meta question about Picard usage
#2

When you save files in Picard it will, depending on your settings, perform all or some of the following actions:

  • Save the tags to files
  • Rename the file according to the file naming settings
  • Move the file into a new folder according to the file naming settings

Windows Explorer is among the worst tools you can use to inspect the tags for your music files. But if it does not show any change check the following in Picard Options > Tags:

  • “Write tags to files” must be enabled
  • Check your setting of “Also include ID3v1 tags in the files”. Windows Explorer used to prefer the obsolete ID3v1 tags if they were present in files, even if ID3v2 tags are present and provide more information. If Windows Explorer does not show any changes try enabling or disabling this option, it might make a difference.

#3

Hello again,
I tried what you suggested and Picard continues to not save tag info to the files. In addition to seeing if the metadata tag has changed on a song file in Windows Explorer I also looked at the file in Audacity and VLC media player. Is there something in Windows 10 that needs to be changed. I also cannot see the hidden files in the folder on my computer even though I changed the Windows 10 option to see hidden files. When I download music folders to my Music player I can see the additional files there. My music has been ripped from CDs and vinyl into loseless wav files if that makes any difference.


#4

Definitely, Picard does not support writing tags to WAV files. The general recommendation would be to convert to another lossless format like FLAC which has built-in support for tags.

For showing hidden files in Picard’s file browser right click in the file browser and select the option to show hidden files. If you can’t see hidden files in Windows Explorer you probably should ask in a Windows support forum.


#5

Thanks a lot. I converted an album to FLAC and used Picard. Everything worked as it should. I now need to convert my files from WAV to FLAC.


#6

Windows tag support is pretty basic. It used to be only ID3v2 v2.3 tags meaning Win7 couldn’t even SHOW modern tags. And the ability to handle FLAC tags didn’t exist.

To double check tags get another geek program like MP3TAG or MediaInfo. With products like Picard and MP3TAG there are active people like @outsidecontext making sure that everything possible is supported in a quality utility. And if it is not supported he will drive the spec forward in a sensible way.

Whereas Microsoft aren’t really interested so they just bodge something basic into the OS and then mess it up.

I use Mediainfo as a replacement for Microsoft’s property pages. Integrates into the OS well and shows me much much more detail about a digital file than MS ever could.


#7

As a side note: Picard might get the feature to tag WAV file with ID3. This is supported by some software, including Explorer and Media Player on at least Windows 10. See the table at https://github.com/quodlibet/mutagen/issues/207#issuecomment-323275414

But I can’t promise when this will be a available, it depends on implementation of this feature in Mutagen, the library Picard uses to read and write tags. There is a patch that already basically works, but it needs some additional work.


#8

If you want to use your WAV files without conversion, you can edit the ID3 tags for WAV with Mp3tag* - at least for the meantime until Picard support it too.

*Since version 2.76 (16.04.2016) Mp3tag support this feature. The actual version is 2.91.