Windows Explorer can't display or edit FLAC tags; they all appear blank

I tried to change all settings nothing works. ID3v2 2.4, ID3v2 2.3, UTF4, UTF16, ID3v1 etc.

Found the solution

Windows doesnt like large album arts. I am not sure if its related to pixel size or the weight of the file, however reducing 3000x3000 8MB album art to 1500x1500 2.3MB and replacing the retagging solved the issue.


Well, that wasn’t the solution I was expecting.

FLAC files use Vorbis tags rather than ID3, so all the options you mentioned (ID3v2 2.4, ID3v2 2.3, UTF4, UTF16, ID3v1 etc.) are irrelevant for FLAC files.

But I also found a reddit post about large embedded album art - perhaps the same one you found - and you either need to limit your cover art size or perhaps to stop using embedded cover art and switch to separate files instead (but this will depend on what your player supports).

I have been retagging all my music, and I stopped worrying about cover art being too large, I will happily embed 20MB covers. I noticed windows having issues with some files as well and couldn’t see the pattern, so thank you for posting this and solving my mystery!

1 Like

It’s a bit odd this is happening, as we have code in Picard that is supposed to prevent this. It’s not quite clear what is happening in Windows Explorer, but the theory is, that Explorer looks only at the first X bytes to find a comment block (which holds the metadata) in the FLAC file. If there is a too large Picture before this it will not find the comment block.

Picard actually tries to work around this by sorting the FLAC blocks with comment first and pictures afterwards. So if this does not work for you there are three possibilities:

  • The sorting does not work as expected
  • The file was saved by another tool which changed the order again (worst case would be if Explorer itself does this)
  • The order of the picture / comment block in FLAC is not the entire story and the above theory is not the (only?) reason why Explorer can not see the tags

An interesting side fact is, that Explorer is still able to save tags, it just doesn’t read the values. If you actually edit the tags the newly added value will be saved and show up in other tools (but still not in Explorer).

See also


@Evil.God do you have patch KB5003214 from Windows Update?

Here are some tools that may be useful for you:


Important: This script will not restore the lost metadata that was stored in the ID3 frame. However, it does make the file playable again.”

@DontMindMe here are some more solutions:

If it helps: First thing I do is re-encode my files with FLAC 1.4.2(--best -e -p --preserve-modtime --force --verify are the options I use) as I wanted all my files consistently encoded. Then I add them to picard which I have set to preserve timestamps, clear existing tags, remove ID3 from FLAC files. I never edit my tags with anything else as I want them consistently tagged.

I just looked through my files, and it is between 3.9MB and 4MB cover art size(I keep the cover art file with them along with embedding) tags start disappearing in Windows (10) explorer for me(Though checking on Windows 11 it’s the same). Interestingly I found one EP where the first 2 tracks didn’t show metadata in windows, and the next two did :laughing: Running 2.11, and I use a mix of windows and linux(VM) when tagging.

Opening one of the files that does not show in explorer with Notepad++ I can see the tags very early in the file. For example there is only 534 characters before the MUSICBRAINZ_RELEASEGROUPID tag. image/jpeg is after 1,526.

That said, it’s not a big deal for me personally. I don’t use explorer for anything but moving files around.



Optimization of Padding for FLAC Files

For people who are using FLAC, I’ve added Utils → Optimize FLAC to the right-click context menu which ensures that 4KB of padding exists in the file. It’s especially helpful if metadata isn’t displayed in Windows Explorer, because either the embedded cover or the embedded padding is too big to handle.