Will not pick up all files in a directory

$ picard --version; lsb_release -a ; uname -a
MusicBrainz Picard 2.7.0b1
Description:	Ubuntu 20.04.3 LTS
Release:	20.04
Codename:	focal
Linux gigabyte 5.8.0-48-generic #54~20.04.1-Ubuntu SMP Sat Mar 20 13:40:25 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Enter directory with .flacs, call picard. (Click for patebin)
Picard display:

Using the Picard GUI to drag the directory into either other column effects nothing.

1 Like

Can you provide a full debug log?


Will this do? picard log - Pastebin.com

I tried to drag one file (2-01) from the far left pane (which, for some unknown reason, was open to the directory in question—it typically picks some directory seemingly at random) to the far right pane which you can see at the end. I also tried to drag the directory into the middle and right panes, tried to right-click and add it, etc., again, to no avail. The files seemingly do not exist to Picard unless I grab them individually and move them.

1 Like

Thanks for the details. I added a ticket at

I unfortunately cannot reproduce the behavior here, but I think I found the cause for the issue. I need some more testing and then I’ll submit a fix.

i have the same problem with the beta, reinstalled 2.6.4. and it worked again and all files are recognized.

1 Like

So once the pull request is merged, is this going to push out into the dev branch so that apt will install it automatically next time I do an apt update/upgrade?

/etc/apt/sources.list.d $ l -w 1 musicbrainz-developers-ubuntu-*

Well… if you want, you can grab that AK & US torrent and then try tagging it since I’ve put it into MBDB. I tried to make a magnet with torrenttools, but it didn’t work when I tried to add it 'cuz you have to sign up for LosslessLegs.

The changes have been merged.

Yes, the daily PPA builds daily with the latest development changes. So the change will eventually show up in the PPA, likely you’ll get an update tomorrow.

1 Like

I saw picard get updated in today’s apt upgrade and that AK & US album tagged properly. I checked Grateful Dead – Europe 72: The Complete Recordings which has 578 .flac files and that worked as well.

Now, the problem that started this:
Why aren’t “media” 1-9 automatically saved as 01-09 in a set with >9 media? E.g., “Medium 1: 1989-01-28: The Birchmere, Alexandria, VA” should be “Medium 01: 1989-01-28: The Birchmere, Alexandria, VA.” Can’t change media numbering in MBDB so the solution should come from there.

1 Like