Various single files, which seem to be FLACs only will crash MBz Picard

Tags: #<Tag:0x00007f4d5bf414d8>

Yesterday I was able to load my entire library(33,000 tracks) and clustered them as well, but I found out I would never finish the album data loads, and abandoned it.
Today I broke it down into smaller sections and now upon adding a folder it will load a few hundred unclustered files then crash. I isolated it all the way down to one single file. Only to realize that it seems to be a problem per every 5-10 albums.

What could have happened since yesterday when it loaded it all up no problem?

  • Which version of Picard do you use? 2.3.2
  • Which operating system do you use? Win 10 64bit
  • What did you do when the bug occurred? Added single file
  • What actually happened and what did you expect to happen? It loads in, then after a few seconds MBz simply closes itself.
  • If you’re using plugins, which plugins do you have enabled? I disabled wikidata genre and disabled last.fm.

This is the debug report.
D: 21:16:01,809 tagger.init:232: Starting Picard from ‘C:\Program Files\MusicBrainz Picard\picard\tagger.pyc’
D: 21:16:01,809 tagger.init:234: Platform: Windows-10-10.0.18362-SP0 CPython 3.7.6
D: 21:16:01,809 tagger.init:235: Versions: Picard 2.3.2, Python 3.7.6, PyQt 5.14.1, Qt 5.14.1, Mutagen 1.44.0, Discid discid 1.2.0, libdiscid 0.6.2, astrcmp C, SSL OpenSSL 1.1.1b 26 Feb 2019
D: 21:16:01,809 tagger.init:236: Configuration file path: ‘C:/Users/Joe/AppData/Roaming/MusicBrainz/Picard.ini’
D: 21:16:01,809 tagger.init:238: User directory: ‘C:\Users\Joe\AppData\Local\MusicBrainz\Picard’
D: 21:16:01,824 i18n.setup_gettext:65: unsupported locale setting
D: 21:16:01,825 i18n.setup_gettext:83: Using locale ‘en_US.cp1252’
D: 21:16:01,825 i18n.setup_gettext:85: Loading gettext translation, localedir=‘C:\Program Files\MusicBrainz Picard\locale’
D: 21:16:01,826 i18n.setup_gettext:87: Loading gettext translation (picard-countries), localedir=‘C:\Program Files\MusicBrainz Picard\locale’
D: 21:16:01,826 i18n.setup_gettext:92: [Errno 2] No translation file found for domain: ‘picard-countries’
D: 21:16:01,826 i18n.setup_gettext:101: _ = <bound method NullTranslations.gettext of <gettext.NullTranslations object at 0x0000014FF0042948>>
D: 21:16:01,826 i18n.setup_gettext:102: N_ = <function at 0x0000014FEFAF9EE8>
D: 21:16:01,826 i18n.setup_gettext:103: ngettext = <bound method NullTranslations.ngettext of <gettext.NullTranslations object at 0x0000014FF0042948>>
D: 21:16:01,826 i18n.setup_gettext:104: gettext_countries = <bound method NullTranslations.gettext of <gettext.NullTranslations object at 0x0000014FF0040508>>
D: 21:16:01,826 i18n.setup_gettext:105: gettext_attributes = <bound method NullTranslations.gettext of <gettext.NullTranslations object at 0x0000014FF0045208>>
D: 21:16:01,853 webservice._network_accessible_changed:291: Network accessible requested: 1, actual: 1
D: 21:16:01,930 webservice.set_cache:317: NetworkDiskCache dir: ‘C:/Users/Joe/AppData/Local/cache/network/’ current size: 90.0 MB max size: 100 MB
I: 21:16:01,931 pluginmanager.load_plugins_from_directory:207: Plugin directory ‘C:\Program Files\MusicBrainz Picard\plugins’ doesn’t exist
D: 21:16:01,931 pluginmanager.load_plugins_from_directory:221: Looking for plugins in directory ‘C:\Users\Joe\AppData\Local\MusicBrainz\Picard\plugins’, 1 names found
I: 21:16:01,948 C:\Users\Joe\AppData\Local\MusicBrainz\Picard\plugins\lastfmng\settings.:55: host: ws.audioscrobbler.com:443
I: 21:16:01,948 C:\Users\Joe\AppData\Local\MusicBrainz\Picard\plugins\lastfmng\settings.:56: key: 0a8b8f968b285654f9b4f16e8e33f2ee
I: 21:16:01,948 C:\Users\Joe\AppData\Local\MusicBrainz\Picard\plugins\lastfmng\settings.:60: collect_unused: False
I: 21:16:01,948 C:\Users\Joe\AppData\Local\MusicBrainz\Picard\plugins\lastfmng\settings.:62: ignore_feat_artists: False
I: 21:16:01,948 C:\Users\Joe\AppData\Local\MusicBrainz\Picard\plugins\lastfmng\settings.:64: default_unknown: Unknown
I: 21:16:01,950 C:\Users\Joe\AppData\Local\MusicBrainz\Picard\plugins\lastfmng\settings.:252: enabled categories: grouping (1), genre (4), mood (4), occasion (4), category (4), country (2), city (1), decade (1)
D: 21:16:01,958 webservice._network_accessible_changed:291: Network accessible requested: 1, actual: 1
D: 21:16:02,039 webservice.set_cache:317: NetworkDiskCache dir: ‘C:/Users/Joe/AppData/Local/cache/network/’ current size: 90.0 MB max size: 100 MB
D: 21:16:02,040 plugin.register:74: ExtensionPoint: track_metadata_processors register <- plugin=‘lastfmng’ item=<function track_metadata_processor at 0x0000014FF0046C18>
D: 21:16:02,040 plugin.register:74: ExtensionPoint: album_metadata_processors register <- plugin=‘lastfmng’ item=<function album_metadata_processor at 0x0000014FF08EC318>
D: 21:16:02,040 plugin.register:74: ExtensionPoint: function_registry register <- plugin=‘lastfmng.script’ item=(‘set2’, FunctionRegistryItem(function=<function func_set2 at 0x0000014FF08ECD38>, eval_args=True, argcount=Bound(lower=2, upper=2)))
D: 21:16:02,040 pluginmanager._load_plugin_from_directory:279: Loading plugin ‘Last.fm.ng’ version 2.0.4.final0, compatible with API: 2.0
D: 21:16:02,041 ui.playertoolbar.init:91: Internal player: QtMultimedia available, initializing QMediaPlayer
D: 21:16:02,182 ui.playertoolbar.init:98: Internal player: available, QMediaPlayer set up
D: 21:16:02,394 tagger.main:985: Looking for Qt locale en_US in C:/Program Files/MusicBrainz Picard/PyQt5/Qt/translations
D: 21:16:02,396 browser.browser.start:78: Starting the browser integration (127.0.0.1:8000)
D: 21:16:02,442 ui.mainwindow.auto_update_check:1255: Skipping start-up check for program updates. Today: 2020-05-11, Last check: 2020-05-10 (Check interval: 7 days), Update level: 0 (stable)

For actually debugging this I’d need the file to test. But does the crash actually happen when you load just this single file, or only if you load several files at once?

1 Like

Hey I responded to your email.

1 Like

Thanks. I tried with your files, but could not reproduce any issue. Could you share your scripts, maybe it is related to this.

Can you reliable reproduce these crashes with these files or does it happen only sometimes?

1 Like

I’m not aware of running any scripts. It’s simply a clean install.
So it’s working a bit differently today and it seems like two files together are the problem.

I will follow up with files at your email again.

I’ve had the same issue recently. At first I though it was a couple of specific folders, but after reading this, I experimented. I can load each of the 11 files in individually, but if I add a second file from the same group, Picard closes immediately.

I will follow up as I discover new informaiton.

I tested after trying each of these things. Updated all plugins, disabled plugins, reset all defaults. Picard crashes on load, with automatically scan disabled.

What I first found gets me past is;
If I have a completed album in the right pane, and add each of the files one at a time, it will scan and tag them all. If at any time, Picard is processing more than one of the suspect files at a time, Picard will exit. After this, the files will scan with no problems, suggesting that the tag frames are the problem.

I was able to fix the issue altogther by deleting the tags from the files in question using MP3Tag.

2 Likes

I should have some time to test that out when I get home. I’ll report back.

EDIT: Actually. I’m going to try my other method first, which will be bringing the files into work for another computer to take a shot at it. Hitting offending albums with mp3tag first will be a lot of time investment I’d rather skip.

Things are going smoothly on my work computer. I wish I could say why.

Some late feedback, but I have finally found the fix for the issue Thanks for providing the broken files.

So the basic issue is that the tags contained some null characters, and that caused a crash in Picard column sorting code. That’s also the reason why it worked for you both after you removed or resavedthe tags of the files, as this fixed the files.

Bugfix for this is in review, see https://tickets.metabrainz.org/browse/PICARD-1853 . Should be fixed in the next release. Thanks again for reporting.

3 Likes