$unset album script ignored for non-album tracks


#1

Suppose you have an album in your library where the tracks do have MB recording id’s, but they have no MB album (release) id.

(That can happen if you have some obscure compilation album that is not present in MB’s database, or e.g. some ‘best of’ compilation album that you have assembled yourself.)

For such an album you will have chosen an album title yourself.
Because I don’t want Picard to make any changes to these album titles, I have a script containing: $unset(album)

That works well if in Picard I have ‘Ignore MBIDs when loading new files’ checked.
Then the album title will indeed be preserved after a lookup/scan.

But if that option is not checked, Picard will load the tracks (my ‘custom’ album) to the right panel, and will not respect “$unset(album)”, and will want to write: [non-album tracks]

Shouldn’t the $unset script be respected in this case too?


#2

Yes, absolutely, that’s how it is supposed to work. I gave this a quick test, looks like $unset(album) album doesn’t work at all for actual releases, and for NAT it at least work when I run a script manually (via context menu). For NAT you also cannot do something like $set(album,TEST).

I entered an issue at https://tickets.metabrainz.org/browse/PICARD-1355


#3

Great. Thanks (again) for taking action this fast.