Unicode regional indicators are not rendered as flags anymore

Tags: #<Tag:0x00007f511a1b5798> #<Tag:0x00007f511a1b53b0>

Since a couple of days Firefox 86 on Windows 10 does not render Unicode regional indicators as flag symbols anymore and shows them as two letters instead.

Short introduction: Some of you will probably know them from the digital release availability annotations generated by a-tisket. For those who do not know what I mean and probably have never seen them because they are not supported by every browser / OS combination, I will give a short example: The combination of the Unicode characters 🇺 and 🇸 (different from U and S - just in case they look similar with your browser’s font) is supposed to look like a United States flag: :us:
Discourse is cheating again (see my post below), better use this random a-tisket annotation as example. Please refer to Wikipedia if you can not see the flag before each country name in the annotationat the end of the last line:

Problem: The display of these flag symbols used to work with the default fonts under Windows 10 for a couple of months now and I have not changed any font-related settings since. For Firefox on Linux the problem does not exist and my research did not reveal any indication that this ever should have worked on Windows!? I am seriously confused as until a few months ago it did in fact not work and then it suddenly worked… until now :frowning_face:

Does anyone else have this problem with these flags? Have you ever seen them under Windows 10? Are they still working for you? Although this is only loosely related to MB I think this is nevertheless a good place to pose these questions since many editors are using a-tisket and might have the same problem.

I can see the Unicode flags on Windows 10 using…
  • Firefox 86
  • an older version of Firefox
  • a Chromium-based browser
  • a different browser
  • The flags used to be rendered but now I can not see them anymore.
  • Which flags? I have never seen them…

0 voters

2 Likes
2 Likes

Thank you for the link, ironically I have searched for “unicode flag” on exactly this page but it returned no results… Am I too dumb to use their search!? Anyway, it looks like Firefox 87 already will fix this (again) :slight_smile:

As a sidenote, after submitting this topic (on Linux, to make sure the flag was still shown, then I switched back to Windows) I can see the flag in the first post which does not get rendered in the edit preview. It shows :us: on hover so I guess this is another smart feature of Discourse where it replaces the Unicode sequence by an image.

2 Likes