Unable to submit AcoustID from Picard

Tags: #<Tag:0x00007f8393f6fa40>

Quoth the Picard’s error log:

E: 20:16:12,355 /usr/lib64/python3.7/site-packages/picard/webservice/__init__._handle_reply:387: Network request error for http://api.acoustid.org:80/v2/submit: Error transferring http://api.acoustid.org:80/v2/submit - server replied: INTERNAL SERVER ERROR (QT code 401, HTTP code 500)
E: 20:16:12,358 /usr/lib64/python3.7/site-packages/picard/acoustid/manager.__fingerprint_submission_finished:100: AcoustID: submission failed with error 'Error transferring http://api.acoustid.org:80/v2/submit - server replied: INTERNAL SERVER ERROR': internal error

Please enable debug output in View Error/Debug Log and post the log output here.

Ultimately this is an internal server error on the AcouszId side and likely needs to be reported for AcoustId

No hiccups here. Just submitted a heap of AcoustIDs without trouble. Nothing new in the log apart from lots of fanart tv plugin errors

@outsidecontext any chance the logging could put a yyyy-mm-dd date with the timestamp? I’ve just looked into my (ancient) log and can’t tell how old some of these messages are. Just guessing from what I was tagging.

1 Like

Okay, I cannot reproduce the issue anymore.

2 Likes

It was either some temporary issue on the AcoustID server side or likely one of the two issues below:

I seem to be having the same issue here at the moment.
Error log says:
E: 19:16:44,125 webservice._handle_reply:387: Network request error for http://api.acoustid.org:80/v2/submit: Error transferring http://api.acoustid.org:80/v2/submit - server replied: INTERNAL SERVER ERROR (QT code 401, HTTP code 500)

I thought it may be a bad API key, so I tried to get a new one, but the AcoustID web site also gave a 500 error??

Update 06/01/2020
What ever the problem was it has now been resolved, as I was able to submit audio signatures again today.

Guess there was a server issue at AcoustID