Unable to submit acoustic ID

I am unable to submit acoustID for this new release I Added:

Could someone else kindly do it? When I load this into Picard, I do have the following in the error log, but do not have time at the moment to address the. I Ask for help only so it does not get forgotten and left incomplete. Thanks.

E: 04:33:18,820 /usr/lib/picard/picard/webservice/init._handle_reply:387: Network request error for http://api.acoustid.org:80/v2/lookup: Socket operation timed out (QT code 4, HTTP code 0)

E: 04:33:18,820 /usr/lib/picard/picard/acoustid/init._on_lookup_finished:67: AcoustID: Lookup network error for ‘Brya Woods- papercuts.mp3’: ‘Socket operation timed out’, b’’

E: 04:33:18,821 /usr/lib/picard/picard/file._lookup_finished:659: Network error encountered during the lookup for Brya Woods- papercuts.mp3. Error code: 4

I think it’s exactly as the error codes say: there was a network error, which could be for any number of reasons. Try again now/later?

1 Like

I had tried a few times and can confirm I have no issues connecting to internet or MB services, so I posted. But I have also not received a message (from you but automated) indicating it is off topic, so I guess I can just leave it alone. I just thought maybe someone else might have the release and could assist by uploading the ID.

I agree it could be any number of thing, thus I also tried alerting the Picard people in case they should hear of similar issues. I have no clue what is wring with this, but I guess forget it.

AcoustID is not run on any MetaBrainz infrastructure and is not related to MetaBrainz per se, so being able to reach any MetaBrainz servers does not really say anything about being able to reach AcoustID servers. :slight_smile:

Can you access https://acoustid.org/? What about http://api.acoustid.org/? (The latter being the one Picard tries to submit data to.)

Re: offtopic: Most of the Picard people that read the Picard category will also read along here; there’s no reason to “crosspost” on the same forum. It just adds clutter and splits the discussion. Which is why I marked your other post as offtopic and hid it. Note that I didn’t mark this post as offtopic, which means the topic itself is not offtopic—only the double/cross posting.


Yes, I can access the resources you listed, although I had originally only tried the resource specifically listed in the errors. I understand that is not hosted on metabrainz servers. But I also know that the Picard programming makes the call(s) to the servers it is on. I have personally seen times where an issue in the “calling code” is in some way invalid or malformed, which can cause the server to timeout on the request. Given this, I would logically assume this information would be of interest to Picard project programmers, as there was an issue while using the product. It may not be an immediate attention sort of thing, but it is something that is often logged for error analysis and possible correlation with other error reports.

For example, I am currently working on an issue where “503 server unavailable” is received by some but not all. Simple logic will tell you to try later, the server is simply not available. But looking at this, that is not the case. The code making the call is getting changed for some users, as I can duplicate the issue by manually altering the call. Maybe a browser, extension, etc issue, unsure, but it is surely something I want to know.

I can try again later when I am on a computer with Picard, but I also do not like leaving my edits incomplete, at least to the extent of my MB knowledge and information available. There are also limited ways to submit the acoustic ID which makes issues like this a show stopper as it relates to that function.

1 Like