Tracks get tagged with Tracknn instead of real title (where nn is 01, 07, 15, etc.)

I’m fairly new to Picard, sure is neat, I wish I had something like this 20 years ago.

I am currently re-ripping my CD collection using EAC and Picard. I’m ripping to FLAC. I don’t have any local custom scripts.

On a few of my albums, instead of the track’s Title as shown in the Picard window, the actual title field “TIT2” is set to “Track08”
So far, I can’t seem to change it, even though Picard displays the proper “The M.T.A” on the window

Here is what I see using’s tag utility

tag -raw ~/whome/Music/flac/Kingston\ Trio/Live\ at\ Crazy\ Horse/Track08.flac

Metadata Format: ID3v2.3
File Type: MP3
Title: Track08
Album: Live at the Crazy Horse
Artist: The Kingston Trio
Track: 8 of 16
Disc: 1 of 1

“TIT2”: “Track08”
“TPE1”: “The Kingston Trio”
“TSSE”: “FLAC.EXE -6 -V -T "ARTIST=The Kingston Trio" -T "TITLE=Track08" -T "ALBUM=Live at the Crazy Horse" -T "DATE=" -T "TRACKNUMBER=08" -T "GENRE=" -T "COMMENT=" -T "BAND=" -T "ALBUMARTIST=" -T "COMPOSER=" -T "DISCNUMBER=1" -T "TOTALDISCS=1" -T "TOTALTRACKS=16" -o”

What am I doing wrong?

First, welcome to the Community. You’re in the right place with your questions.

You haven’t really told us what steps you are taking in Picard, so please forgive me if I seem to be asking or suggesting something obvious…

The information reported by tag seems to be the tag information stored by EAC in the files. Also the fact that it is showing the File Type as MP3 when you’re ripping to FLAC looks odd.

Are you matching your files to a release in the right-hand pane before saving from Picard? See the Matching Files to Tracks section of the Picard User Guide for more information.

The Work Flow Recommendations section describes some typical ways that Picard can be used to retrieve metadata from MusicBrainz and tag your files. Your process sounds like it is best covered under the When the CD is available workflow. This provides more of a step-by-step procedure for that workflow.

To get the information from the MusicBrainz database, you will need to load the appropriate release. There are a few different ways to do this depending on what you have available. This is explained in the Retrieving Album Information section.

In your case, I would suggest you first try retrieving the information using the Lookup CD or Ripper Log method. This should get you the best match if the CD is in the database and has a CD Table of Contents (TOC) assigned which matches your CD. If there is no match, you can do a search and attach the TOC if you find the CD in the system.

Since you’re using EAC to rip your files, you can do the lookup using the EAC ripper log if you prefer to not read the CD in your drive (like if you’ve already filed the CD away in a box or something).

I hope this helps point you in the right direction. If something isn’t clear or you have any other questions, please ask.

1 Like

You shouldn’t allow EAC to write ID3v2 tags to FLAC files. I’ve never tried to enable it because it’s a bad idea, but one of those checkboxes is located in Compression options > External Compression.

It is possible that EAC is writing tags, but that is not my intention.

I’m using the online database, not a local copy

My workflow is pretty simple:

  1. stick audio CD in reader
  2. fire up EAC
  3. click on the Picard button in EAC
  4. most of the time, EAC has all the important data.
  5. I have EAC “save compressed” which writes out the .WAV file and then invokes an external program/process to convert the WAV to FLAC
  6. then I open the disk folder with Picard, “cluster” the folder, and press “scan”. Most of the time, this fills in all the data
  7. I press “save” button in Picard.

For a small subset of my CDs, Picard doesn’t have the data.
4) alternative: I fill in the artist and album into EAC and then do the
5) as above
6) again, most of the time, Picard can find the album or most of the tracks, so I have Picard “save”

Most of the CDs that I have problems with are old. Often they are like the example a gave, a late 1980s CD reissue of a very old vinyl album, like
the example “The Kingston Trio Live at the Crazy Horse”

It’s a MusicBrainz logo, not Picard.

Please share screenshots (and the text that overflows out of the screen) of all of the pages in Exact Audio Copy’s “Compression Options” window.

Oh, I didn’t know that switch existed.
I’ve turned it off and will continue ripping. If I notice a difference, I’ll get back to you


If you’re clustering your files, don’t use scan, but instead use lookup. Scan will ignore your clusters and look up each file individually via its acoustic fingerprint. Scan should be only used as a last resort. In your case, if you have the CD in the drive I strongly recommend using the Lookup CD method. This will get you the best match (if the CD TOC is in the system).

Also, I didn’t notice anything in your steps where you match the files (in the clustering pane) to releases (in the albums pane) before saving. If you don’t do that, Picard will not write the tag information retrieved from MusicBrainz to your files.

I’m afraid I don’t follow this part:

you match the files (in the clustering pane) to releases (in the albums pane) before saving

what do you mean here?
I do look at the tracks in the lower left window. It has column titles of
“tag Original Value New Value”

I turned off ID3 tags in EAC and things seem to be working better.
I’ve simple re-ripped and used Picard on the ancient CDs.
So far, no failures.

See Matching Files to Tracks and Saving Updated Files in the documentation.

Oh, I did not know about dragging tracks from the folder view to the right hand pane.