Tracknumber for track 0 not being set

Tags: #<Tag:0x00007fe3158a95a8> #<Tag:0x00007fe3158a9468>

I’m trying to tag an album with musicbrainz where the first track is 0:

An old version (1.3.2) of Picard names and tags the file correctly (img 1)

A newer version of picard (2.1.3) names the file correctly (00 Die Arzte - Lady.flac), but does not set the track number to 0 in the tag (img2). Is this due to a setting I have overlooked? Or has something changed in newer releases of picard?

3 Likes

Have tried this on a couple of versions/OS’s:
Linux 2.1.3 - incorrect
Linux 2.3.1 - incorrect
Linux 2.4.0b2 - incorrect
Windows 2.3.2 portable - correct

Thanks a lot for reporting this. I can confirm, the track number 0 gets ignored when setting the tags.

I added a ticket https://tickets.metabrainz.org/browse/PICARD-1884, will be fixed for the next release.

3 Likes