Titelnummer wird falsch gespeichert

Tags: #<Tag:0x00007fd2a4e0fbb8> #<Tag:0x00007fd2a4e0fa50>

Hallo,
ich benutze Musicbrainz 2.5.2 und Windows 10.
Beim speichern der fertig getaggten Musikstücke werden die Titelnummern falsch abgespeichert.
Der Fehler tauchte auch bei Musicbrainz 2.5.1 auf. Vorher tauchte dieser Fehler nicht auf. Es könnte sein, das der Fehler nach dem neuesten Windows Update aufgetreten ist.
Was kann ich tun, damit dies nicht geschieht?
MFG Toni

Hallo Toni, was genau ist mit “falsch” gemeint?
Könntest du bitte ein Beispiel angeben, wie das “falsche” Ergebnis in Picard 2.5.2 aussieht und wie es mit vorherigen Versionen ausgesehen hat? Oder werden die Tags bloß von einem anderen Programm (z.B. Windows Explorer) falsch angezeigt?
Möglicherweise helfen auch ein Screenshot und ein Link zum Eintrag der betroffenen Veröffentlichung auf musicbrainz.org weiter, damit ich und andere hier im Forum das Problem besser verstehen können.

4 Likes

Hallo,
das Musikalbum wird in Musicbrainz gefunden, mit den jeweiligen Titelnummer von 1 bis 11. Dann speicher ich das Album und die Titelnummern werden nicht übernommen und wahllos vergeben.


image

Unter Dateibenennung habe ich folgendes:
$if2(%albumartist%,%artist%)/[%date%] %album% (MP3)/$if($gt(%totaldiscs%,1),CD%discnumber%,)/$num(%tracknumber%,2). %title%

Folgende Plugins benutze ich nur:
Feat. Artists in Titles
Title Case

2 Likes

Hallo,
Ergänzung zu dem oben aufgeführten.
Bevor ich die getaggten Dateien abspeicher, zeigt Musicbrainz die Werte falsch .
Der ursprüngliche Wert und der neue Wert wird falsch angezeigt.
Der neue Wert, falsch angezeigt, wird so falsch gespeichert.


Ich bin ein bisschen verwirrt - laut deines foobar2000-Screenshots wurde ja einfach kein einziger Tag gespeichert (Album, Date & Track Number sind leer, Last modified im August). Ist Einstellungen -> Tags speichern aktiviert? Welche Einstellungen unter Einstellungen -> Einstellungen -> Tags und darunter ID3 sind denn aktiviert?

Hallo,
der Screenshot von Foobar2000 und Musicbrainz sind vor der Speicherung und sollen den ursprünglichen Wert darstellen.

Also betreffend des Tracks Monster von Walking On Cars hätte ich eventuell eine Erklärung, wie die falsche Tracknummer “3” zustandekommt: Picard interpretiert Nummern mit einer bestimmten Formatierung am Anfang oder am Ende des Dateinamens als Tracknummer, wenn der entsprechende Tag nicht gesetzt ist.
Laut deinem foobar2000 Screenshot ist dies der Fall (keine Tracknummer bzw. “0-” als Tag) und der Dateiname ist Walking On Cars - Monster (3).mp3, daher wird der ursprüngliche Wert für die Tracknummer (in der linken Spalte des Picard-Screenshots) als “3” angezeigt.
Wenn du nun zusätzlich die Tracknummer unter Einstellungen > Einstellungen > Tags als geschützten Tag eingetragen hast, wird dieser falsche Wert auch nicht mit dem korrekten Wert “1” aus MB überschrieben (und steht daher auch in der Spalte Neuer Wert).
Falls meine Annahme stimmt, müsstest du entweder die Dateinamen “frisieren” (irreführende Nummern am Ende entfernen) oder die Tracknummer aus der Liste der geschützten Tags entfernen, um das Problem zu beheben. Ich hoffe, ich konnte dir damit weiterhelfen.

4 Likes

Hallo,
danke für die Antwort.
Unter Einstellung>Tags > Tags ausnehmen überschrieben zu werden, steht ==> tracknumber
Ich wußte nicht, daß es diesen Wert gibt. Ich habe Ihn nicht gesetzt.
Ich nehme diesen Wert nun heraus und werde berichten, ob eine Besserung eingetreten ist.

2 Likes

Hallo,
wie Du vorgeschlagen hast, habe ich die Tracknummer aus der Liste der geschützten Tags entfernt.
Jetzt funktioniert wieder alles.
Vielen Dank für Deine Hilfe.
Was mich ein bißchen irritiert, daß ich diesen Wert dort nicht gesetzt habe und es vorher diesbezüglich 1 Jahr oder eigentlich nie Probleme gab.
Mfg Toni

Das kann auch versehentlich über Kontextmenü beim Tag bearbeiten (“Zur Liste der zu bewahrenden Tags hinzufügen”) passiert sein. Standardmäßig ist die Liste leer.