Tags Not Being Preserved

Simply, I put tags in the box to preserve them, and it doesn’t work. Namely it’s the artistsort and albumartist sort that are constantly overwritten.

The ONLY things I want added are label and release date. Any advice?

If the tags are empty, Picard will fill them even with the preserve tag setting. For tags you don’t want at all you can add a script, $unset(tagname). Just beware it WILL remove existing values.

Here is every tag Picard knows about internally. If it’s not here, it’s not likely to be in the MBID.

acoustid_id, albumartist, albumartistsort, album, albumsort, arranger, artist, artists, artistsort, asin, barcode, bpm, catalognumber, comment:, compilation, composer, composersort, conductor, copyright, date, discid, discnumber, discsubtitle, djmixer, encodedby, encodersettings, engineer, genre, grouping, isrc, key, label, language, ~length, license, lyricist, lyrics, media, mixer, mood, movement, movementnumber, movementtotal, musicbrainz_albumartistid, musicbrainz_albumid, musicbrainz_artistid, musicbrainz_discid, musicbrainz_originalalbumid, musicbrainz_originalartistid, musicbrainz_recordingid, musicbrainz_releasegroupid, musicbrainz_trackid, musicbrainz_workid, musicip_fingerprint, musicip_puid, performer:, producer, r128_album_gain, r128_track_gain, ~rating, releasecountry, releasestatus, releasetype, remixer, replaygain_album_gain, replaygain_album_peak, replaygain_album_range, replaygain_reference_loudness, replaygain_track_gain, replaygain_track_peak, replaygain_track_range, script, showmovement, subtitle, title, titlesort, totaldiscs, totaltracks, tracknumber, website, work, writer

Take out ‘label’, ‘date’ and ‘originalyear’ if you don’t want those touched.
Add any additional tags you’ve defined on your own, case-insensitively, each separated by, a, comma, and space. Order matters not.

If these tags are NOT present in any tracks processed on the Right side of Picard, but do exist in the MBDB they -WILL- be added.

The only thing that Picard will not do is over-write an existing value if the tag is specified to be preserved in Picard Options.

If you do NOT want any additional tags added that did not exist when the track was loaded, you’re going to have to write a somewhat interesting script and set the Picard option to IGNORE MBIDs when loading tracks.

2 Likes

Hi there, I am new to the forum and somewhat new to MusicBrainz Picard. I have been trying to use the preserve these tags function for some time and have found it simply is not working. I tried with the previous version of Picard and have tried with the current one, Version 2.3.2.

For example, I have the date field already populated and do not wish to change it. So this is NOT the case where the field is blank. I list “date” (I’ve also tried “Date”) in the preserve these tags field and save it by clicking “Make It So”. Then when saving the new tags, Picard replaces all my tags including the date tags with its new, incorrect dates.

Please let me know what I need to do differently or if there is a bug in Picard and if anyone knows if it could be resolved.

Many Thanks.

A few questions I can think of:

What file format are you using?

If Picard is overwriting the data when saving, is it not showing that the data will change in the bottom panel? Are you checking the preview before saving?

And speaking of the bottom panel, have tries right clicking on the tag and choosing “add to preserved tags” to be sure it’s getting the right tag name?

2 Likes

Thanks very much for the reply! My file format is flac. I think I may have it working now, although I will need to test much more to make sure. In terms of checking the bottom panel, I understand data in green is what is considered most accurate and yellow is likely but less sure. What is black? And is there any way to alphebatize or customize what labels Picard shows in the bottom panel?

Green text is newly added, yellow is changed, black is unchanged. This should be fairly clear from looking at the columns side by side.

I think the only sorting option is you can choose to show changes first. Right click in the bottom panel and there’s a tickbox for it

1 Like

Tags are shown alphabetically, with some important tags moved to the top. You can customize which tags you want to have displayed at the top in Options > User interface > Top tags

2 Likes

Thank you both for the replies. The order of labels shown in the bottom panel seem to change with each song which seems a bit crazy to me. For one of the pieces, “Length” is the first tag, before Album Artist, so the order seems neither alphabetical nor, I think, for importance.

I would love to be able to customize this. @Outsidecontext, thanks for that direction - unfortunately when I go to Options > User Interface > there is no option for “Top Tags” or similar listed. I have Version 2.3.2 - which I think is the latest?

It’s actually in a sub-section of the User Interface options page. See https://picard-docs.musicbrainz.org/en/config/options_interface_top_tags.html for details.

Thank you, @rdswift, I see it now!

And, after re-reading the thread and using all the help here, I’m seeing more clearly how the panel operates. I still need to spend more time with it, but thanks to everyone here for the help!