Suddenly having feat. showing up in names


Not sure what I did or how, but now all my albums and songs are ending up with this feat. in the names? How do I stop this? and How can I get rid of it in the hundreds that it has done this with? without doing it manually???
Any Help greatly appreciated


Picard/Musicbrainz puts the ‘featured’ artist into the artist field, not the track field, because that’s where it belongs :wink:

To move the featured artists back to the track name, go into Picard > Options > Plugins > and install and tick either ‘Feat. Artists In Titles’ or 'Feat. Artists Removed’
Then you can add all your tagged music again (it should automatically be saved to the right panel if it’s already been tagged with a MBID), and hit save to apply the changes/ activated plugins.
You can always repeat this process without the plugins activated to reverse this if you change your mind (which is one of the best things about Picard, you can quickly change things after tagging once, if you keep the MBID tags in your files)

The other option is to leave the tracks and to browse your music by ‘album artist’ instead of ‘track artist’, which will leave the credits in the correct place and let you browse your albums properly.
Some music players, eg iTunes, don’t support this last I checked.

Have fun :slight_smile:


You mean albums and songs that you renamed with Picard, right? If so, here’s what to do:

  1. In Picard, click the Options menu and then choose “Options…” from the list.
  2. In the left column, select “Plugins”.
  3. Enable the plugin called “Feat. Artists Removed”.
  4. Click “Ok”.
  5. Reload your files in Picard. Picard should match them right away because they have already been tagged.
  6. Ensure that “Rename Files” is enabled in the Options menu.
  7. When all the files are correctly matched in the right column, resave them.


Thank You for the replies… I have downloaded and installed that plugin however it does not seem to be renaming the files??
I am attaching some screenshots showing what it is doing to file and folder names and also showing the plugin that I have installed and the options I have selected… Is there something I am missing?


Forgot to mention I do have the option to rename files when saving checked!


I tried it, and it’s not working for me either (not sure who maintains that)
The other plugin (move feat. to titles) does work for me though, will that do the job for you?


I had a bit of an issue with that as well in my own library – not specifically with having the featured artists show up in the folder names, but with having four or more folders per artist because of who was featured at the album level. I solved that through checking two custom tags (%enclosingfolder% and %artistfolder%), the first of which adds a new level if present (Alan Jackson/Alan Jackson feat. Lee Ann Womack/Freight Train) and the second which actually changes the folder name (Alan Jackson/Freight Train). With a bit more logic, I was able to shorten the enclosed folders a bit as well (Alan Jackson/feat. Lee Ann Womack/Freight Train). It’s definitely a manual solution, but if you’re interested:

		_ $trim($right(%_savealbumartist%,$sub($len(%_savealbumartist%),$len(%enclosingfolder%)))),



Beyond that plug for overly-complex scripts, it looks to me like the reason you’re running into this is because your naming script is using %artist% rather than %albumartist%. There are two potential reasons for that: either your files have lost that field in the tags, so be sure that “Album artist” is present and properly filled in the bottom pane, and check the “Scripting” page if the options if it’s not; or your script is missing the album artist so check that, in the “File naming” page, the first folder is given as $if2(%albumartist%,%artist%) or something of that nature. The “Move feat. to Titles” plugin @aerozol recommends is another way of doing it, but it comes with collateral damage to the data that I’m not fond of.

Whatever fix you use, you will still have to load all of the affected files back through Picard, but at least you won’t have to move them yourself.


IN the naming section this is what I have %artist%/%album%/%artist% - %title%
the only thing in scripting is to do with changing the date to year only

Are you saying to get rid of this problem I need to change the first word to Album artist?
also I am still confused as to what happened in the first place as this was not happening at first…
Thank You for all the help I am new at this so it is greatly appreciated


Yeah. Not sure what happened to it either, but, using the example of Freight Train, %albumartist% contains “Alan Jackson” (the name under the title at the top of the page) for everything in the release, and while %artist% is the same for most of the tracks (the name in the “Artist” column of the tracklist), “Till the End” has an artist of “Alan Jackson feat. Lee Ann Womack”. Since your script is only using the second, it doesn’t care what’s in %albumartist% and is perfectly happy to pull that one track out from the rest of the others, because it is different from the others.

I wouldn’t do a straight replacement, because that will wind up having trouble with what we call standalone recordings – roughly, songs that aren’t part of an album. Instead, I recommend the following line:

$if2(%albumartist%,%artist%,Unknown Artist)/%album%/%artist% - %title%

The $if2 part says “take the first one of these that’s not empty”, which will be %albumartist% for the most part, but will still fall back to %artist% for those rare weird files. If even that is empty – essentially, will only happen if the file has no real tags and you don’t know anything about it beyond the fact you like it – it creates an “Unknown Artists” folder to stick it in just to clean things up that little bit more.

Another question I have is whether you mean to not have the track numbers; do you like the file being named Alan Jackson - After 17.mp3 or would you rather 03 - Alan Jackson - After 17.mp3? Not an issue either way since any music library program will see the 03 in the tags and put it third in the album, but adding that to the file name brings that organization to the file browser. If you do like the second, use this line instead:

$if2(%albumartist%,%artist%,Unknown Artist)/%album%/$num(%tracknumber%,2) - %artist% - %title%

You’ll probably need to load and save your entire library back through Picard (in manageable chunks) if you do add the track number to the file rather than just the misfiled songs the first script requires, so take that into consideration when deciding which to use.


Hi, I would prefer to just have the artist name, ie: Alan Jackson, Title of song, and the album and the year of the album, I am not looking to add track numbers, and as I am not uploading any data to MB this should not create any conflicts.
with the current setting of %artist%/%album%/%artist% - %title% what should I change? I do have a script that changes the date to year only. I did find ones that were supposed to remove feat. however no luck they were on this scripting documentation page.
Appreciate all your help


In that case, you’ll want the first line I gave in my most recent post, replacing the %artist% with an $if2 call. By the way, the only thing Picard ever uploads are ratings and AcoustIDs, and the former only if you enable it; you don’t have to worry about giving us bad data.


Forgive my questions… Do you mean from this %artist%/%album%/%artist% - %title%
to this $if2/%album%/%artist% - %title% ?

$if2(%albumartist%,%artist%,Unknown Artist)/%album%/%artist% - %title%


Thank You, so far so good :slight_smile: Appreciate the help :slight_smile:


Just wondering, what script are you using for changing the date to year only? Been looking for that for a while.

To clarify: Most media players display “Date” rather than “Original Year” of the album. Therefore, I would prefer to always have date set for the original year of the release, so it is easier to categorize further.

If there is a better way to deal with this, however, I would be happy to try it.


There are two ways of doing that: one using the year of the earliest release in the group, and one using the year of the specific release you have. Your use of “original” makes me think you may want the former, but since that would result in changing (rather than just losing precision on) the data, I’ll give you the second as well.

As you’ve seen, Picard does provide a year-only field, and using it as the date is a simple matter of copying it over. And if you’re interested in the date from the perspective of “when did the artist(s) put this together” it might actually be closer to what you want.


If you care about things from a version-specific perspective (“when was this particular reissue released”) or just don’t like getting rid of data, we can use the fact that MB always gives dates with the year first. There might be some issues if you have a file not in the database that has it in a nonstandard format, but if you’re tagging a file like that, you know you need to be careful in the first place, so you should spot any issues before they get saved.


By the way, even if you do use the first, I’d still recommend having the second as a backup. It won’t matter for any releases Picard can find on MB, but if you have any unmatched files or match something to a recording rather than a release, doing so will avoid deleting any date already on the file.