Solved: MusicBrainz Picard can't save tags (error: errno 13 permission denied)

musicbrainz
picard
Tags: #<Tag:0x00007f23c1b34548> #<Tag:0x00007f23c1b343b8>

#1

FYI. If Pickard can’t save tags, check your antivirus for blocked actions.
I could do everything I wanted to do to update tags and collect random rips into their respective albums – except save the results. I spent the day researching and trying suggested corrections, changing permissions, and more with no results. I could not even save an unchanged set of tags back to the file. I could with MP3Tag, but I had over a hundred files to update and couldn’t figure out how to use that program for more than onezies.
Until I looked at the log for my antivirus, Bitdefender. It showed that it had blocked Pickard from writing to my Music folder. There had been no notification of that action. I allowed the action and whoopee! I could save my Pickard changes!


#2

Thanks for the heads up. Antivirus software seems to cause all kinds of hiccups like that.


#3

You can also get this error when files are read only for some reason. It doesn’t seem to effect other tagging programs but it does Picard. Disabling read only in file properties seems to fix it but its annoying to do each time.