[SOLVED] How can I make Picard NOT use the "full-date" but YEAR only...?

I’m assuming I have to do another “script”? Using 13 already ugh LOL.
I’ve looked, but not sure how I can do it.

I’m of course talking about the “Date Tag”, many songs now have a full date there instead of a year, and I want that tag to be kept clean with just a year only.

Help… Thanks.

Have a look at the $left() function. Also, as of Picard 2.7 there is a new $year() function.

1 Like

Great, sounds good, thank you.

On another note, if you always use a few of the same scripts, you can always combine them into a single script. :wink:

That would definitely be good, can you give me an example of like 3 $unset scripts, for example, “$unset(compilation)” what a group of them combined might look like?

Would definitely help with all the settings I have to change/save in a text file for future reference.

Just put each commend on a new line in the combined script. For example one of my test scripts is:

$noop(  General Test Script  )
$set(album,%album% [file])

I don’t have a scripting brain, but could you explain how I can get the $left() function and the new $year() function to work?

I put them in and I’m STILL getting “full dates” instead of the Year only?

How are you trying to use them? Unless I’m misunderstanding, it should be something as simple as:


LOL, I’m a scripting idiot… I had no idea about all that “extra” stuff. $set, adding “date” the (( )) etc.
So I used


per your information and it worked…

When I used $unset(compilation) and others, for example, I didn’t have to do any extra stuff to it, so I figured the above would work the same, hence my confusion. I was trying to use $year(date,date_order=“ymd”) for example and it wouldn’t work.

You gave me what I needed… Thank you. :slight_smile: :yum:

1 Like