Showing tags in Windows Explorer?


#1

I’m using Windows 7 and rechecking my “sorted” folder, which is full of MP3s that were already renamed with Picard/Musicbrainz (changing things like “featuring”, which is now added to the artist instead of the title). I noticed that changes are made in the tags inside my MP3s, but in Windows Explorer (with the folder optimized for “music” view), tags like interpreter, title number and others are still shown as empty.

I do have a bunch of MP3s that show these tags in Windows Explorer and I’m sure I added them with Picard back then. So why doesn’t it work now?

I checked that my files aren’t write protected, “Save tags to files” is enabled in the Picard options, ID3v2 version is set to 2.3, but it still won’t add these tags when saving. How can I get these tags show in Windows Explorer?


#2

Are any of the tags displaying?

Are you adding extra columns? If so, which columns?

The tag display built into the OS is a bit basic.


#3

I actually don’t know exactly how this behaves in Win 7, but the Windows Explorer used to prefer ID3v1 tag for display if available. Removing the ID3v1 tags from the files would then help.

But actually when you use Picard it will, depending on the settings, either write the ID3v1 tags or remove existing v1 tags completely, so not sure how it would happen that they are out of sync.


#4

What are these? Can you give us a screenshot of the details view of explorer. I think you may be selecting fields that don’t actually have tags associated.

Also - what happens if you Right Click one of those MP3 files and look at the Properties? The Details tab will show you what Windows thinks your MP3 tags are.

Now compare that with what the tags REALLY are in the file. Load the same track into Picard and look at the lower left panel. That shows you which tags Picard thinks your file has.


#5

Here’s an example after I rechecked and renamed the folder. Don’t ask me why one track shows the tags correctly in Explorer. None of the files are write-protected, so I don’t know why it worked for one but not the others. For me it looks like the fields in Explorer correspond to the ones in Picard? (yes, that’s a German Windows 7)


#6

TL:DR - turn on the ID3v1 support.

Full details…
Now I see what you meant by “title number”. Just a translation thing. I have used screenshots below from a GB version of Win7. This will make it easier to line up the different languages.

I was tagging with Picard on one of my Win7 PCs at the weekend. For the tags in MP3 files I have Picard set as follows:

image

That is giving me Win7 details as follows:

File details:

I also use UTF-16 on another Win7 PC and that doesn’t seem to make any difference.

Now please look carefully at that folder I have in the second image. Look at track two. Both the “TITLE” and “CONTRIBUTING ARTISTS” are truncated. The band is “Carter the Unstoppable Sex Machine” and not “Carter the Unstoppable Sex Mac”.

So that is showing that Windows 7 is relying on the ancient and basic ID3v1 tags. So make sure the last tick box on the metadata options page is ticked.

Please also compare with a Win10 image of the same thing. Here you can see the FULL track names of track 2 and the full band name. That implies to me they have probably upgraded to ID3v2

And one last thing… I can explain the “oddity” in your example album. Install MP3TAG www.mp3tag.de and you will find that it can show you which type of tags you have in your files. I bet that your track 2 has both ID3v1 and ID3v2 tags with all your other tracks just having ID3v2 tags.

(Little tip. In Win7 and above there is a program called “Snipping Tool”. Ideal for taking shots of bits of the screen. They can then be pasted DIRECTLY into this forum without needing to Save to File. A very handy trick)


#7

I have exactly the same settings in the options, except that I had ID3v2 Version set to 2.3 and encoding to UTF-16. ID3v1 tags has always been ticked.

I now switched to 2.4 and UTF-8, tried to rename the tracks, but Explorer still won’t show the tags. The only other thing I can think of are my two accounts on my system, admin and user. But I’ve been using Picard with my user account ever since and renaming the files as well as moving them into different folders works, so there can’t be anything wrong with the user permissions.

Edit: I unticked ID3v1, renamed/saved these tracks and the tags on the one track disappeared now too. I then ticked ID3v1 again, renamed/saved everything again and the tags were back on that one track, but still no success with the others. It’s like that one track has some “spare space” to save the tags into the file, but the others don’t?


#8

It’s been a while since I made use of it myself, but perhaps you find this useful?:
https://www.softpointer.com/AudioShell.htm


#9

This could indicate that sometimes the ID3v1 tags saved by Picard are incompatible with Explorer (without knowing who is at fault). But from the screenshot I cannot say what makes the tags of the one file that works different from the rest.


#10

@hiccup AudioShell looks useful. I prefer to use the freeware MP3TAG from the Right Click menu.

@CaptainKebab have you tried MP3TAG? That will show if one file is being weird at holding MP3 tags.

I have certainly seen Windows mess the tag visuals up a lot. Often see one file not showing tags. I generally just turn them off as I also find it too slow to appear in big folders. I turn on the status bar instead. Though in your case I guess it will show the same issue as your properties are blank.

Are you also sure the files are not corrupted? Did you rip these yourself?

@outsidecontext my example files were tagged with Picard v1.4.2 so I don’t think this is specifically a Picard issue.


#11

Audioshell is also freeware.
But the reason I brought it up is that I thought to remember that it kind of integrated itself into Windows, so Explorer would get extended capabilities in viewing/editing audio files.
But after having done a quick test just now I don’t believe it does that.
So forget about it, it’s not a solution to the OP’s issue.


#12

I may well have misunderstood the problem, but I noted that Picard is set to tag with ID3v2.4 - Windows Explorer in Windows 7 doesn’t support v2.4. Could this be part of the problem?


#13

I did a Google search, I found solutions like using the “sfc” command (didn’t work), adding registry values (already had them), installing extra software (no thanks)…

One was to use MP3Val, a tool (no installation required, can simply be unzipped) that checks for errors in MP3 files. I tested it with one file and it indeed fixed the problem. Explorer now shows the tags. They even still display after I rename/save the fixed file with Picard again. Huge downside: it creates a backup file of every MP3 that was repaired. In my case, if I let it fix my “sorted” folder, I’ll be left with hundreds of backup files. Furthermore, the fixed file has a slightly different file size from the orginal, not sure if only garbage was removed or also something in the audio quality was changed.


#14

According to the Mp3val documentation you can use the commandline option:
-nb

Delete .bak files that were created during file rebuilding. Use this option together with -f.

There are also options to keep file timestamps (-t).

Small addition to your

from the same documentation:

MP3val neither decodes audio data nor checks for data validity in the frame.


#15

@CaptainKebab MP3Val is very good. And this certainly sounded like corrupted files. I had that happen once with an external hard disk of P2P files a mate gave me. Clearly a lot of tracks on that hard disk were bad rips and incomplete downloads.

If you have loads of *.bak files in your folders windows makes it VERY easy to delete them all even from the GUI.

Go to the top level of your Music folder. Now use the search box at top right of the explorer window and type in *.bak. Windows search makes you a list up of all the *.bak files. Just hit CTRL+A to Select All Files. Then press the delete key. All done in one hit.

image

Also command line: CD to your music folder and type

cd d:\MusicFolder\
del *.bak /S /Q 

That will delete all files ending in .bak. The /S goes into all sub folders. The /Q doesn’t keep asking you to confirm everything. (Do I need to say "backup " before you start this?)