Setting value separator

artist
picard
tagging
Tags: #<Tag:0x00007f23c59e7b78> #<Tag:0x00007f23c59e78a8> #<Tag:0x00007f23c59e75d8>

#1

I cannot believe that I am the only one to ask this question, but I’ve searched and read this forum and hit up google finding no solution.

How in the world can you force Picard to use a specific character as the separator/joiner for multiple value tags… Artist specifically.

I see you can define it for folksonomy, but that seems to only apply to genre.

If the MusicBrainz entry has the Artist field as

“Artist So and So feat. This Guy, Another Person and One More Person”

I’d the tags to be written as

“Artist So and So; This Guy; Another Person; One More Person.”

I’ve been manually doing this, which is fine, but every time I reintroduce an album to Picard, it is no longer a perfect album due to my Artist tag differing.

A script for padded discnumber and tracknumber prevents Picard from flagging a track/album as incorrect when it pad either with a leading zero. I’d love to operate the same way for Artist


#2

The tag %artists% displays the artists the way you want. So you could use %artists% in your music player instead of %artist%, and if your music player isn’t that flexible, you can use the tagger script $set(artist,%artists%) under Options > Scripting.


#3

The latter is exactly what I was looking for! 1,000,000 Thanks!

A virgin album in Picard will now separate the names in artist with a semi-colon.

Albums in which I manually separated artist, Picard no longer suggests “reverting” back to artist feat. artist2, artist3, so it appears as a perfect album in Picard.

Again… Thank you!