Scan option Not Working on Most Files


#1

While in Picard scan was working fine but has stopped. This has started on most files.
I ripped some files from a cd. All I get is Track1 Track2 and so on. When I scan these files it should rename then to the Artist and Title but they will not scan or lookup. They remain Track1 Track2. IMO, I think MusicBrainz.org is having some downtime or just snoozing on some scans. To get it to work I have to manually put in the Artist and Title to get scan to wake-up. Should not have to do that especially if you have over 14 GB tracks to do.


#2

To find the tracks using scan:

  1. The release has to be in MusicBrainz.
  2. The recordings on that release have to have AcoustID fingerprints attached to them.

If #1 isn’t true, then you won’t be able to tag them with Picard until someone (probably you) adds the release to the database.
If #1 is true, but #2 isn’t, the best way to find it is to use something like Mp3tag to fill in the artist and album name, then use lookup. If you’re going to rip CDs in the future, it’s best to use a MusicBrainz aware ripper like Foobar or MusicBee.

Probably not what you wanted to hear, but there it is.


#3

I do use MusicBee and it still dose it. Must be a Windows 10 issue.


#4

From you description it is not quite clear what you are doing and what is happening. “Lookup” will obviously not work well when you have no existing artist and title tags (or the title is just “Track1”).

When you click “Scan” what happens? Does Picard start loading an album in the right pane? If yes, does it give an error or does it just not finish loading?

If “Scan” does not load an album, does at least show the AcoustId in the metadata (see How to determine if Scan function is working)?

If it does show the AcoustId “Scan” is working but the AcoustId is not yet linked to any MusicBrainz recording. In this case you have to fallback to any other method of loading an album into Picard (e.g. using “Lookup” or if this does not work manual search) and assign the tracks. Afterwards you can submit the matches so the AcoustIds get properly linked to the recordings. Just make sure you have selected the proper recording.


#5

Does the release exist in MusicBrainz?


#6

When I hit scan some of the files get the info and new name and tags while some just stay the Track#
I ripped tracks from a Dierks Bentley Black CD it rips them as Track1, 2 and so on.
When I scan them in Picard some will get the new name as what it printed on the CD while some will be
left alone and scan ignores them leaving them as track6 or track9. The ripped dose not add the names
to the mp3s that is why I use Picard to get them. This is the clearest I can tell you to my understanding.
This CD has been out for a few years so it’s acoustic fingerprints should be already up on MB. If other music
ID sites like Amazon or Shazam can find it can’t see why MB can’t. IMO, somethings not right with Picard. That same CD worked before all the tracks got tagged and named. What changed?


#7

Only if somebody submitted it. Which release is it?


#8

Where will I find that on the CD box? BTW, I do not have good eye site to read labels anymore without having someone else read it for me. I bought the CD when it came out in 2016
Also my Picard Version is 2.0.4


#9

Sorry, I meant not the label but the album, and I totally missed you had given this before. So the example was

Actually there are AcoustIds for the recordings, e.g. https://musicbrainz.org/recording/a22b61b8-0c94-426d-9b94-b916803492ad/fingerprints , but it might still be your files generate different AcoustIds.

So a couple of things to check:

  1. For one of the tracks that are not recognized, let’s take track6, please have a look if there is an AcoustId in the tag list at the bottom. If so, which one? See this image for an example:

  2. If there is no AcoustId generated at all maybe indeed something did go wrong. Maybe there is something broken with the file itself. Does it playback without problems?

Regardless of the above, it always can happen that a file is not recognized. You also write it correctly finds other files from the same release, so this indicates your setup is working in general.

If a single file is not found but the release is loaded into the right pane you can always just drag and drop the file onto the correct track in the right pane. Afterwards you will even be able to submit the new AcoustId with the “Submit AcoustIds” button.

If the release is not loaded into the right pane you have to manually load it first. See the following script for details:


#10

That is the CD, When I ripped it after I got the CD, MBP named and tagged them with no issues.
I had to re rip the CD because I lost all my files when a Microsoft Update messed up Window 10 and I
had to get the OS reinstalled again from scratch at the store I bought it from and everything was wiped.
That is why I mentioned below may be a Windows 10 issues. If there was a way I can send you a test mp3
I’m having issues with I would.


#11

I sent you a PM / e-mail via your editor’s profile


#12

Where do I find the message? I don’t know how to access the inbox on this site.


#13

You should get it on whatever email you used for your account on MusicBrainz itself.


#14

It has been sent to you. good lick with it.


#15

Thanks. I gave this a test run, but I could not reproduce the issue. I tried on Windows 10 with both the current Picard 2.0.4 and even the older 1.4.2 and 1.3 versions (always a fresh install with default settings), also on Linux with latest Picard. In all cases the file was identified with the “Scan” button as shown below.

Also interesting is that this recording has three AcoustIds attached, but this specific file gets https://acoustid.org/track/f4eb927e-635f-4d21-9076-a2f54316ee11 which is the most popular AcoustId for this track.

Last thing to check (and I should have asked earlier): After you click the “Scan” button for this file, is there any error output in “Help” > “Show Error/Debug Log”?

Edit: And you are using Picard 2.0.4?


#16

When I hit scan it dose nothing. same thing with when I hit Lookup. Error log empty. Yes i have Picard 2.0.4


#17

Can you please do the following:

  1. Start Picard
  2. In Help > View Error/Debug Log select “Debug” in the “Verbosity” dropdown at the bottom left
  3. Load only this single file into Picard, select it and press scan
  4. Copy and paste the entire output of the log view here

Hopefully this gives us some clues.


#18

I just re ripped the CD again to see if that was the issue. I uninstalled MB Picard and did a clean reinstall of Picard 2.0.4. Tested the new ripped CD tracks. First scan did find only 8 of them. scanned again did not find the remaining ones. clicked options to change stuff and found in fingerprinting and option an API Key
got the key from https://acoustid.org/login?return_url=https%3A%2F%2Facoustid.org%2Fapi-key and did
another scan on the files. Nailed it. I don’t know if it was one of the settings I changed or the API that did the trick.


#19

BTW, Before I uninstalled Picard I did the log file thing you wanted and saved the log file. Here it is.

D: 19:04:27,050 ui.itemviews.dropMimeData:519: Drop target = None
D: 19:04:27,055 ui.itemviews.drop_urls:482: Dropped the URL: ‘file:///C:/Users/Donna/Documents/Music/Old School/10-Track 10.mp3’
D: 19:04:27,059 tagger.add_files:380: Adding files [<File ‘10-Track 10.mp3’>]
D: 19:04:27,062 file._move:461: Moving <File ‘10-Track 10.mp3’> from None to <Cluster ‘Unclustered Files’>
D: 19:04:27,068 formats.id3._load:191: Loading file ‘C:\Users\Donna\Documents\Music\Old School\10-Track 10.mp3’
D: 19:04:27,085 coverart.image.init:65: Saving image data aee48f7b831b3e6e6c8e604bc9a1013e to ‘C:\Users\Donna\AppData\Local\Temp\picard8b5goh4w.jpg’
D: 19:04:27,091 file.update:500: Updating file <File ‘10-Track 10.mp3’>
D: 19:04:39,851 file.update:500: Updating file <File ‘10-Track 10.mp3’>
D: 19:04:39,859 acoustid._run_next_task:199: Starting fingerprint calculator ‘C:\Program Files\MusicBrainz Picard\fpcalc.exe’ ‘C:\Users\Donna\Documents\Music\Old School\10-Track 10.mp3’
D: 19:04:40,267 acoustid._lookup_fingerprint:120: AcoustID: looking up the fingerprint for file ‘C:\Users\Donna\Documents\Music\Old School\10-Track 10.mp3’
D: 19:04:40,269 webservice.post:445: POST-DATA ‘meta=recordings%20releasegroups%20releases%20tracks%20compress&fingerprint=AQADtImSbVEUKZGg5UeeJNmCi07x5MV05pgSHVGbEyq3qAW7kiHCMBemH-eJS7JwcjmeicK_4NlRCvGhnckY5D-eBc-Cn8gfPEfS3Fkw2RKFS0WzD3yOn8FfpCRPqDrioOmP_mCPZGGU7AjJo_le9ImCKXWmomqC60a1C82NF6cGPzmuKPgp_DMarkNIKSuS9sf3YXzwD9-LZsrRZkkJ9hTuYnoQpnjELcKZD2HYHOEV5EkSBp84_JKQXgmSF09sjOEGrkmSwv_w42gY5UGyS8Yu-MdOF-qXwoqUPEW8Hd_y4uwRehceuYNgJ0uIEA9_fCpRkpXgHL2My_g55GN0cL8OzZKOeEqWHJ-Ie0mFPtHxTmi5w3XwaY1w8XiM6vgzNBGVpOgPOkIyKjly4nmI7a3Q4yeeXcjFjXgPRyeejMJPQh_K6hHM6cF3eEdFZRnxHPnEGP3RhD7OZ7g83MF_JFmTFLGk4MT7JfAzFjejDj_yxEiO7cSjOMgbCtWFh0XLI5eY4hnOD82Xo2Oy4_rwInEYIkcln3C1JJKC7TuuornEFDsz4UG84oeWy0e3SXhU4t_wKy3uo9FlaE-ER-iX4_lC3Av8LJiORyFOpQHD7XAdiOOC8KmO98LJ4fqCH5O9wT_KH-OKXDJe_NCLxgdHHc_hE1dypJcjjLUD_ztyKsOhijm-Br-CZswSEcePkz5KDyKXo88ePFJ6_HhwHuaL_8GZ2diNXkuhw7vQLktQHVLi6DvkH48sDT_CMD-qH20c48fJHueSItzV4X0g7ZLx5dhzPMnRHO1SQ9eHNzmeDW90XEp6VD78DFrjQ-ePB_cDf-mQo9fRPMazHBdpPPkRuxX0dEQfpBeNPnrw5DiLmDvUnAhfNL2KkuiDWx2-B_eFhzyao_KRS1mgj0J4xXCNUM7RqEdlHM1ftLfQ5w1O-Kge3MrQHVp-HPFHHP3hUSvOo2Q-9PqQkg-0p0d-osT747sSNDJxHXcO4yb2PHieIiSh5UfG9viDS3rxJDrI6yjzoomDk5kw5E-QtNGHRpGWo1rxLgWOWkeeXMLzNBCj9-hxLvg_IT9-HLdxwmMWPDtyQ7viIH1QxT_ihgkxJ9CfI9qJ-8Jn40wSBc1-hIe6D_kUFk20PKhvITzEXQpqHfGkLEfXo8lFhO0HLUeOajushxHq7cKPS8iPJouyEH0EPcUf4Y-R87iC9xJqBT-ewjiDXA9EhyLRj0e7w0luqE8j5K7RR8cv_Ie3Gk-e4LVwE2kJHfkrXDmeo2pF4coSZ7jwoVmPN8UlYwsTSQ1-dHlKNMvwS8gVE26aCaozfNByaD8iyw_e9Gjt4SkNr8O1B28FPzvCv0jQF1cvmMoTPMd_dEyKH6icC_kT6BzSkcaHnsc1xcI3KRYu5WhUoiRzXEp6JJPuIUzF4M7xHE32FfWPL1HwLA9O_HhJOM5i_Mh19IGWZ8fR60UYHn_wTCJ8fD-uo8kWdDy-o7l2lI-Faxb6KcKjECVD1C_hvEXIQ06OX8ElJRQe5JGV4xeF8DkaZzqOX2iUhjta5fgfNLaM92hq_Mgvo8-FRjvu4sEf_MOVpEpxHz_CU0OyPMLxC-9V_MP0H8d_lP3wobcShHkCdZOOP0ZzBtqRKzM-bkGYaDmmNTtOBzpyXB2eTMnQPOgpVHssNDqPkXUQ6YWWR4mQ4zhCqRPR7JBN40deIY-k44JOFz3C8DheHN05vDtm7fCZHD_8oCRCyocWb8cXKTmydnB_4T1yHX9iSAmHSsx4xMmDH9dyZTgRPoWWI87EHa-W45GJ-Q-aK8zQJ5mNC5XWIUyiHXqnI_xSNA6P47RQMleMKu2K_0bD7OiPWwoaNajG4Tf6Cb6E8IOujEJuRfiOM0N9I4zTGY8OXZOV4Fs84RGhdjLywzfyvniOH1rS7EG4kE5QbQmaOMfxr3gYB8nEcUIYXjgeVhR-xKQHNa_gTUqG_MdxhM9y-Cx8Hc9iIrcO_8c5-Kh0pziPX0LyB7EYcbiUKcRzlHGCJmLSI7_wHbKnZrhOaFmGvsIpY8elMMezK9AjpF_w41m0bGDS_uiTIzl75ExAZ8cuXDweT9KDWqXRfBmO_Dhl_Eo2Qc1xtD-ucPAWhPqJ5_iJo_nUoEOu4xCfDueHX2jkoTqL5oX2fcIRZi9x5sV3_KiIEz7xUSfyVNj1DJrtCNYxMUdsGk9Qy0KzKCHy4D-qdMnQOIkKPcEPnU7R_OgPNZuS43dx5nju5Aie4EeYhFNGoz9uHDemvI3wHJEe5cITC_Pxa7ilCY37IpKVQ_h53EmOT1qDM72gM8edQD9CHr7CoHJ2vLvw3_jhKPmR54E8JQ_y44qMPruxTULHG5eEX-AzsMdv4ZSOK4vw8viF60K4G012FvqxK0d-fWh8oz-eEA33oVJHPFPy4HFw_Miz7IFOI_zxbIfzoc9wKQ–F0_O4Ed1TYF1hBbx6HgO3YmF_EEfDg0_XDl25UWjcsKfCgmfB-GPe8SVHF8unMxCCtRTnNmR5yKSdzlI77h3CT8ipc4L7Qgpr7jyGJ8uOI529PuRmxu0LE8REueO_EITPYVW9fgvnOgPrfSCnBSq0GiyHdeO5jPR48qRCzo7osmiGFX4CLWPXPgpXD0uHT9-tBMuHRdG58LPYM-RjszwBneNSkezHE8Gx8yDTzmhXnEQPkczPE5RkoedFO6FXjNCOVLhpNKhUcMvIW-xV5nQvAh5FdJV9JKG5kR1CY1-XDx0ZkYY3gCgGDKIIGYcUQYRBQAABEMAiGCKGQAVBEQIhwhRQAEFsBQGEIGMQowByRwgAhihpBMQOAEUIoQYIYCSgACFICmCKSAAMYQQQYwRAFmBiCAAACKAAAIwRBCkXhDDmGIEKCYAVAAhAYAighhKGABIOAAMEAoMAACyhltnhEBCJAEEItZ4QoAhhikFBDNSAAQAMIIwAIBgSAhghCVGQQGYkMIRwhgFAEEEgACSQiCNQEQgQIRiiBGFgCBEAK8MAMIoQYADQFEACCDIOAYUMhQhxBhgAiikADEeASGGJIwBAQBSQAAmCHJMGQKAMAIpKLghAgIjBCGEEAiYsZQYJpQwRAECACIIMECIEMYopIwFSCAAgCCGGUBIQ4AAQbQAAgnNFFmeCWmIEUAgBpAAgBgCEFFEMUkMQowohkAgQEDBCKEIEGCoMYYgIBBCABoAhFAAOAAQIQ4x46hDgglmMDgCAAEYYAAYIQAhwkAAGCNCCCgYAUQoQQQgwiChjAIIeGGUUEAAKZBSiCoEAAEACKIAUwQoAQFFTBAihAKACWGIAIQYooQwDjADiGLEOCeQAVIQ4oQgJiCjgDEAIaCMoQKgR4wkACggiFYEWEqcI0IwEAhRBCADgBIAAaSIUMwQgZwBSCECjBGACCQAIwAkAQgxCgFCGEBEGESAUwAII5UwRCFBHBlQAceIIQgJ0AUDADEJgBDGC2IEEIA5QBBCChCFCEHEeAQMAEQAADSBAAEgEKIIAEcAQAYIpwgIDDLEABQAEEAGA8gwAwEBgggwwQdCAOKQEEYCIAghADBABPOKAgcAIZ4BJCwRAgABBBIUGUOAAEAgIoFBBkAChUDACcINIAQBIgBRBiAqFAEECaYUEBCRIAQQDhBGECGQAGcQQ9QJQIEABAkDDECCEuCcEIgAooAQAFAgAADCACCAAYAAKQgxhjCjALECM-MAUZ4SBAxjAFnHIBAIIKEEU0AAJ4gRzAiDkMFKCESIYAAI&duration=333&client=v8pQ6oyB&clientversion=2.0.4.final0&format=json’
D: 19:04:40,279 webservice.ratecontrol.get_delay_to_next_request:114: (‘api.acoustid.org’, 80): Last request was 1460752 ms ago, starting another one
D: 19:04:40,282 webservice.ratecontrol.increment_requests:134: (‘api.acoustid.org’, 80): Incrementing requests to: 1
D: 19:04:40,622 webservice.ratecontrol.decrement_requests:142: (‘api.acoustid.org’, 80): Decrementing requests to: 0
D: 19:04:40,624 webservice._handle_reply:400: Received reply for http://api.acoustid.org:80/v2/lookup: HTTP 200 (OK)
D: 19:04:40,625 ui.mainwindow.set_statusbar_message:283: No matching tracks for file ‘C:\Users\Donna\Documents\Music\Old School\10-Track 10.mp3’
D: 19:04:40,626 file.update:500: Updating file <File ‘10-Track 10.mp3’>
D: 19:04:40,628 webservice.ratecontrol._out_of_backoff:225: (‘api.acoustid.org’, 80): oobackoff; delay: 333ms -> 333ms; slow start; window size 3.000 -> 4.000